- update to 5.59
- remove no longer required post-patch target, shifted into release - fix options that fail to build - enable by default options that were unconditionally enabled before the latest change - option-specific dependencies should only be pulled in when the option is turned on (e.g. change USE_XORG=xinerama to XINERAMA_USE= xorg=xinerama) - use preferred options helpers (e.g. change MESAGL_CONFIGURE_OFF=--without-opengl --without-ftgl to MESAGL_CONFIGURE_WITH= mesa opengl ftgl - sort variables according to the 'Order of Variables in Port Makefiles' chapter in the Porter's Handbook - add missing library dependencies - add missing tab after = - ?= -> = Submitted by: jrm@ Reviewed by: jgh@ Differential Revision: https://reviews.freebsd.org/D21556
This commit is contained in:
parent
ebf97e4ba1
commit
64bde4a115
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=513774
3 changed files with 38 additions and 72 deletions
|
@ -2,9 +2,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xlockmore
|
||||
PORTVERSION= 5.58
|
||||
PORTREVISION= 1
|
||||
CATEGORIES?= x11
|
||||
PORTVERSION= 5.59
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://www.sillycycle.com/xlock/ \
|
||||
SF/bsdsrc/${.CURDIR:T}
|
||||
|
||||
|
@ -13,23 +12,24 @@ COMMENT= Like XLock session locker/screen saver, but just more
|
|||
|
||||
LICENSE= BSD2CLAUSE
|
||||
|
||||
USES= tar:xz gnome xorg
|
||||
LIB_DEPENDS= libfreetype.so:print/freetype2
|
||||
|
||||
USES= tar:xz xorg
|
||||
USE_XORG= ice sm x11 xaw xext xpm
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
PORTDOCS= README ${PORTNAME}.README
|
||||
CONFIGURE_ARGS= --without-motif --without-ttf --without-editres \
|
||||
--without-dtsaver --without-rplay --without-nas \
|
||||
--without-gtk --without-esound --disable-setuid
|
||||
|
||||
USE_XORG= x11 xaw ice sm xpm xext xinerama
|
||||
|
||||
LIB_DEPENDS+= libfreetype.so:print/freetype2 \
|
||||
libpng.so:graphics/png
|
||||
--without-gtk --without-esound --disable-setuid \
|
||||
--disable-kerberos4
|
||||
GNU_CONFIGURE= yes
|
||||
PORTDOCS= README ${PORTNAME}.README
|
||||
|
||||
OPTIONS_DEFINE= MESAGL MB SYSLOG DISABLE_ALLOW_ROOT NICE_ONLY BLANK_ONLY \
|
||||
KERBEROS5 BAD_PAM GTK2 TIME_BOMB CUSTOMIZATION MAGICK JP \
|
||||
XINERAMA DOCS
|
||||
OPTIONS_DEFAULT= XINERAMA
|
||||
OPTIONS_RADIO= ONE
|
||||
OPTIONS_RADIO_ONE= PAM XLOCK_GROUP
|
||||
OPTIONS_DEFAULT= MB XINERAMA
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
MESAGL_DESC= Mesa 3D (for GL modes)
|
||||
|
@ -45,43 +45,46 @@ TIME_BOMB_DESC= Allow autologout
|
|||
CUSTOMIZATION_DESC= Allow tune through resource file
|
||||
JP_DESC= Japanese Language Support
|
||||
|
||||
OPTIONS_RADIO= ONE
|
||||
OPTIONS_RADIO_ONE= PAM XLOCK_GROUP
|
||||
|
||||
NO_OPTIONS_SORT=yes
|
||||
|
||||
JP_IMPLIES= MB
|
||||
NO_OPTIONS_SORT= yes
|
||||
|
||||
MAKE_ARGS+= bindir=${PREFIX}/bin \
|
||||
mandir=${PREFIX}/man/man1 \
|
||||
datarootdir=${PREFIX}/share \
|
||||
xapploaddir=${PREFIX}/lib/X11/app-defaults
|
||||
|
||||
MESAGL_CONFIGURE_WITH= mesa
|
||||
MESAGL_VARS= CFLAGS+="-I${LOCALBASE}/include/FTGL -I${LOCALBASE}/include/freetype2" USE_GL=yes
|
||||
MESAGL_LIB_DEPENDS= libftgl.so:graphics/ftgl
|
||||
MESAGL_CONFIGURE_ENV= XLOCKLIBS="-lpthread"
|
||||
MESAGL_CONFIGURE_OFF= --without-opengl --without-ftgl
|
||||
KERBEROS5_CFLAGS= ${GSSAPICPPFLAGS}
|
||||
KERBEROS5_CONFIGURE_ENV= XLOCKLIBS="${GSSAPILDFLAGS} ${GSSAPILIBS} -lcom_err"
|
||||
KERBEROS5_CONFIGURE_ENABLE= kerberos5
|
||||
KERBEROS5_VARS= CFLAGS+=-I${KRB5_HOME}/include KRB5LIB=-L${KRB5_HOME}/lib
|
||||
KERBEROS5_CONFIGURE_ENV= XLOCKLIBS="${KRB5LIB}"
|
||||
KERBEROS5_USES= gssapi:mit
|
||||
MESAGL_CFLAGS= -I${LOCALBASE}/include/FTGL
|
||||
MESAGL_CONFIGURE_ENV= XLOCKLIBS+="-lpthread"
|
||||
MESAGL_CONFIGURE_WITH= mesa opengl ftgl
|
||||
MESAGL_LIB_DEPENDS= libftgl.so:graphics/ftgl
|
||||
MESAGL_USES= gl
|
||||
MESAGL_USE= gl=gl,glu
|
||||
BAD_PAM_CONFIGURE_ENABLE= bad-pam
|
||||
PAM_CONFIGURE_ENABLE= pam
|
||||
NICE_ONLY_CONFIGURE_ENABLE= nice-only
|
||||
BLANK_ONLY_CONFIGURE_ENABLE= blank-only
|
||||
MB_CONFIGURE_ON= --enable-use-mb
|
||||
MB_CONFIGURE_OFF= --disable-mb
|
||||
MB_CONFIGURE_ENABLE= mb
|
||||
SYSLOG_CONFIGURE_ENABLE= syslog
|
||||
XINERAMA_CONFIGURE_WITH= xinerama
|
||||
XINERAMA_USE= xorg=xinerama
|
||||
DISABLE_ALLOW_ROOT_CONFIGURE_ON= --disable-allow-root
|
||||
XLOCK_GROUP_CONFIGURE_ENABLE= xlock-group
|
||||
TIME_BOMB_CONFIGURE_ENABLE= bomb
|
||||
CUSTOMIZATION_CONFIGURE_ENABLE= customization
|
||||
JP_VARS= XLOCKMORE_LANG=ja CATEGORIES+=japanese
|
||||
MAGICK_CONFIGURE_OFF= --without-magick
|
||||
MAGICK_LIB_DEPENDS= libMagickCore-6.so:graphics/ImageMagick6
|
||||
JP_IMPLIES= MB
|
||||
JP_CATEGORIES= japanese
|
||||
JP_VARS= XLOCKMORE_LANG=ja
|
||||
MAGICK_CONFIGURE_WITH= magick
|
||||
MAGICK_LIB_DEPENDS= libMagickCore-6.so:graphics/ImageMagick6 \
|
||||
libpng16.so:graphics/png
|
||||
GTK2_CONFIGURE_WITH= gtk2
|
||||
GTK2_VARS+= USE_GNOME+=gtk20
|
||||
GTK2_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
|
||||
libpng16.so:graphics/png
|
||||
GTK2_USE= gnome=cairo,gdkpixbuf2,gtk20
|
||||
GTK2_USES= gnome pkgconfig
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
|
@ -89,10 +92,6 @@ GTK2_VARS+= USE_GNOME+=gtk20
|
|||
CONFIGURE_ARGS+= --with-lang=${XLOCKMORE_LANG}
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MKERBEROS5} && empty(KRB5_HOME)
|
||||
BROKEN= KRB5_HOME is undefined!
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MPAM} && empty(PORT_OPTIONS:MBAD_PAM)
|
||||
pre-extract:
|
||||
@${ECHO}
|
||||
|
@ -102,9 +101,6 @@ pre-extract:
|
|||
@${ECHO}
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/xglockrc/ s|PROGRAM|DATA|' ${WRKSRC}/xglock/Makefile.in
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/docs/Revisions ${STAGEDIR}${DOCSDIR}/${PORTNAME}.README
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1567716907
|
||||
SHA256 (xlockmore-5.58.tar.xz) = fc9f81773afef0dc7e3e62defbad4056d8d16af9ba8208eeec73d1b2970e41ed
|
||||
SIZE (xlockmore-5.58.tar.xz) = 1878452
|
||||
TIMESTAMP = 1570202828
|
||||
SHA256 (xlockmore-5.59.tar.xz) = 2d2a6855ecdeee4856ace76acf615d3b2e48303951bb5fd31a234e4a54615251
|
||||
SIZE (xlockmore-5.59.tar.xz) = 1935296
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
--- xglock/xglock.c.orig 2017-01-06 05:18:57 UTC
|
||||
+++ xglock/xglock.c
|
||||
@@ -1,3 +1,27 @@
|
||||
+Assertion failed: (SE.DT.dominates(Ret, &*BIP)), function ReuseOrCreateCast, file /usr/src/contrib/llvm/lib/Analysis/ScalarEvolutionExpander.cpp, line 83.
|
||||
+cc: error: unable to execute command: Abort trap (core dumped)
|
||||
+cc: error: clang frontend command failed due to signal (use -v to see invocation)
|
||||
+
|
||||
+--- xglock/xglock.c.orig 2018-07-08 11:29:53 UTC
|
||||
++++ xglock/xglock.c
|
||||
+@@ -1489,7 +1489,7 @@ static void
|
||||
+ create_boolOptions_buttons(GtkScrolledWindow *parent)
|
||||
+ {
|
||||
+ gint i;
|
||||
+- gpointer iptr = 0;
|
||||
++ guint iptr = 0;
|
||||
+ GtkWidget *box0;
|
||||
+ GtkWidget *box1;
|
||||
+ GtkWidget *box2;
|
||||
+@@ -1514,7 +1514,7 @@ create_boolOptions_buttons(GtkScrolledWindow *parent)
|
||||
+ gtk_box_pack_start(GTK_BOX(i%2 ? box1 : box2), button, TRUE, TRUE, 0);
|
||||
+ gtk_signal_connect(GTK_OBJECT(button), "clicked",
|
||||
+ (GtkSignalFunc) bool_option_clicked_cb,
|
||||
+- iptr++);
|
||||
++ GUINT_TO_POINTER(iptr++));
|
||||
+ gtk_widget_show(button);
|
||||
+ }
|
||||
+ }
|
||||
/*-
|
||||
* xglock.c - main file for xglock, the GTK+ gui interface to xlock.
|
||||
*
|
Loading…
Reference in a new issue