- Update to 0.2.9

- Transfer maintainership to submitter

PR:		ports/64916
Submitted by:	Stefan Grundmann <sg-sendpr@waset.de>
Approved by:	old maintainer
This commit is contained in:
Pav Lucistnik 2004-03-31 13:52:13 +00:00
parent 5a2e431ad0
commit 652f66e6fa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=105771
3 changed files with 66 additions and 17 deletions

View file

@ -6,21 +6,25 @@
#
PORTNAME= osd
PORTVERSION= 0.2.6
PORTREVISION= 1
PORTVERSION= 0.2.9
CATEGORIES= misc python
MASTER_SITES= http://repose.cx/pyosd/ \
http://damien.kangaweb.com/moving/stuff/pyosd/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= pyosd-${PORTVERSION}
MAINTAINER= lars.eggert@gmx.net
MAINTAINER= sg-sendpr@waset.de
COMMENT= A python wrapper for osd, for displaying text on your X display
LIB_DEPENDS= xosd.4:${PORTSDIR}/misc/xosd
RUN_DEPENDS= ${LOCALBASE}/bin/twistd:${PORTSDIR}/devel/py-twisted
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_REINPLACE= yes
post-patch:
${REINPLACE_CMD} -e 's;_X11BASE_;${X11BASE};g' ${WRKSRC}/setup.py
post-extract:
${MV} ${WRKSRC}/pyosd ${WRKSRC}/osd

View file

@ -1,2 +1,2 @@
MD5 (pyosd-0.2.6.tar.gz) = 060df94f464f77f664446f59e62ca1a0
SIZE (pyosd-0.2.6.tar.gz) = 17894
MD5 (pyosd-0.2.9.tar.gz) = a5f0dbdd7516518a82538f20e1266fb9
SIZE (pyosd-0.2.9.tar.gz) = 19274

View file

@ -1,23 +1,68 @@
--- setup.py.orig Sat Nov 23 22:17:59 2002
+++ setup.py Sat Aug 9 10:11:17 2003
@@ -2,15 +2,16 @@
from distutils.core import setup, Extension
-setup (name = "pyosd",
+setup (name = "osd",
version = "0.2.6",
description = "Python wrapper for libosd",
--- setup.py.orig Mon Feb 23 05:43:05 2004
+++ setup.py Tue Mar 30 03:11:16 2004
@@ -8,9 +8,11 @@
url = "http://repose.cx/pyosd/",
author = "Damien Elmes",
author_email = "pyosd@repose.cx",
- packages = ['pyosd'],
+ include_dirs = ['/usr/X11R6/include'],
+ include_dirs = ['_X11BASE_/include'],
+ packages = ['osd'],
ext_modules = \
- [Extension("_pyosd", ["_pyosd.c"],
- libraries=["xosd"])]
+ [Extension("_osd", ["_pyosd.c"],
+ library_dirs = ['/usr/X11R6/lib'], libraries=["xosd"])]
+ libraries=["xosd"],
+ library_dirs = ['_X11BASE_/lib'])]
)
--- osd/__init__.py.orig Mon Mar 1 06:17:23 2004
+++ osd/__init__.py Tue Mar 30 03:11:16 2004
@@ -26,7 +26,7 @@
fonts or colours across the screen.
'''
-import _pyosd
+import _osd as _pyosd
import re
import string
@@ -44,7 +44,7 @@
error = _pyosd.error
-default_font="-*-helvetica-medium-r-normal-*-*-360-*-*-p-*-*-*"
+default_font="-*-helvetica-medium-r-normal-*-*-240-*-*-p-*-*-*"
class osd:
""" osd is a class used to create an object which can display messages on
--- osd/daemon.py.orig Mon Jan 26 02:14:01 2004
+++ osd/daemon.py Tue Mar 30 03:11:16 2004
@@ -37,8 +37,8 @@
"""
import os
-import pyosd
-import pyosd.daemon
+import osd as pyosd
+import osd.daemon
import sys
import string
--- _pyosd.c.orig Mon Mar 1 06:16:05 2004
+++ _pyosd.c Tue Mar 30 03:11:16 2004
@@ -73,13 +73,13 @@
};
void
-init_pyosd(void)
+init_osd(void)
{
PyObject *self;
PyObject *dict;
// create the module and add the functions
- self = Py_InitModule("_pyosd", pyosd_methods);
+ self = Py_InitModule("_osd", pyosd_methods);
// init custom exception
dict = PyModule_GetDict(self);