Add security/ipv6toolkit, a portable IPv6 security assessment suite.

WWW:	http://www.si6networks.com/research/tools.html
This commit is contained in:
Hiroki Sato 2012-07-16 18:36:15 +00:00
parent 2bb539e158
commit 6570992594
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=300968
8 changed files with 127 additions and 0 deletions

View file

@ -223,6 +223,7 @@
SUBDIR += ipfwcount
SUBDIR += ipguard
SUBDIR += ipsec-tools
SUBDIR += ipv6toolkit
SUBDIR += isakmpd
SUBDIR += isnprober
SUBDIR += its4

View file

@ -0,0 +1,35 @@
# Ports collection makefile for: ipv6toolkit
# Date created: Mon, July 16, 2012
# Whom: hrs
#
# $FreeBSD$
#
PORTNAME= ipv6toolkit
PORTVERSION= 1.2
CATEGORIES= security ipv6
MASTER_SITES= http://www.si6networks.com/research/
DISTNAME= ipv6-toolkit-v${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
COMMENT= A set of IPv6 security assessment tools
LICENSE= GPLv3
.if !defined(NOPORTDOCS)
MAKE_ENV= WITH_DOCS=
MAN1= scan6.1
.endif
PORTDOCS= README.TXT flow6-manual.pdf frag6-manual.pdf \
icmp6-manual.pdf jumbo6-manual.pdf na6-manual.pdf \
ni6-manual.pdf ns6-manual.pdf ra6-manual.pdf \
rd6-manual.pdf rs6-manual.pdf scan6-manual.pdf \
tcp6-manual.pdf
.if !defined(NOPORTDOCS)
post-install:
${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}
.endif
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (ipv6-toolkit-v1.2.tar.gz) = d8faa851221f2d4eda5f818d2669e897407cabb92ce2eabd80ffec781f19c738
SIZE (ipv6-toolkit-v1.2.tar.gz) = 1404587

View file

@ -0,0 +1,11 @@
--- /dev/null 2012-07-17 03:01:43.000000000 +0900
+++ Makefile 2012-07-17 03:02:23.000000000 +0900
@@ -0,0 +1,8 @@
+# $FreeBSD$
+
+SUBDIR= tools
+.if defined(WITH_DOCS)
+SUBDIR+= manuals
+.endif
+
+.include <bsd.subdir.mk>

View file

@ -0,0 +1,21 @@
--- /dev/null 2012-07-17 03:15:58.000000000 +0900
+++ manuals/Makefile 2012-07-17 03:16:10.000000000 +0900
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PREFIX?= /usr/local
+FILESDIR?= ${DESTDIR}${PREFIX}/share/doc/ipv6toolkit
+MANDIR?= ${DESTDIR}${PREFIX}/man/man
+
+FILES= flow6-manual.pdf frag6-manual.pdf icmp6-manual.pdf \
+ jumbo6-manual.pdf na6-manual.pdf ni6-manual.pdf \
+ ns6-manual.pdf ra6-manual.pdf rd6-manual.pdf rs6-manual.pdf \
+ scan6-manual.pdf tcp6-manual.pdf
+
+NO_MANCOMPRESS=
+MAN= scan6.1
+
+beforeinstall:
+ mkdir -p ${FILESDIR}
+
+.include <bsd.prog.mk>

View file

@ -0,0 +1,40 @@
--- /dev/null 2012-07-17 03:00:00.000000000 +0900
+++ tools/Makefile 2012-07-17 02:59:01.000000000 +0900
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PREFIX?= /usr/local
+BINDIR?= ${DESTDIR}${PREFIX}/bin
+CFLAGS+= -Wall
+
+PROG= flow6 frag6 icmp6 jumbo6 na6 ni6 ns6 ra6 rd6 rs6 scan6 tcp6
+
+.for P in ${PROG}
+PT:=${P}
+${P}.o: ${P}.c ${P}.h
+${P}: ${P}.o
+.if ${PT:Mflow6}
+ ${CC} ${CFLAGS} ${LDFLAGS} -o ${.TARGET} ${P}.o -lpcap -lm
+.elif ${PT:Mfrag6}
+ ${CC} ${CFLAGS} ${LDFLAGS} -o ${.TARGET} ${P}.o -lpcap -lm
+.else
+ ${CC} ${CFLAGS} ${LDFLAGS} -o ${.TARGET} ${P}.o -lpcap
+.endif
+CLEANFILES+= ${P} ${P}.o
+.endfor
+
+all: ${PROG}
+
+beforeinstall:
+ mkdir -p ${BINDIR}
+
+realinstall: _proginstall
+
+_proginstall:
+ ${INSTALL} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
+ ${_INSTALLFLAGS} ${PROG} ${DESTDIR}${BINDIR}
+
+.include <bsd.init.mk>
+.include <bsd.files.mk>
+.include <bsd.obj.mk>
+.include <bsd.sys.mk>

View file

@ -0,0 +1,4 @@
The IPv6 toolkit is a portable IPv6 security assessment suite produced
by Fernando Gont on behalf of the UK CPNI.
WWW: http://www.si6networks.com/research/tools.html

View file

@ -0,0 +1,13 @@
@comment $FreeBSD$
bin/flow6
bin/frag6
bin/icmp6
bin/jumbo6
bin/na6
bin/ni6
bin/ns6
bin/ra6
bin/rd6
bin/rs6
bin/scan6
bin/tcp6