SKK-like Kana-to-Kanji FrontEnd Processor
PR: ports/7576 Submitted by: Yusuke NAWANO <azuki@azkey.org>
This commit is contained in:
parent
0eb246d2a3
commit
6585eb7c1a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=14452
9 changed files with 135 additions and 0 deletions
32
japanese/skkfep/Makefile
Normal file
32
japanese/skkfep/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# New ports collection Makefile for: skkfep
|
||||
# Version required: 0.85
|
||||
# Date created: 22 Jul 1998
|
||||
# Whom: Yusuke Nawano <azuki@azkey.org>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= skkfep0.85
|
||||
PKGNAME= ja-skkfep-0.85
|
||||
CATEGORIES= japanese
|
||||
MASTER_SITES= ftp://ftp.azkey.org/pub/misc/skkfep/
|
||||
|
||||
PATCH_SITES= ftp://ftp.azkey.org/pub/misc/skkfep/
|
||||
PATCHFILES= skkfep111.diff.gz
|
||||
PATCH_DIST_STRIP= -p1
|
||||
|
||||
MAINTAINER= azuki@azkey.org
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/libexec/skkserv:${PORTSDIR}/japanese/skk
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
MAN1= skkfep.1
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/skkfep ${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/escmode ${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/resetsize ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/skkfep.1 ${PREFIX}/man/man1
|
||||
|
||||
.include <bsd.port.mk>
|
2
japanese/skkfep/distinfo
Normal file
2
japanese/skkfep/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (skkfep0.85.tar.gz) = 352fcc62f2d60d98b1d5e3b310ccfa77
|
||||
MD5 (skkfep111.diff.gz) = 4e044feb8df7bfad7dc6f1e267c66c5d
|
39
japanese/skkfep/files/patch-aa
Normal file
39
japanese/skkfep/files/patch-aa
Normal file
|
@ -0,0 +1,39 @@
|
|||
--- config.h.orig Sun Jul 26 21:14:43 1998
|
||||
+++ config.h Sun Jul 26 21:16:05 1998
|
||||
@@ -2,7 +2,7 @@
|
||||
* Configuration for SKKFEP
|
||||
*/
|
||||
|
||||
-#include "configs/sun.h"
|
||||
+#include "configs/freebsd.h"
|
||||
|
||||
#if makefile_parameter
|
||||
CC=gcc
|
||||
@@ -15,12 +15,12 @@
|
||||
#define REGMODE /* enable register mode feature */
|
||||
#define USE_SKKSRCH /* use skksrch.c instead of skkserv */
|
||||
#define USE_TRIANGLE /* use triangle mark like SKK */
|
||||
-#define SKKFEP_LIB /* use skkfep as library for SKK interface on jvim */
|
||||
+#undef SKKFEP_LIB /* use skkfep as library for SKK interface on jvim */
|
||||
|
||||
#define DEFAULT_KANAKEY "^j"
|
||||
|
||||
/* By Y. Kaneko */
|
||||
-/*#define KUTOUTEN /* "."->maru, ","->ten */
|
||||
+#define KUTOUTEN /* "."->maru, ","->ten */
|
||||
|
||||
#ifndef SKKFEP_LIB
|
||||
#define KANJIBS /* do/don't shuft-out BS code in JIS mode */
|
||||
@@ -43,10 +43,10 @@
|
||||
|
||||
#define NATIVECODE euc /* EUC Kanji code */
|
||||
|
||||
-#define SKK_SERVER_HOST "ei5nazha" /* SKK server host */
|
||||
+#define SKK_SERVER_HOST "localhost" /* SKK server host */
|
||||
|
||||
#ifdef USE_SKKSRCH
|
||||
-# define SKKSRCH_DIC "/usr/local/skk/lib/SKK-JISYO.L"
|
||||
+# define SKKSRCH_DIC "/usr/local/share/skkfep/SKK-JISYO.Li"
|
||||
# define BINARY_SEARCH /* do binary search in skksrch.c */
|
||||
# define USE_SERVER
|
||||
# define openSKKserv openSKKsrch
|
28
japanese/skkfep/files/patch-ab
Normal file
28
japanese/skkfep/files/patch-ab
Normal file
|
@ -0,0 +1,28 @@
|
|||
--- protoMakefile.orig Mon Jul 27 18:59:01 1998
|
||||
+++ protoMakefile Mon Jul 27 18:59:17 1998
|
||||
@@ -4,19 +4,19 @@
|
||||
SRCS=fep.c connsh.c readwrite.c terms.c stty.c keybind.c romkan.c etc.c\
|
||||
kkconv.c keymap.c version.c
|
||||
FEPLIBSRCS=keybind.c romkan.c kkconv.c keymap.c
|
||||
-#SKKSRCS=skklib.c connserv.c
|
||||
-SKKSRCS=skklib.c skksrch.c
|
||||
+SKKSRCS=skklib.c connserv.c
|
||||
+#SKKSRCS=skklib.c skksrch.c
|
||||
OBJS=fep.o connsh.o readwrite.o terms.o stty.o keybind.o romkan.o etc.o\
|
||||
kkconv.o keymap.o version.o
|
||||
FEPLIBOBJS=keybind.o romkan.o kkconv.o keymap.o
|
||||
-#SKKOBJS=skklib.o connserv.o
|
||||
-SKKOBJS=skklib.o skksrch.o
|
||||
+SKKOBJS=skklib.o connserv.o
|
||||
+#SKKOBJS=skklib.o skksrch.o
|
||||
SDICOBJS=simpledic.o
|
||||
SKKFEP=skkfep
|
||||
SKKFEPLIB=libskkfep.a
|
||||
|
||||
-all: jc $(SKKFEPLIB)
|
||||
-#all: jc $(SKKFEP)
|
||||
+#all: jc $(SKKFEPLIB)
|
||||
+all: jc $(SKKFEP)
|
||||
|
||||
romkan.c: romkan-org.c jc
|
||||
./jc -`./jc -c romkan-org.c`P romkan-org.c > romkan.c
|
9
japanese/skkfep/files/patch-ad
Normal file
9
japanese/skkfep/files/patch-ad
Normal file
|
@ -0,0 +1,9 @@
|
|||
--- configs/freebsd.h.orig Wed Jul 29 05:07:27 1998
|
||||
+++ configs/freebsd.h Wed Jul 29 05:07:47 1998
|
||||
@@ -12,5 +12,5 @@
|
||||
#include <libutil.h> /* for openpty() */
|
||||
|
||||
#if makefile_parameter
|
||||
-SYSLIBS=-lutil
|
||||
+SYSLIBS=-lutil -lxpg4
|
||||
#endif
|
17
japanese/skkfep/files/patch-ae
Normal file
17
japanese/skkfep/files/patch-ae
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- skkfep.1.old Wed Jul 29 04:09:11 1998
|
||||
+++ skkfep.1 Wed Jul 29 04:26:46 1998
|
||||
@@ -68,6 +68,14 @@
|
||||
With this option, ESC key becomes `RETUEN-TO-SKK-MODE' key.
|
||||
This option is useful for vi-users.
|
||||
.TP
|
||||
+.B -viesc
|
||||
+With this option, ESC + one of 'iaoIASR' key becomes `RETUEN-TO-SKK-MODE' key.
|
||||
+This option is useful for vi-users.
|
||||
+.TP
|
||||
+.B -emacsesc
|
||||
+With this option, ESC + any key becomes `RETUEN-TO-SKK-MODE' key.
|
||||
+This option is useful for emacs-users.
|
||||
+.TP
|
||||
.B -rs
|
||||
Reverse status line.
|
||||
.TP
|
1
japanese/skkfep/pkg-comment
Normal file
1
japanese/skkfep/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
SKK-like Kana-to-Kanji FrontEnd Processor
|
4
japanese/skkfep/pkg-descr
Normal file
4
japanese/skkfep/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
skkfep is a tool to input Kana and Kanji from the terminal.
|
||||
This also include some patches for Word registration.
|
||||
|
||||
-Yusuke NAWANO <azuki@azkey.org>
|
3
japanese/skkfep/pkg-plist
Normal file
3
japanese/skkfep/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/skkfep
|
||||
bin/escmode
|
||||
bin/resetsize
|
Loading…
Reference in a new issue