heyu is used to control X10 CM11A devices

PR:		15738
Submitted by:	Paul M. Lambert <plambert@plambert.net>
This commit is contained in:
Chris D. Faulhaber 2000-01-05 13:30:35 +00:00
parent d3a5d62363
commit 658aa84723
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24435
12 changed files with 172 additions and 0 deletions

35
misc/heyu/Makefile Normal file
View file

@ -0,0 +1,35 @@
# New ports collection makefile for: heyu
# Version required: 1.28f
# Date created: 27 December 1999
# Whom: plambert@plambert.net
#
# $FreeBSD$
#
DISTNAME= x10_heyu
PKGNAME= heyu-1.28f
CATEGORIES= misc
MASTER_SITES= http://www.prado.com/~dbs/
EXTRACT_SUFX= .tgz
MAINTAINER= plambert@plambert.net
ALL_TARGET= heyu
WRKSRC= ${WRKDIR}/heyu.dir
MAN1= heyu.1
MAN5= x10config.5 \
x10sched.5
do-configure:
${PERL} -pi.orig -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/Makefile
post-install:
strip ${PREFIX}/bin/heyu
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/examples/heyu
${INSTALL_DATA} ${WRKSRC}/x10config ${PREFIX}/share/examples/heyu
${INSTALL_DATA} ${WRKSRC}/x10sched.conf.sample ${PREFIX}/share/examples/heyu
.endif
.include <bsd.port.mk>

1
misc/heyu/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (x10_heyu.tgz) = f41c73b9665242ce5b9aba2b9a4f92e8

34
misc/heyu/files/patch-aa Normal file
View file

@ -0,0 +1,34 @@
--- Makefile.orig Tue Jan 4 23:10:44 2000
+++ Makefile Tue Jan 4 23:12:54 2000
@@ -3,7 +3,7 @@
BIN = /usr/local/bin
MAN = /usr/local/man/man1
MAN5 = /usr/local/man/man5
-GROUP = sys
+GROUP = wheel
OWNER = bin
@@ -13,19 +13,19 @@
# -DVOID if compiler doesn't understand 'void'
# -DMINIEXCH if using the DEC mini-exchange
-CFLAGS = -O $(DFLAGS) -Wall
+#CFLAGS = -O $(DFLAGS) -Wall
#LDFLAGS = -z -i
#LIBS = -lm -lc_s # uncomment if using shared libraries
LIBS = -lm -lc
## For LINUX, use the following defines in addition to what's above
-DFLAGS = -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT
+#DFLAGS = -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT
## For solaris, use the following defines in addition to what's above
# DFLAGS = -DSYSV -DPOSIX -DSOLARIS -DLOCKDIR=\"/var/spool/locks\" -DHASSELECT
## if you're using freebsd, just set the flag for select.
-# DFLAGS= -DHASSELECT
+DFLAGS= -DHASSELECT -DLOCKDIR=\"/var/tmp\"
## If you aren't sure, try this
#DFLAGS = -DSYSV -DPOSIX

1
misc/heyu/pkg-comment Normal file
View file

@ -0,0 +1 @@
Control a CM11A interface from the command line

12
misc/heyu/pkg-descr Normal file
View file

@ -0,0 +1,12 @@
The CM11A is a device built by the X10 company for controlling
devices by sending signals through the power lines. It's a small
box that plugs into an AC outlet and connects to a serial port.
The CM11A is shipped with Windows software. Heyu will control your
X10 devices, set the cm11a interface clock and monitor x10 signals
on the AC power lines. It will upload macros and timers to your
CM11A for stand-alone execution.
WWW: http://www.prado.com/~dbs/
- plambert
plambert@plambert.net

3
misc/heyu/pkg-plist Normal file
View file

@ -0,0 +1,3 @@
bin/heyu
share/examples/heyu/x10config
share/examples/heyu/x10sched.conf.sample

35
misc/heyu2/Makefile Normal file
View file

@ -0,0 +1,35 @@
# New ports collection makefile for: heyu
# Version required: 1.28f
# Date created: 27 December 1999
# Whom: plambert@plambert.net
#
# $FreeBSD$
#
DISTNAME= x10_heyu
PKGNAME= heyu-1.28f
CATEGORIES= misc
MASTER_SITES= http://www.prado.com/~dbs/
EXTRACT_SUFX= .tgz
MAINTAINER= plambert@plambert.net
ALL_TARGET= heyu
WRKSRC= ${WRKDIR}/heyu.dir
MAN1= heyu.1
MAN5= x10config.5 \
x10sched.5
do-configure:
${PERL} -pi.orig -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/Makefile
post-install:
strip ${PREFIX}/bin/heyu
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/examples/heyu
${INSTALL_DATA} ${WRKSRC}/x10config ${PREFIX}/share/examples/heyu
${INSTALL_DATA} ${WRKSRC}/x10sched.conf.sample ${PREFIX}/share/examples/heyu
.endif
.include <bsd.port.mk>

1
misc/heyu2/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (x10_heyu.tgz) = f41c73b9665242ce5b9aba2b9a4f92e8

34
misc/heyu2/files/patch-aa Normal file
View file

@ -0,0 +1,34 @@
--- Makefile.orig Tue Jan 4 23:10:44 2000
+++ Makefile Tue Jan 4 23:12:54 2000
@@ -3,7 +3,7 @@
BIN = /usr/local/bin
MAN = /usr/local/man/man1
MAN5 = /usr/local/man/man5
-GROUP = sys
+GROUP = wheel
OWNER = bin
@@ -13,19 +13,19 @@
# -DVOID if compiler doesn't understand 'void'
# -DMINIEXCH if using the DEC mini-exchange
-CFLAGS = -O $(DFLAGS) -Wall
+#CFLAGS = -O $(DFLAGS) -Wall
#LDFLAGS = -z -i
#LIBS = -lm -lc_s # uncomment if using shared libraries
LIBS = -lm -lc
## For LINUX, use the following defines in addition to what's above
-DFLAGS = -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT
+#DFLAGS = -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT
## For solaris, use the following defines in addition to what's above
# DFLAGS = -DSYSV -DPOSIX -DSOLARIS -DLOCKDIR=\"/var/spool/locks\" -DHASSELECT
## if you're using freebsd, just set the flag for select.
-# DFLAGS= -DHASSELECT
+DFLAGS= -DHASSELECT -DLOCKDIR=\"/var/tmp\"
## If you aren't sure, try this
#DFLAGS = -DSYSV -DPOSIX

1
misc/heyu2/pkg-comment Normal file
View file

@ -0,0 +1 @@
Control a CM11A interface from the command line

12
misc/heyu2/pkg-descr Normal file
View file

@ -0,0 +1,12 @@
The CM11A is a device built by the X10 company for controlling
devices by sending signals through the power lines. It's a small
box that plugs into an AC outlet and connects to a serial port.
The CM11A is shipped with Windows software. Heyu will control your
X10 devices, set the cm11a interface clock and monitor x10 signals
on the AC power lines. It will upload macros and timers to your
CM11A for stand-alone execution.
WWW: http://www.prado.com/~dbs/
- plambert
plambert@plambert.net

3
misc/heyu2/pkg-plist Normal file
View file

@ -0,0 +1,3 @@
bin/heyu
share/examples/heyu/x10config
share/examples/heyu/x10sched.conf.sample