Approved by:	portmgr@
This commit is contained in:
Vanilla I. Shu 2014-06-19 07:15:33 +00:00
parent 779e11504a
commit 6651d9e9f2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=358360
2 changed files with 20 additions and 4 deletions

View file

@ -22,7 +22,6 @@ USES= perl5
USE_PERL5= build
WRKSRC = ${WRKDIR}/${DISTNAME:R}
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e '/gnu\*)/,/;;/{/CXX=/d; /CXX_OPTIMIZE_FLAGS=/d; \
s/CXXFLAGS="/&$$ac_cv_env_CXXFLAGS_value /; }' \
@ -49,9 +48,9 @@ CXXFLAGS+= -fpermissive
PORTEXAMPLES= *
post-install:
@${MKDIR} ${EXAMPLESDIR}/doubledouble
@${INSTALL_DATA} ${WRKSRC}/contrib/examples/* ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/contrib/doubledouble/* ${EXAMPLESDIR}/doubledouble
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/doubledouble
@${INSTALL_DATA} ${WRKSRC}/contrib/examples/* ${STAGEDIR}${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/contrib/doubledouble/* ${STAGEDIR}${EXAMPLESDIR}/doubledouble
.endif
.include <bsd.port.post.mk>

View file

@ -0,0 +1,17 @@
--- mtl/Makefile.in.orig 2014-06-19 15:12:46.890432000 +0800
+++ mtl/Makefile.in 2014-06-19 15:13:23.850278020 +0800
@@ -454,11 +454,11 @@ uninstall-am: uninstall-info-am
make-install-dirs:
- -if test '!' -d $(includedir); then mkdir -p $(includedir); fi
+ -if test '!' -d $(DESTDIR)$(includedir); then mkdir -p $(DESTDIR)$(includedir); fi
install-data-hook: make-install-dirs
- -@ echo Installing $(includedir) ; \
- $(INSTALL_DATA) *.h $(includedir)
+ -@ echo Installing $(DESTDIR)$(includedir) ; \
+ $(INSTALL_DATA) *.h $(DESTDIR)$(includedir)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: