Update port to version 4.4.4.
Add support for PORTDOCS in pkg-plist. Patches in files/ have been regenerated for this release, but they do the same things as before.
This commit is contained in:
parent
578470c87a
commit
6655b08385
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41961
8 changed files with 44 additions and 43 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= xnc
|
||||
PORTVERSION= 4.4.0
|
||||
PORTVERSION= 4.4.4
|
||||
CATEGORIES= x11-fm
|
||||
MASTER_SITES= http://www.xnc.dubna.su/src/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
|
||||
|
@ -35,8 +35,8 @@ MAN1= es.1 ives.1 vs.1 xjpegroot.1 xnc.1 xnlaunch.1
|
|||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/xnc
|
||||
${INSTALL_DATA} ${WRKSRC}/Docs/* ${PREFIX}/share/doc/xnc
|
||||
@${MKDIR} ${PREFIX}/share/doc/xnc
|
||||
@${INSTALL_DATA} ${WRKSRC}/Docs/* ${PREFIX}/share/doc/xnc
|
||||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (xnc-4.4.0.src.tar.gz) = cf3feffce6b562c6055aec4827615e3f
|
||||
MD5 (xnc-4.4.4.src.tar.gz) = 2d4501a74c78667855f2deeca1eb7ecd
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- groups.cxx.~1~ Thu Sep 24 22:42:27 1998
|
||||
+++ groups.cxx Tue Apr 27 23:00:25 1999
|
||||
@@ -18,6 +18,7 @@
|
||||
#include <config.h>
|
||||
--- groups.cxx.orig Wed Apr 25 21:03:06 2001
|
||||
+++ groups.cxx Wed Apr 25 21:04:50 2001
|
||||
@@ -19,6 +19,7 @@
|
||||
#endif
|
||||
#include <sys/types.h>
|
||||
#include <stdio.h>
|
||||
+#include <sys/param.h>
|
||||
#include <grp.h>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- filedir/makefile.in.orig Wed Feb 16 15:38:53 2000
|
||||
+++ filedir/makefile.in Wed Feb 16 15:39:08 2000
|
||||
--- filedir/makefile.in.orig Wed Apr 25 20:11:20 2001
|
||||
+++ filedir/makefile.in Wed Apr 25 20:11:28 2001
|
||||
@@ -34,7 +34,7 @@
|
||||
@MCOMMON@
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.in.orig Thu Jan 4 23:53:59 2001
|
||||
+++ Makefile.in Thu Jan 4 23:58:48 2001
|
||||
@@ -181,21 +181,21 @@
|
||||
--- Makefile.in.orig Wed Apr 25 20:43:09 2001
|
||||
+++ Makefile.in Wed Apr 25 20:42:53 2001
|
||||
@@ -186,21 +186,21 @@
|
||||
|
||||
install:
|
||||
#Installing X Northern Captain...
|
||||
|
@ -29,7 +29,7 @@
|
|||
+ $(INSTALL_PROGRAM) ./xsetup/xncsetup $(INSTDIR)
|
||||
+ $(INSTALL_PROGRAM) ./xjroot/xjpegroot $(INSTDIR)
|
||||
+ $(INSTALL_PROGRAM) ./launch/xnlaunch $(INSTDIR)
|
||||
+# /bin/sh ./replace.script
|
||||
+ # /bin/sh ./replace.script
|
||||
mkdir -p $(INSTPLUG)
|
||||
$(INS) ./plugins/five/libxncfive.so $(INSTPLUG)
|
||||
echo "Don't foget run 'xncsetup' before starting XNC"
|
||||
$(INS) ./plugins/aqua/libxncaqua.so $(INSTPLUG)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- image/makefile.in.orig Tue Jan 18 17:35:15 2000
|
||||
+++ image/makefile.in Sat Jun 24 15:56:50 2000
|
||||
@@ -31,31 +31,31 @@
|
||||
--- image/makefile.in.orig Wed Apr 25 20:12:34 2001
|
||||
+++ image/makefile.in Wed Apr 25 20:14:32 2001
|
||||
@@ -31,34 +31,34 @@
|
||||
all:: libie.a $(PNGDEP) $(ZDEP)
|
||||
|
||||
24to8.o: 24to8.c
|
||||
|
@ -11,6 +11,10 @@
|
|||
- $(CC) -c jpeg.c $(CXXOPT) $(INCLUDES)
|
||||
+ $(CC) -c jpeg.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS)
|
||||
|
||||
accel.o: accel.c
|
||||
- $(CC) -c accel.c $(CXXOPT) $(CXXINCLUDES)
|
||||
+ $(CC) -c accel.c $(CXXOPT) $(CXXINCLUDES) $(CPPFLAGS)
|
||||
|
||||
pcdr.o: pcdr.c
|
||||
- $(CC) -c pcdr.c $(CXXOPT) $(INCLUDES)
|
||||
+ $(CC) -c pcdr.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS)
|
||||
|
@ -37,20 +41,16 @@
|
|||
|
||||
png.o: png.c
|
||||
- $(CC) -c png.c $(CXXOPT) $(INCLUDES) $(ZINC) $(PNGINC)
|
||||
+ $(CC) -c png.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS) $(ZINC) $(PNGINC)
|
||||
+ $(CC) -c png.c $(CXXOPT) $(INCLUDES) $(ZINC) $(PNGINC) $(CPPFLAGS)
|
||||
|
||||
../zlib/libz.a:
|
||||
cd ../zlib && make
|
||||
@@ -64,10 +64,10 @@
|
||||
@@ -67,7 +67,7 @@
|
||||
cd ../libpng && make
|
||||
|
||||
pcxr.o: pcxr.c
|
||||
- $(CC) -c pcxr.c $(CXXOPT) $(INCLUDES)
|
||||
+ $(CC) -c pcxr.c $(CXXOPT) $(INCLUDES) $(CPPFLAGS)
|
||||
|
||||
accel.o: accel.c
|
||||
- $(CC) -c accel.c $(CFLAGS)
|
||||
+ $(CC) -c accel.c $(CFLAGS) $(CPPFLAGS)
|
||||
|
||||
libie.a: $(IOBJS)
|
||||
$(RM) -f libie.a
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
-------------------------------------------------------------------------------
|
||||
| Attention! EVERY user who wants to use xnc should first execute 'xncsetup' |
|
||||
| from X-Window to configure his/her own profile. |
|
||||
| from X11 to configure his/her own profile. |
|
||||
-------------------------------------------------------------------------------
|
||||
|
|
|
@ -1,24 +1,25 @@
|
|||
bin/users.xnc
|
||||
bin/groups.xnc
|
||||
bin/rpm.xnc
|
||||
bin/zips.xnc
|
||||
bin/gzip.xnc
|
||||
bin/bzip.xnc
|
||||
bin/xnc
|
||||
bin/ives
|
||||
bin/es
|
||||
bin/groups.xnc
|
||||
bin/gzip.xnc
|
||||
bin/ives
|
||||
bin/rpm.xnc
|
||||
bin/users.xnc
|
||||
bin/vs
|
||||
bin/xncsetup
|
||||
bin/xjpegroot
|
||||
bin/xnc
|
||||
bin/xncsetup
|
||||
bin/xnlaunch
|
||||
bin/zips.xnc
|
||||
lib/libxncaqua.so
|
||||
lib/libxncfive.so
|
||||
share/doc/xnc/index.html
|
||||
share/doc/xnc/doc1.html
|
||||
share/doc/xnc/doc2.html
|
||||
share/doc/xnc/doc3.html
|
||||
share/doc/xnc/doc4.html
|
||||
share/doc/xnc/doc5.html
|
||||
share/doc/xnc/doc6.html
|
||||
share/doc/xnc/doc7.html
|
||||
share/doc/xnc/doc8.html
|
||||
@dirrm share/doc/xnc
|
||||
%%PORTDOCS%%share/doc/xnc/doc1.html
|
||||
%%PORTDOCS%%share/doc/xnc/doc2.html
|
||||
%%PORTDOCS%%share/doc/xnc/doc3.html
|
||||
%%PORTDOCS%%share/doc/xnc/doc4.html
|
||||
%%PORTDOCS%%share/doc/xnc/doc5.html
|
||||
%%PORTDOCS%%share/doc/xnc/doc6.html
|
||||
%%PORTDOCS%%share/doc/xnc/doc7.html
|
||||
%%PORTDOCS%%share/doc/xnc/doc8.html
|
||||
%%PORTDOCS%%share/doc/xnc/index.html
|
||||
%%PORTDOCS%%@dirrm share/doc/xnc
|
||||
|
|
Loading…
Reference in a new issue