security/nflib: Turn on the internal optimization option NFL_OPTIMIZED; Eliminate testcases from the 'build' target
This commit is contained in:
parent
f812380a4e
commit
665dd96ae4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=526861
2 changed files with 17 additions and 1 deletions
|
@ -4,6 +4,7 @@ PORTNAME= nflib
|
|||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.0.0-23
|
||||
DISTVERSIONSUFFIX= -g5cf40ed
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security math
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
@ -24,6 +25,12 @@ GH_ACCOUNT= quarkslab
|
|||
GH_PROJECT= NFLlib
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
TEST_TARGET= test
|
||||
CMAKE_ON= NFL_OPTIMIZED
|
||||
|
||||
do-test:
|
||||
@cd ${BUILD_WRKSRC} && \
|
||||
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_TESTING:BOOL=ON ${CMAKE_SOURCE_PATH} && \
|
||||
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
|
||||
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
9
security/nflib/files/patch-CMakeLists.txt
Normal file
9
security/nflib/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,9 @@
|
|||
--- CMakeLists.txt.orig 2020-02-22 22:31:07 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -64,4 +64,6 @@ install(FILES ${NFLLIB_HDRS_3} DESTINATION include/nfl
|
||||
install(FILES ${NFLLIB_HDRS_4} DESTINATION include/nfl/opt/arch)
|
||||
install(FILES ${NFLLIB_PRNG_HDRS} DESTINATION include/nfl/prng)
|
||||
|
||||
+if (BUILD_TESTING)
|
||||
add_subdirectory(tests)
|
||||
+endif()
|
Loading…
Reference in a new issue