This is the latest version of xemacs - Xemacs 21.1.
This requires xemacs-packages which be will committed next. Xemacs now allows the user to maintain packages himself. See DESCR. This supersedes PR 11618, which was based on an older release. This commit was blasted over a repository copy of xemacs20, which is why there are so many changes. Submitted by: Michael Elbel (me@freebsd.org)
This commit is contained in:
parent
d7b0c7f42f
commit
667b857a75
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=19689
21 changed files with 1788 additions and 8907 deletions
|
@ -1,27 +1,32 @@
|
|||
# New ports collection makefile for: X-Emacs
|
||||
# Version required: 20.4
|
||||
# Date created: 26 August 1997
|
||||
# Whom: Michael Elbel (me)
|
||||
# Version required: 21.1
|
||||
# Date created: 24 Apr 1999
|
||||
# Whom: Michael Elbel (me@FreeBSD.org)
|
||||
#
|
||||
# $Id: Makefile,v 1.26 1999/01/25 22:06:11 gj Exp $
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= xemacs-20.4
|
||||
DISTNAME= xemacs-21.1.2
|
||||
PKGNAME= xemacs-21.1
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= \
|
||||
ftp://ftp.xemacs.org/pub/xemacs/${DISTNAME}/ \
|
||||
ftp://ftp.mpi-sb.mpg.de/pub/gnu/mirror/ftp.xemacs.org/xemacs/${DISTNAME}/ \
|
||||
ftp://ftp.usyd.edu.au:/pub/Xemacs/${DISTNAME}/ \
|
||||
ftp://ftp.lab.kdd.co.jp/xemacs/${DISTNAME}/ \
|
||||
ftp://ftp.th-darmstadt.de:/pub/editors/xemacs/${DISTNAME}/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${MULEDISTFILE}
|
||||
ftp://ftp.xemacs.org/pub/xemacs/${PKGNAME}/ \
|
||||
ftp://ftp.mpi-sb.mpg.de/pub/gnu/mirror/ftp.xemacs.org/xemacs/${PKGNAME}/ \
|
||||
ftp://ftp.usyd.edu.au/pub/Xemacs/${PKGNAME}/ \
|
||||
ftp://ftp.lab.kdd.co.jp/xemacs/${PKGNAME}/ \
|
||||
ftp://ftp.th-darmstadt.de/pub/editors/xemacs/${PKGNAME}/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}-elc${EXTRACT_SUFX} ${DISTNAME}-info${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= me@FreeBSD.org
|
||||
|
||||
RUN_DEPENDS= ${PREFIX}/lib/xemacs/xemacs-packages/etc/enriched.doc:${PORTSDIR}/editors/xemacs-packages
|
||||
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
png.3:${PORTSDIR}/graphics/png
|
||||
|
||||
XEMACS_VER= 21.1-p2
|
||||
DIST_SUBDIR= xemacs
|
||||
|
||||
USE_GMAKE= yes
|
||||
STRIP=
|
||||
HAS_CONFIGURE= yes
|
||||
|
@ -32,29 +37,33 @@ CONFIGURE_ARGS= ${XEMACS_ARCH} --prefix=${PREFIX} \
|
|||
--with-sound=native \
|
||||
--site-includes=${PREFIX}/include \
|
||||
--site-libraries=${PREFIX}/lib \
|
||||
--sitelispdir="${PREFIX}/lib/xemacs/site-lisp ${PREFIX}/share/emacs/site-lisp" \
|
||||
--with-session=yes \
|
||||
${WITH_XFACE} ${WITH_MULE} ${WITH_DIALOGS} ${WITH_OFFIX}
|
||||
MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
|
||||
gnuserv.1 xemacs.1
|
||||
ALL_TARGET= all dist
|
||||
PLIST_SUB= XEMACS_VER=20.4 XEMACS_ARCH=${XEMACS_ARCH}
|
||||
|
||||
PLIST_SUB= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}
|
||||
|
||||
# Have
|
||||
pre-configure:
|
||||
pre-fetch:
|
||||
.if !defined(USE_MULE)
|
||||
@echo "To compile in the MULE features, set the environment variable USE_MULE"
|
||||
.endif
|
||||
.if defined(HAVE_MOTIF)
|
||||
.if !defined(MOTIF_STATIC)
|
||||
@echo ""
|
||||
@echo "If your MOTIF library is actually lesstif, you might occasionally"
|
||||
@echo "experience locked-up frames."
|
||||
@echo "In this case, set the environment variable MOTIF_STATIC and recompile, "
|
||||
@echo "which will force the use of athena widgets for dialogs."
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if defined(USE_MULE)
|
||||
WITH_MULE= --with-mule
|
||||
MULEDISTFILE= ${DISTNAME}-mule.tar.gz
|
||||
PLIST= ${PKGDIR}/PLIST.mule
|
||||
# MULEDISTFILE= ${DISTNAME}-mule.tar.gz
|
||||
# PLIST= ${PKGDIR}/PLIST.mule
|
||||
.endif
|
||||
|
||||
# hack to avoid shipping binaries linked with Motif
|
||||
|
@ -70,16 +79,16 @@ WITH_OFFIX?= --with-offix=no
|
|||
.endif
|
||||
|
||||
post-install:
|
||||
.for file in b2m ctags etags gnuclient ${DISTNAME}
|
||||
ln -s xemacs-${XEMACS_VER} ${PREFIX}/bin/xemacs21
|
||||
.for file in b2m ctags etags gnuclient xemacs-${XEMACS_VER}
|
||||
strip ${PREFIX}/bin/${file}
|
||||
.endfor
|
||||
# ``make install'' does not set the permissions like pkg_add does.
|
||||
chmod 1777 /var/run/emacs/lock
|
||||
chmod 755 ${PREFIX}/lib/xemacs/site-lisp
|
||||
chmod 755 ${PREFIX}/share/emacs/site-lisp
|
||||
# ${MKDIR} ${PREFIX}/lib/xemacs
|
||||
${RM} -f ${PREFIX}/bin/send-pr
|
||||
# install xemacs20.sh into ${PREFIX}/etc/rc.d
|
||||
@if [ ! -d ${PREFIX}/etc/rc.d ]; then mkdir -p ${PREFIX}/etc/rc.d; fi
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/xemacs20.sh ${PREFIX}/etc/rc.d
|
||||
# install xemacs21.sh into ${PREFIX}/etc/rc.d
|
||||
@if [ ! -d ${PREFIX}/etc/rc.d ]; then ${MKDIR} ${PREFIX}/etc/rc.d; fi
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/xemacs21.sh ${PREFIX}/etc/rc.d
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
MD5 (xemacs-20.4.tar.gz) = 56912174ed51f4a21b490a96704ee5c0
|
||||
MD5 (xemacs-20.4-mule.tar.gz) = 25ad2761b0fc98dbed45be44ad03665c
|
||||
MD5 (xemacs/xemacs-21.1.2.tar.gz) = d6c3027d8efb56d265dda522392fa8bb
|
||||
MD5 (xemacs/xemacs-21.1.2-elc.tar.gz) = 257d6043e6930004edba05ed74e75650
|
||||
MD5 (xemacs/xemacs-21.1.2-info.tar.gz) = cf4c2eba16e1342e6cc235590cfbfdac
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- configure Thu Nov 20 03:13:44 1997
|
||||
+++ configure.n Tue Dec 9 09:55:11 1997
|
||||
@@ -9706,7 +9706,7 @@
|
||||
|
||||
fi
|
||||
if test "$with_database_berkdb" = "yes"; then
|
||||
- for path in "db/db.h" "db.h"; do
|
||||
+ for path in "/usr/include/db.h" "db/db.h" "db.h"; do
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 9712 "configure"
|
||||
--- configure.orig Wed May 26 06:28:12 1999
|
||||
+++ configure Wed May 26 06:28:08 1999
|
||||
@@ -11172,7 +11172,7 @@
|
||||
if test "$with_database_berkdb" != "no"; then
|
||||
echo $ac_n "checking for Berkeley db.h""... $ac_c" 1>&6
|
||||
echo "configure:11175: checking for Berkeley db.h" >&5
|
||||
- for path in "db/db.h" "db.h"; do
|
||||
+ for path in "/usr/include/db.h" "db/db.h" "db.h"; do
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 11178 "configure"
|
||||
#include "confdefs.h"
|
||||
|
|
14
editors/xemacs-devel/files/xemacs21.sh
Normal file
14
editors/xemacs-devel/files/xemacs21.sh
Normal file
|
@ -0,0 +1,14 @@
|
|||
#!/bin/sh
|
||||
# script to create the lock directory in case it was
|
||||
# removed in /etc/rc
|
||||
#echo -n ' Xemacs'
|
||||
if [ -d /var/run/emacs/lock ]
|
||||
then
|
||||
# delete any junk which may have been left around
|
||||
rm -f /var/run/emacs/lock/*
|
||||
else
|
||||
mkdir -p /var/run/emacs/lock
|
||||
fi
|
||||
# can always do this
|
||||
chmod 1777 /var/run/emacs/lock
|
||||
exit 0
|
|
@ -1 +1 @@
|
|||
XEmacs text editor version 20
|
||||
XEmacs text editor version 21
|
||||
|
|
|
@ -17,3 +17,5 @@ XEmacs has similar functionality to GNU Emacs. It uses a different
|
|||
display model, including support for Motif menu and scroll bars and the
|
||||
ability to run as a widget inside other applications. Many people say
|
||||
it looks nicer than GNU Emacs.
|
||||
|
||||
Web site: http://www.xemacs.org
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,27 +1,32 @@
|
|||
# New ports collection makefile for: X-Emacs
|
||||
# Version required: 20.4
|
||||
# Date created: 26 August 1997
|
||||
# Whom: Michael Elbel (me)
|
||||
# Version required: 21.1
|
||||
# Date created: 24 Apr 1999
|
||||
# Whom: Michael Elbel (me@FreeBSD.org)
|
||||
#
|
||||
# $Id: Makefile,v 1.26 1999/01/25 22:06:11 gj Exp $
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= xemacs-20.4
|
||||
DISTNAME= xemacs-21.1.2
|
||||
PKGNAME= xemacs-21.1
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= \
|
||||
ftp://ftp.xemacs.org/pub/xemacs/${DISTNAME}/ \
|
||||
ftp://ftp.mpi-sb.mpg.de/pub/gnu/mirror/ftp.xemacs.org/xemacs/${DISTNAME}/ \
|
||||
ftp://ftp.usyd.edu.au:/pub/Xemacs/${DISTNAME}/ \
|
||||
ftp://ftp.lab.kdd.co.jp/xemacs/${DISTNAME}/ \
|
||||
ftp://ftp.th-darmstadt.de:/pub/editors/xemacs/${DISTNAME}/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${MULEDISTFILE}
|
||||
ftp://ftp.xemacs.org/pub/xemacs/${PKGNAME}/ \
|
||||
ftp://ftp.mpi-sb.mpg.de/pub/gnu/mirror/ftp.xemacs.org/xemacs/${PKGNAME}/ \
|
||||
ftp://ftp.usyd.edu.au/pub/Xemacs/${PKGNAME}/ \
|
||||
ftp://ftp.lab.kdd.co.jp/xemacs/${PKGNAME}/ \
|
||||
ftp://ftp.th-darmstadt.de/pub/editors/xemacs/${PKGNAME}/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}-elc${EXTRACT_SUFX} ${DISTNAME}-info${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= me@FreeBSD.org
|
||||
|
||||
RUN_DEPENDS= ${PREFIX}/lib/xemacs/xemacs-packages/etc/enriched.doc:${PORTSDIR}/editors/xemacs-packages
|
||||
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
png.3:${PORTSDIR}/graphics/png
|
||||
|
||||
XEMACS_VER= 21.1-p2
|
||||
DIST_SUBDIR= xemacs
|
||||
|
||||
USE_GMAKE= yes
|
||||
STRIP=
|
||||
HAS_CONFIGURE= yes
|
||||
|
@ -32,29 +37,33 @@ CONFIGURE_ARGS= ${XEMACS_ARCH} --prefix=${PREFIX} \
|
|||
--with-sound=native \
|
||||
--site-includes=${PREFIX}/include \
|
||||
--site-libraries=${PREFIX}/lib \
|
||||
--sitelispdir="${PREFIX}/lib/xemacs/site-lisp ${PREFIX}/share/emacs/site-lisp" \
|
||||
--with-session=yes \
|
||||
${WITH_XFACE} ${WITH_MULE} ${WITH_DIALOGS} ${WITH_OFFIX}
|
||||
MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
|
||||
gnuserv.1 xemacs.1
|
||||
ALL_TARGET= all dist
|
||||
PLIST_SUB= XEMACS_VER=20.4 XEMACS_ARCH=${XEMACS_ARCH}
|
||||
|
||||
PLIST_SUB= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}
|
||||
|
||||
# Have
|
||||
pre-configure:
|
||||
pre-fetch:
|
||||
.if !defined(USE_MULE)
|
||||
@echo "To compile in the MULE features, set the environment variable USE_MULE"
|
||||
.endif
|
||||
.if defined(HAVE_MOTIF)
|
||||
.if !defined(MOTIF_STATIC)
|
||||
@echo ""
|
||||
@echo "If your MOTIF library is actually lesstif, you might occasionally"
|
||||
@echo "experience locked-up frames."
|
||||
@echo "In this case, set the environment variable MOTIF_STATIC and recompile, "
|
||||
@echo "which will force the use of athena widgets for dialogs."
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if defined(USE_MULE)
|
||||
WITH_MULE= --with-mule
|
||||
MULEDISTFILE= ${DISTNAME}-mule.tar.gz
|
||||
PLIST= ${PKGDIR}/PLIST.mule
|
||||
# MULEDISTFILE= ${DISTNAME}-mule.tar.gz
|
||||
# PLIST= ${PKGDIR}/PLIST.mule
|
||||
.endif
|
||||
|
||||
# hack to avoid shipping binaries linked with Motif
|
||||
|
@ -70,16 +79,16 @@ WITH_OFFIX?= --with-offix=no
|
|||
.endif
|
||||
|
||||
post-install:
|
||||
.for file in b2m ctags etags gnuclient ${DISTNAME}
|
||||
ln -s xemacs-${XEMACS_VER} ${PREFIX}/bin/xemacs21
|
||||
.for file in b2m ctags etags gnuclient xemacs-${XEMACS_VER}
|
||||
strip ${PREFIX}/bin/${file}
|
||||
.endfor
|
||||
# ``make install'' does not set the permissions like pkg_add does.
|
||||
chmod 1777 /var/run/emacs/lock
|
||||
chmod 755 ${PREFIX}/lib/xemacs/site-lisp
|
||||
chmod 755 ${PREFIX}/share/emacs/site-lisp
|
||||
# ${MKDIR} ${PREFIX}/lib/xemacs
|
||||
${RM} -f ${PREFIX}/bin/send-pr
|
||||
# install xemacs20.sh into ${PREFIX}/etc/rc.d
|
||||
@if [ ! -d ${PREFIX}/etc/rc.d ]; then mkdir -p ${PREFIX}/etc/rc.d; fi
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/xemacs20.sh ${PREFIX}/etc/rc.d
|
||||
# install xemacs21.sh into ${PREFIX}/etc/rc.d
|
||||
@if [ ! -d ${PREFIX}/etc/rc.d ]; then ${MKDIR} ${PREFIX}/etc/rc.d; fi
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/xemacs21.sh ${PREFIX}/etc/rc.d
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
MD5 (xemacs-20.4.tar.gz) = 56912174ed51f4a21b490a96704ee5c0
|
||||
MD5 (xemacs-20.4-mule.tar.gz) = 25ad2761b0fc98dbed45be44ad03665c
|
||||
MD5 (xemacs/xemacs-21.1.2.tar.gz) = d6c3027d8efb56d265dda522392fa8bb
|
||||
MD5 (xemacs/xemacs-21.1.2-elc.tar.gz) = 257d6043e6930004edba05ed74e75650
|
||||
MD5 (xemacs/xemacs-21.1.2-info.tar.gz) = cf4c2eba16e1342e6cc235590cfbfdac
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- configure Thu Nov 20 03:13:44 1997
|
||||
+++ configure.n Tue Dec 9 09:55:11 1997
|
||||
@@ -9706,7 +9706,7 @@
|
||||
|
||||
fi
|
||||
if test "$with_database_berkdb" = "yes"; then
|
||||
- for path in "db/db.h" "db.h"; do
|
||||
+ for path in "/usr/include/db.h" "db/db.h" "db.h"; do
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 9712 "configure"
|
||||
--- configure.orig Wed May 26 06:28:12 1999
|
||||
+++ configure Wed May 26 06:28:08 1999
|
||||
@@ -11172,7 +11172,7 @@
|
||||
if test "$with_database_berkdb" != "no"; then
|
||||
echo $ac_n "checking for Berkeley db.h""... $ac_c" 1>&6
|
||||
echo "configure:11175: checking for Berkeley db.h" >&5
|
||||
- for path in "db/db.h" "db.h"; do
|
||||
+ for path in "/usr/include/db.h" "db/db.h" "db.h"; do
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 11178 "configure"
|
||||
#include "confdefs.h"
|
||||
|
|
14
editors/xemacs/files/xemacs21.sh
Normal file
14
editors/xemacs/files/xemacs21.sh
Normal file
|
@ -0,0 +1,14 @@
|
|||
#!/bin/sh
|
||||
# script to create the lock directory in case it was
|
||||
# removed in /etc/rc
|
||||
#echo -n ' Xemacs'
|
||||
if [ -d /var/run/emacs/lock ]
|
||||
then
|
||||
# delete any junk which may have been left around
|
||||
rm -f /var/run/emacs/lock/*
|
||||
else
|
||||
mkdir -p /var/run/emacs/lock
|
||||
fi
|
||||
# can always do this
|
||||
chmod 1777 /var/run/emacs/lock
|
||||
exit 0
|
|
@ -1 +1 @@
|
|||
XEmacs text editor version 20
|
||||
XEmacs text editor version 21
|
||||
|
|
|
@ -17,3 +17,5 @@ XEmacs has similar functionality to GNU Emacs. It uses a different
|
|||
display model, including support for Motif menu and scroll bars and the
|
||||
ability to run as a widget inside other applications. Many people say
|
||||
it looks nicer than GNU Emacs.
|
||||
|
||||
Web site: http://www.xemacs.org
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,27 +1,32 @@
|
|||
# New ports collection makefile for: X-Emacs
|
||||
# Version required: 20.4
|
||||
# Date created: 26 August 1997
|
||||
# Whom: Michael Elbel (me)
|
||||
# Version required: 21.1
|
||||
# Date created: 24 Apr 1999
|
||||
# Whom: Michael Elbel (me@FreeBSD.org)
|
||||
#
|
||||
# $Id: Makefile,v 1.26 1999/01/25 22:06:11 gj Exp $
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= xemacs-20.4
|
||||
DISTNAME= xemacs-21.1.2
|
||||
PKGNAME= xemacs-21.1
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= \
|
||||
ftp://ftp.xemacs.org/pub/xemacs/${DISTNAME}/ \
|
||||
ftp://ftp.mpi-sb.mpg.de/pub/gnu/mirror/ftp.xemacs.org/xemacs/${DISTNAME}/ \
|
||||
ftp://ftp.usyd.edu.au:/pub/Xemacs/${DISTNAME}/ \
|
||||
ftp://ftp.lab.kdd.co.jp/xemacs/${DISTNAME}/ \
|
||||
ftp://ftp.th-darmstadt.de:/pub/editors/xemacs/${DISTNAME}/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${MULEDISTFILE}
|
||||
ftp://ftp.xemacs.org/pub/xemacs/${PKGNAME}/ \
|
||||
ftp://ftp.mpi-sb.mpg.de/pub/gnu/mirror/ftp.xemacs.org/xemacs/${PKGNAME}/ \
|
||||
ftp://ftp.usyd.edu.au/pub/Xemacs/${PKGNAME}/ \
|
||||
ftp://ftp.lab.kdd.co.jp/xemacs/${PKGNAME}/ \
|
||||
ftp://ftp.th-darmstadt.de/pub/editors/xemacs/${PKGNAME}/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}-elc${EXTRACT_SUFX} ${DISTNAME}-info${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= me@FreeBSD.org
|
||||
|
||||
RUN_DEPENDS= ${PREFIX}/lib/xemacs/xemacs-packages/etc/enriched.doc:${PORTSDIR}/editors/xemacs-packages
|
||||
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
png.3:${PORTSDIR}/graphics/png
|
||||
|
||||
XEMACS_VER= 21.1-p2
|
||||
DIST_SUBDIR= xemacs
|
||||
|
||||
USE_GMAKE= yes
|
||||
STRIP=
|
||||
HAS_CONFIGURE= yes
|
||||
|
@ -32,29 +37,33 @@ CONFIGURE_ARGS= ${XEMACS_ARCH} --prefix=${PREFIX} \
|
|||
--with-sound=native \
|
||||
--site-includes=${PREFIX}/include \
|
||||
--site-libraries=${PREFIX}/lib \
|
||||
--sitelispdir="${PREFIX}/lib/xemacs/site-lisp ${PREFIX}/share/emacs/site-lisp" \
|
||||
--with-session=yes \
|
||||
${WITH_XFACE} ${WITH_MULE} ${WITH_DIALOGS} ${WITH_OFFIX}
|
||||
MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
|
||||
gnuserv.1 xemacs.1
|
||||
ALL_TARGET= all dist
|
||||
PLIST_SUB= XEMACS_VER=20.4 XEMACS_ARCH=${XEMACS_ARCH}
|
||||
|
||||
PLIST_SUB= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}
|
||||
|
||||
# Have
|
||||
pre-configure:
|
||||
pre-fetch:
|
||||
.if !defined(USE_MULE)
|
||||
@echo "To compile in the MULE features, set the environment variable USE_MULE"
|
||||
.endif
|
||||
.if defined(HAVE_MOTIF)
|
||||
.if !defined(MOTIF_STATIC)
|
||||
@echo ""
|
||||
@echo "If your MOTIF library is actually lesstif, you might occasionally"
|
||||
@echo "experience locked-up frames."
|
||||
@echo "In this case, set the environment variable MOTIF_STATIC and recompile, "
|
||||
@echo "which will force the use of athena widgets for dialogs."
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if defined(USE_MULE)
|
||||
WITH_MULE= --with-mule
|
||||
MULEDISTFILE= ${DISTNAME}-mule.tar.gz
|
||||
PLIST= ${PKGDIR}/PLIST.mule
|
||||
# MULEDISTFILE= ${DISTNAME}-mule.tar.gz
|
||||
# PLIST= ${PKGDIR}/PLIST.mule
|
||||
.endif
|
||||
|
||||
# hack to avoid shipping binaries linked with Motif
|
||||
|
@ -70,16 +79,16 @@ WITH_OFFIX?= --with-offix=no
|
|||
.endif
|
||||
|
||||
post-install:
|
||||
.for file in b2m ctags etags gnuclient ${DISTNAME}
|
||||
ln -s xemacs-${XEMACS_VER} ${PREFIX}/bin/xemacs21
|
||||
.for file in b2m ctags etags gnuclient xemacs-${XEMACS_VER}
|
||||
strip ${PREFIX}/bin/${file}
|
||||
.endfor
|
||||
# ``make install'' does not set the permissions like pkg_add does.
|
||||
chmod 1777 /var/run/emacs/lock
|
||||
chmod 755 ${PREFIX}/lib/xemacs/site-lisp
|
||||
chmod 755 ${PREFIX}/share/emacs/site-lisp
|
||||
# ${MKDIR} ${PREFIX}/lib/xemacs
|
||||
${RM} -f ${PREFIX}/bin/send-pr
|
||||
# install xemacs20.sh into ${PREFIX}/etc/rc.d
|
||||
@if [ ! -d ${PREFIX}/etc/rc.d ]; then mkdir -p ${PREFIX}/etc/rc.d; fi
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/xemacs20.sh ${PREFIX}/etc/rc.d
|
||||
# install xemacs21.sh into ${PREFIX}/etc/rc.d
|
||||
@if [ ! -d ${PREFIX}/etc/rc.d ]; then ${MKDIR} ${PREFIX}/etc/rc.d; fi
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/xemacs21.sh ${PREFIX}/etc/rc.d
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
MD5 (xemacs-20.4.tar.gz) = 56912174ed51f4a21b490a96704ee5c0
|
||||
MD5 (xemacs-20.4-mule.tar.gz) = 25ad2761b0fc98dbed45be44ad03665c
|
||||
MD5 (xemacs/xemacs-21.1.2.tar.gz) = d6c3027d8efb56d265dda522392fa8bb
|
||||
MD5 (xemacs/xemacs-21.1.2-elc.tar.gz) = 257d6043e6930004edba05ed74e75650
|
||||
MD5 (xemacs/xemacs-21.1.2-info.tar.gz) = cf4c2eba16e1342e6cc235590cfbfdac
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- configure Thu Nov 20 03:13:44 1997
|
||||
+++ configure.n Tue Dec 9 09:55:11 1997
|
||||
@@ -9706,7 +9706,7 @@
|
||||
|
||||
fi
|
||||
if test "$with_database_berkdb" = "yes"; then
|
||||
- for path in "db/db.h" "db.h"; do
|
||||
+ for path in "/usr/include/db.h" "db/db.h" "db.h"; do
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 9712 "configure"
|
||||
--- configure.orig Wed May 26 06:28:12 1999
|
||||
+++ configure Wed May 26 06:28:08 1999
|
||||
@@ -11172,7 +11172,7 @@
|
||||
if test "$with_database_berkdb" != "no"; then
|
||||
echo $ac_n "checking for Berkeley db.h""... $ac_c" 1>&6
|
||||
echo "configure:11175: checking for Berkeley db.h" >&5
|
||||
- for path in "db/db.h" "db.h"; do
|
||||
+ for path in "/usr/include/db.h" "db/db.h" "db.h"; do
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 11178 "configure"
|
||||
#include "confdefs.h"
|
||||
|
|
14
editors/xemacs21/files/xemacs21.sh
Normal file
14
editors/xemacs21/files/xemacs21.sh
Normal file
|
@ -0,0 +1,14 @@
|
|||
#!/bin/sh
|
||||
# script to create the lock directory in case it was
|
||||
# removed in /etc/rc
|
||||
#echo -n ' Xemacs'
|
||||
if [ -d /var/run/emacs/lock ]
|
||||
then
|
||||
# delete any junk which may have been left around
|
||||
rm -f /var/run/emacs/lock/*
|
||||
else
|
||||
mkdir -p /var/run/emacs/lock
|
||||
fi
|
||||
# can always do this
|
||||
chmod 1777 /var/run/emacs/lock
|
||||
exit 0
|
|
@ -1 +1 @@
|
|||
XEmacs text editor version 20
|
||||
XEmacs text editor version 21
|
||||
|
|
|
@ -17,3 +17,5 @@ XEmacs has similar functionality to GNU Emacs. It uses a different
|
|||
display model, including support for Motif menu and scroll bars and the
|
||||
ability to run as a widget inside other applications. Many people say
|
||||
it looks nicer than GNU Emacs.
|
||||
|
||||
Web site: http://www.xemacs.org
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue