- Fix build on amd64 (crude hack to pass -fPIC to c++ compiles)

Reported by:	pointyhat via kris
Tested on:	arved's box
This commit is contained in:
Pav Lucistnik 2004-11-06 23:12:14 +00:00
parent 166eb9dfb7
commit 6743d66769
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=121009

View file

@ -0,0 +1,11 @@
--- setup.py.orig Fri May 14 15:17:43 2004
+++ setup.py Sun Nov 7 01:02:10 2004
@@ -199,7 +199,7 @@
self.compiler.set_executable("linker_so",
cxx + ["-shared"])
elif build: # fix for 2.3, only if we are making C++ modules
- self.compiler.compiler_so = self.compiler.compiler_cxx
+ self.compiler.compiler_so = self.compiler.compiler_cxx + ["-fPIC"]
else:
self.compiler.compiler_so = self._original_compiler_so