dxa65 is a disassembler for MOS 6502 and compatible CPUs
NMOS 6502s (such as 6502A, 6504, 6507, 6510, 7501, 8500, 8501, 8502 ...) CMOS 6502s (65C02 and Rockwell R65C02) WWW: http://www.floodgap.com/retrotech/xa#dxa PR: ports/179030 Submitted by: uffe@uffe.org
This commit is contained in:
parent
8c55b12f72
commit
675b5a216a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=324009
5 changed files with 67 additions and 0 deletions
|
@ -373,6 +373,7 @@
|
||||||
SUBDIR += dulwich
|
SUBDIR += dulwich
|
||||||
SUBDIR += duplo
|
SUBDIR += duplo
|
||||||
SUBDIR += dwarfdump
|
SUBDIR += dwarfdump
|
||||||
|
SUBDIR += dxa65
|
||||||
SUBDIR += dyncall
|
SUBDIR += dyncall
|
||||||
SUBDIR += e00compr
|
SUBDIR += e00compr
|
||||||
SUBDIR += e2fsprogs-libss
|
SUBDIR += e2fsprogs-libss
|
||||||
|
|
38
devel/dxa65/Makefile
Normal file
38
devel/dxa65/Makefile
Normal file
|
@ -0,0 +1,38 @@
|
||||||
|
# Created by: Uffe Jakobsen <uffe@uffe.org>
|
||||||
|
# $FreeBSD$
|
||||||
|
|
||||||
|
PORTNAME= dxa
|
||||||
|
PORTVERSION= 0.1.3
|
||||||
|
CATEGORIES= devel
|
||||||
|
MASTER_SITES= http://www.floodgap.com/retrotech/xa/dists/
|
||||||
|
PKGNAMESUFFIX= 65
|
||||||
|
|
||||||
|
MAINTAINER= uffe@uffe.org
|
||||||
|
COMMENT= Disassembler for MOS 6502 and compatible CPUs
|
||||||
|
|
||||||
|
OPTIONS_DEFINE= DOCS
|
||||||
|
|
||||||
|
USES= gmake
|
||||||
|
|
||||||
|
MAN1= dxa.1
|
||||||
|
MLINKS= dxa.1 dxa65.1
|
||||||
|
|
||||||
|
PLIST_FILES= bin/dxa65
|
||||||
|
PORTDOCS= INSTALL
|
||||||
|
|
||||||
|
.include <bsd.port.options.mk>
|
||||||
|
|
||||||
|
post-patch-script:
|
||||||
|
@${REINPLACE_CMD} 's|CC = |CC ?= |g' ${WRKSRC}/Makefile
|
||||||
|
@${REINPLACE_CMD} 's|CFLAGS = |CFLAGS ?= |g' ${WRKSRC}/Makefile
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/dxa ${PREFIX}/bin/dxa65
|
||||||
|
${INSTALL_MAN} ${WRKSRC}/dxa.1 ${MAN1PREFIX}/man/man1
|
||||||
|
|
||||||
|
.if ${PORT_OPTIONS:MDOCS}
|
||||||
|
@${MKDIR} ${DOCSDIR}
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCSDIR}
|
||||||
|
.endif
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
2
devel/dxa65/distinfo
Normal file
2
devel/dxa65/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
||||||
|
SHA256 (dxa-0.1.3.tar.gz) = 1e7adb7f0306397f45ed068203d36ae6c0886c698899ba89080cbf161a31c72e
|
||||||
|
SIZE (dxa-0.1.3.tar.gz) = 23595
|
21
devel/dxa65/files/patch-label.c
Normal file
21
devel/dxa65/files/patch-label.c
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
--- label.c.orig 2006-11-01 18:23:28.000000000 +0200
|
||||||
|
+++ label.c 2010-08-31 21:45:43.000000000 +0300
|
||||||
|
@@ -40,7 +40,7 @@
|
||||||
|
#include "opcodes.h"
|
||||||
|
|
||||||
|
label *labeltable;
|
||||||
|
-char defaultlabel[5];
|
||||||
|
+char defaultlabel[6];
|
||||||
|
unsigned numLabels = 0;
|
||||||
|
|
||||||
|
#ifndef __STDC__
|
||||||
|
@@ -55,7 +55,7 @@
|
||||||
|
label *entry;
|
||||||
|
char *buffer;
|
||||||
|
|
||||||
|
- if (!((buffer = malloc (strlen (name)))))
|
||||||
|
+ if (!((buffer = malloc (strlen (name) + 1))))
|
||||||
|
return;
|
||||||
|
|
||||||
|
entry = numLabels ?
|
||||||
|
|
5
devel/dxa65/pkg-descr
Normal file
5
devel/dxa65/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
||||||
|
dxa65 is a disassembler for MOS 6502 and compatible CPUs
|
||||||
|
NMOS 6502s (such as 6502A, 6504, 6507, 6510, 7501, 8500, 8501, 8502 ...)
|
||||||
|
CMOS 6502s (65C02 and Rockwell R65C02)
|
||||||
|
|
||||||
|
WWW: http://www.floodgap.com/retrotech/xa#dxa
|
Loading…
Reference in a new issue