add wxbasic 0.52

wxBasic Programming Language
This commit is contained in:
Ying-Chieh Liao 2002-06-03 18:19:32 +00:00
parent 7f047e4f8e
commit 67972653e5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60542
7 changed files with 72 additions and 0 deletions

View file

@ -208,6 +208,7 @@
SUBDIR += tinycobol
SUBDIR += treecc
SUBDIR += wamcc
SUBDIR += wxbasic
SUBDIR += xsb
SUBDIR += yabasic
SUBDIR += yap

39
lang/wxbasic/Makefile Normal file
View file

@ -0,0 +1,39 @@
# ex:ts=8
# Ports collection makefile for: wxbasic
# Date created: Feb 10, 2002
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= wxbasic
PORTVERSION= 0.52
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= wxsource-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
USE_MESA= yes
NO_WRKSUBDIR= yes
MAKEFILE= makefile.unx
USE_GMAKE= yes
CFLAGS+= ${PTHREAD_CFLAGS}
LIBS+= -lglut -lGL -lGLU -lwx_gtk_gl ${PTHREAD_LIBS}
MAKE_ENV= CXXFLAGS="${CXXFLAGS}" LIBS="${LIBS}"
post-patch:
@${PERL} -pi -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/core.c
pre-build:
@(cd ${WRKSRC} ; \
${MV} -f wxbasic.y tmp ; ${CAT} tmp | col -b > wxbasic.y ; \
bison -o y_tab.c wxbasic.y)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wxbasic ${PREFIX}/bin
.include <bsd.port.mk>

1
lang/wxbasic/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (wxsource-0.52.tar.gz) = 980a1fdac284357287ffbca041d654b4

View file

@ -0,0 +1,17 @@
--- makefile.unx.orig Tue Jun 4 01:50:21 2002
+++ makefile.unx Tue Jun 4 01:54:42 2002
@@ -12,12 +12,12 @@
.SUFFIXES: .o .cpp
.cpp.o :
- $(CXX) -c `wx-config --cxxflags` -o $@ $<
+ $(CXX) ${CFLAGS} -c `wx-config --cxxflags` -o $@ $<
all: $(PROGRAM)
$(PROGRAM): $(OBJECTS)
- $(CXX) -o $(PROGRAM) $(OBJECTS) `wx-config --libs`
+ $(CXX) -o $(PROGRAM) $(OBJECTS) `wx-config --libs` ${LIBS}
clean:
rm -f *.o $(PROGRAM)

1
lang/wxbasic/pkg-comment Normal file
View file

@ -0,0 +1 @@
wxBasic Programming Language

12
lang/wxbasic/pkg-descr Normal file
View file

@ -0,0 +1,12 @@
wxBasic is an Basic interpreter that is:
- Free
- Open Source (LGPL)
- Cross-platform (currently Windows and Linux)
wxBasic can create stand-alone executables by binding together source code
with the interpreter.
wxBasic is written primarily in C, with some C++ linking it to the wxWindows
library. wxWindows supplies the cross-platform features.
WWW: http://wxbasic.sourceforge.net/

1
lang/wxbasic/pkg-plist Normal file
View file

@ -0,0 +1 @@
bin/wxbasic