PR: ports/11816
Submitted by: sobomax@altavista.net A network modem sharing server.
This commit is contained in:
parent
3877104668
commit
679b8e1b9e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=20112
9 changed files with 105 additions and 0 deletions
24
comms/mserver/Makefile
Normal file
24
comms/mserver/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
||||||
|
# New ports collection makefile for: mserver
|
||||||
|
# Version required: 0.23a
|
||||||
|
# Date created: 21 May 1999
|
||||||
|
# Whom: Maxim Sobolev <sobomax@altavista.net>
|
||||||
|
#
|
||||||
|
# $Id$
|
||||||
|
#
|
||||||
|
|
||||||
|
DISTNAME= mserver-0.23a
|
||||||
|
CATEGORIES= comms
|
||||||
|
MASTER_SITES= ftp://ftp.innet.be/pub/staff/carl/
|
||||||
|
|
||||||
|
MAINTAINER= sobomax@altavista.net
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
${MKDIR} ${PREFIX}/share/doc/mserver
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/mserver ${PREFIX}/sbin
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/tcpconn ${PREFIX}/sbin
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/mserver.conf ${PREFIX}/etc/mserver.conf.default
|
||||||
|
${INSTALL_SCRIPT} ${WRKSRC}/mserver.sh.sample ${PREFIX}/etc/rc.d/mserver.sh.sample
|
||||||
|
${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/mserver
|
||||||
|
${INSTALL_MAN} ${WRKSRC}/README.tcpconn ${PREFIX}/share/doc/mserver
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
1
comms/mserver/distinfo
Normal file
1
comms/mserver/distinfo
Normal file
|
@ -0,0 +1 @@
|
||||||
|
MD5 (mserver-0.23a.tar.gz) = ff3a68a80de1559b992f4de982a7b876
|
30
comms/mserver/files/patch-aa
Normal file
30
comms/mserver/files/patch-aa
Normal file
|
@ -0,0 +1,30 @@
|
||||||
|
diff -ruN mserver-0.23a.orig/Makefile mserver-0.23a/Makefile
|
||||||
|
--- Makefile.orig Thu Jan 15 21:12:33 1998
|
||||||
|
+++ Makefile Fri May 21 11:10:30 1999
|
||||||
|
@@ -1,8 +1,7 @@
|
||||||
|
#
|
||||||
|
# Makefile for mserver
|
||||||
|
#
|
||||||
|
-CC = gcc
|
||||||
|
-CCOPTS = -O2
|
||||||
|
+CC = cc
|
||||||
|
LIBS =
|
||||||
|
|
||||||
|
INCLUDES = config.h stty.h
|
||||||
|
@@ -16,13 +15,13 @@
|
||||||
|
$(CC) tcpconn.o stty.o -o tcpconn $(LIBS)
|
||||||
|
|
||||||
|
mserver.o: mserver.c $(INCLUDES)
|
||||||
|
- $(CC) $(CCOPTS) -c -o mserver.o mserver.c
|
||||||
|
+ $(CC) $(CFLAGS) -c -o mserver.o mserver.c
|
||||||
|
|
||||||
|
tcpconn.o: tcpconn.c $(INCLUDES)
|
||||||
|
- $(CC) $(CCOPTS) -c -o tcpconn.o tcpconn.c
|
||||||
|
+ $(CC) $(CFLAGS) -c -o tcpconn.o tcpconn.c
|
||||||
|
|
||||||
|
stty.o: stty.c $(INCLUDES)
|
||||||
|
- $(CC) $(CCOPTS) -c -o stty.o stty.c
|
||||||
|
+ $(CC) $(CFLAGS) -c -o stty.o stty.c
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -f mserver tcpconn *.o core
|
17
comms/mserver/files/patch-ab
Normal file
17
comms/mserver/files/patch-ab
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
diff -ruN mserver-0.23a.orig/config.h mserver-0.23a/config.h
|
||||||
|
--- config.h.orig Sun Jan 18 11:57:10 1998
|
||||||
|
+++ config.h Fri May 21 11:51:00 1999
|
||||||
|
@@ -4,7 +4,6 @@
|
||||||
|
|
||||||
|
/* #define if we are building on a BSD system */
|
||||||
|
|
||||||
|
-#undef BSD
|
||||||
|
|
||||||
|
/* location of the runtime config file */
|
||||||
|
|
||||||
|
@@ -12,5 +11,5 @@
|
||||||
|
|
||||||
|
/* location of the spool dir for modem locks */
|
||||||
|
|
||||||
|
-#define LOCK_DIR "/var/lock"
|
||||||
|
+#define LOCK_DIR "/var/spool/lock"
|
12
comms/mserver/files/patch-ac
Normal file
12
comms/mserver/files/patch-ac
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
diff -ruN mserver-0.23a.orig/mserver.c mserver-0.23a/mserver.c
|
||||||
|
--- mserver.c.orig Wed Jan 28 21:52:09 1998
|
||||||
|
+++ mserver.c Thu May 20 19:36:14 1999
|
||||||
|
@@ -264,7 +264,7 @@
|
||||||
|
|
||||||
|
static struct { int ibaud, speed; } btable[] =
|
||||||
|
{
|
||||||
|
-#if !defined(BSDI)
|
||||||
|
+#if !defined(BSD)
|
||||||
|
{ 460800, B460800 },
|
||||||
|
#endif
|
||||||
|
{ 230400, B230400 },
|
7
comms/mserver/files/patch-ad
Normal file
7
comms/mserver/files/patch-ad
Normal file
|
@ -0,0 +1,7 @@
|
||||||
|
diff -ruN mserver-0.23a.orig/mserver.sh.sample mserver-0.23a/mserver.sh.sample
|
||||||
|
--- mserver.sh.sample Thu Jan 1 03:00:00 1970
|
||||||
|
+++ mserver.sh.sample Fri May 21 12:01:53 1999
|
||||||
|
@@ -0,0 +1,3 @@
|
||||||
|
+#!/bin/sh
|
||||||
|
+echo -n " mserver"
|
||||||
|
+/usr/local/sbin/mserver
|
1
comms/mserver/pkg-comment
Normal file
1
comms/mserver/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
||||||
|
A network modem sharing server.
|
6
comms/mserver/pkg-descr
Normal file
6
comms/mserver/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
||||||
|
The mserver program is a network modem sharing server which allows modems to
|
||||||
|
be exported to any number of hosts on the (local) internet. Access control to
|
||||||
|
each individually exported modem is performed on a per-host basis.
|
||||||
|
|
||||||
|
- Maxim Sobolev
|
||||||
|
sobomax@altavista.net
|
7
comms/mserver/pkg-plist
Normal file
7
comms/mserver/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
||||||
|
sbin/mserver
|
||||||
|
sbin/tcpconn
|
||||||
|
etc/mserver.conf.default
|
||||||
|
etc/rc.d/mserver.sh.sample
|
||||||
|
share/doc/mserver/README
|
||||||
|
share/doc/mserver/README.tcpconn
|
||||||
|
@dirrm share/doc/mserver
|
Loading…
Reference in a new issue