*/*: Remove expired ports:

2020-12-31 chinese/sunpinyin: Uses Python 2.7 which is EOLed upstream
2021-06-23 chinese/fcitx-sunpinyin: Uses EOL Python 2.7 via chinese/sunpinyin
This commit is contained in:
Rene Ladan 2021-06-26 20:31:20 +02:00
parent 616f425648
commit 67bd778a71
19 changed files with 2 additions and 348 deletions

2
MOVED
View file

@ -16449,3 +16449,5 @@ math/gringo||2021-06-26|Has expired: Uses Python 2.7 which is EOLed upstream
math/aspcud||2021-06-26|Has expired: Uses EOL Python 2.7 via math/gringo
math/py-pyasp||2021-06-26|Has expired: Uses EOL Python 2.7 via math/gringo
devel/viewvc|devel/viewvc-devel|2021-06-26|Has expired: Uses Python 2.7 which is EOLed upstream
chinese/sunpinyin||2021-06-26|Has expired: Uses Python 2.7 which is EOLed upstream
chinese/fcitx-sunpinyin||2021-06-26|Has expired: Uses EOL Python 2.7 via chinese/sunpinyin

View file

@ -30,7 +30,6 @@
SUBDIR += fcitx-configtool
SUBDIR += fcitx-libpinyin
SUBDIR += fcitx-rime
SUBDIR += fcitx-sunpinyin
SUBDIR += fcitx-table-extra
SUBDIR += fcitx-ui-light
SUBDIR += fcitx5-chewing
@ -127,7 +126,6 @@
SUBDIR += sourcehansans-tc-otf
SUBDIR += sourcehanserif-sc-otf
SUBDIR += sourcehanserif-tc-otf
SUBDIR += sunpinyin
SUBDIR += taipeisanstc
SUBDIR += tin
SUBDIR += tintin++

View file

@ -1,25 +0,0 @@
# Created by: Zhihao Yuan <lichray@gmail.com>
PORTNAME= fcitx-sunpinyin
PORTVERSION= 0.4.2
PORTREVISION= 1
CATEGORIES= chinese
MASTER_SITES= http://download.fcitx-im.org/${PORTNAME}/
DIST_SUBDIR= fcitx
MAINTAINER= lichray@gmail.com
COMMENT= SunPinyin support for Fcitx
LICENSE= GPLv2
DEPRECATED= Uses EOL Python 2.7 via chinese/sunpinyin
EXPIRATION_DATE=2021-06-23
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libfcitx-config.so:chinese/fcitx \
libsunpinyin.so:chinese/sunpinyin
USES= cmake gettext gnome pkgconfig tar:xz
INSTALLS_ICONS= yes
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
TIMESTAMP = 1536753006
SHA256 (fcitx/fcitx-sunpinyin-0.4.2.tar.xz) = 0bf2d72d77732f06e7f04c119507c08b9618b21c4027e3997186bd7e4d0788c4
SIZE (fcitx/fcitx-sunpinyin-0.4.2.tar.xz) = 42984

View file

@ -1,4 +0,0 @@
fcitx-sunpinyin provides SunPinyin, a statistical language model based
input method engine, as a back-end to the Fcitx IM framework.
WWW: https://fcitx-im.org/wiki/Fcitx

View file

@ -1,9 +0,0 @@
[
{ type: install
message: <<EOM
You probably need to remove the old configurations, i.e,
rm -fr $HOME/.config/fcitx
before switching to the fcitx-sunpinyin back-end!
EOM
}
]

View file

@ -1,23 +0,0 @@
lib/fcitx/fcitx-sunpinyin.so
share/fcitx/addon/fcitx-sunpinyin.conf
share/fcitx/configdesc/fcitx-sunpinyin.desc
share/fcitx/inputmethod/sunpinyin.conf
share/fcitx/skin/classic/sunpinyin.png
share/fcitx/skin/dark/sunpinyin.png
share/fcitx/skin/default/sunpinyin.png
share/fcitx/imicon/sunpinyin.png
share/icons/hicolor/128x128/apps/fcitx-sunpinyin.png
share/icons/hicolor/16x16/apps/fcitx-sunpinyin.png
share/icons/hicolor/22x22/apps/fcitx-sunpinyin.png
share/icons/hicolor/24x24/apps/fcitx-sunpinyin.png
share/icons/hicolor/32x32/apps/fcitx-sunpinyin.png
share/icons/hicolor/48x48/apps/fcitx-sunpinyin.png
share/locale/ca/LC_MESSAGES/fcitx-sunpinyin.mo
share/locale/da/LC_MESSAGES/fcitx-sunpinyin.mo
share/locale/de/LC_MESSAGES/fcitx-sunpinyin.mo
share/locale/ja/LC_MESSAGES/fcitx-sunpinyin.mo
share/locale/ko/LC_MESSAGES/fcitx-sunpinyin.mo
share/locale/ru/LC_MESSAGES/fcitx-sunpinyin.mo
share/locale/tr/LC_MESSAGES/fcitx-sunpinyin.mo
share/locale/zh_CN/LC_MESSAGES/fcitx-sunpinyin.mo
share/locale/zh_TW/LC_MESSAGES/fcitx-sunpinyin.mo

View file

@ -1,41 +0,0 @@
# Created by: Zhihao Yuan <lichray@gmail.com>
PORTNAME= sunpinyin
DISTVERSION= 2.0.4rc3
PORTREVISION= 1
CATEGORIES= chinese devel
MASTER_SITES= SF/open-gram:2
DISTFILES= lm_sc.3gm.arpa-20140820.tar.bz2:2 dict.utf8-20131214.tar.bz2:2
MAINTAINER= lichray@gmail.com
COMMENT= Statistical language model based input method engine
LICENSE= LGPL21 CDDL
LICENSE_COMB= dual
NOT_FOR_ARCHS= riscv64
NOT_FOR_ARCHS_REASON= ./config.h:119:3: can not detect the endianness!
LIB_DEPENDS= libsqlite3.so:databases/sqlite3
USES= gmake iconv perl5 pkgconfig python:2.7 scons shebangfix
USE_GITHUB= yes
GH_TAGNAME= a8bd811
MAKE_ARGS+= --prefix=${PREFIX}
USE_LDCONFIG= yes
USE_PERL5= build
SHEBANG_FILES= python/*.py
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
INSTALL_TARGET= install-lib install-headers --install-sandbox=${STAGEDIR}
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsunpinyin.so.3.0
${SETENV} PATH=${WRKSRC}/src:$${PATH} ${GMAKE} -C ${WRKDIR} \
-f ${WRKSRC}/src/sunpinyin-dictgen.mk STAGEDIR=${STAGEDIR}
${INSTALL} -d ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKDIR}/lm_sc.t3g ${WRKDIR}/pydict_sc.bin \
${STAGEDIR}${DATADIR}
.include <bsd.port.mk>

View file

@ -1,6 +0,0 @@
SHA256 (sunpinyin-sunpinyin-2.0.4rc3-a8bd811_GH0.tar.gz) = 762575e71a5e24c4efc291407302a161ad51b8bf8902d952b54076f4511997ef
SIZE (sunpinyin-sunpinyin-2.0.4rc3-a8bd811_GH0.tar.gz) = 547083
SHA256 (lm_sc.3gm.arpa-20140820.tar.bz2) = 751bab7c55ea93a2cedfb0fbb7eb09f67d4da9c2c55496e5f31eb8580f1d1e2f
SIZE (lm_sc.3gm.arpa-20140820.tar.bz2) = 36623028
SHA256 (dict.utf8-20131214.tar.bz2) = af70bc2bcd7af7468495774fed9e3a2de434650119fbc3d3388c2bcf7e0acb01
SIZE (dict.utf8-20131214.tar.bz2) = 674512

View file

@ -1,51 +0,0 @@
--- SConstruct.orig 2014-11-14 14:17:48 UTC
+++ SConstruct
@@ -1,6 +1,7 @@
import platform
import os
import sys
+from functools import reduce
version = "2.0.4"
@@ -215,10 +216,11 @@ def CreateEnvironment():
make = 'gmake'
tar = 'gtar'
libln_builder = Builder(action='cd ${TARGET.dir} && ln -s ${SOURCE.name} ${TARGET.name}')
- env = Environment(ENV=os.environ, CFLAGS=cflags, CXXFLAGS='',
+ env = Environment(ENV=os.environ,
MAKE=make, WGET=wget, W3M=w3m, TAR=tar,
- CPPPATH=['.'] + allinc(),
- tools=['default', 'textfile'])
+ tools=['default', 'textfile'],
+ **ARGUMENTS)
+ env['CPPPATH'] = ['.'] + allinc()
env.Append(BUILDERS={'InstallAsSymlink': libln_builder})
env['ENDIANNESS'] = "be" if sys.byteorder == "big" else "le"
return env
@@ -227,7 +229,7 @@ def CreateEnvironment():
def PassVariables(envvar, env):
for (x, y) in envvar:
if x in os.environ:
- print 'Warning: you\'ve set %s in the environmental variable!' % x
+ print('Warning: you\'ve set %s in the environmental variable!' % x)
env[y] = os.environ[x]
env = CreateEnvironment()
@@ -375,7 +377,6 @@ def DoConfigure():
conf.CheckFunc('getopt_long')
conf.CheckFunc('getpagesize')
conf.CheckFunc('get_opt')
- conf.CheckCHeader('iconv.h')
conf.CheckCHeader('inttypes.h')
conf.CheckCHeader('locale.h')
conf.CheckCHeader('libintl.h')
@@ -463,7 +464,7 @@ def DoInstall():
lib_target_bin),
]
- lib_pkgconfig_target = env.Install(os.path.join(libdir, 'pkgconfig'),
+ lib_pkgconfig_target = env.Install(os.path.join(env['PREFIX'], 'libdata/pkgconfig'),
['sunpinyin-2.0.pc'])
bin_target = env.Install(bindir, bins)
man1_target = env.Install(man1dir, man1s)

View file

@ -1,11 +0,0 @@
--- man/SConscript.orig 2014-11-14 14:17:48 UTC
+++ man/SConscript
@@ -1,7 +1,7 @@
import os
Import('env')
-pod2man = Builder(action = 'pod2man < $SOURCE > $TARGET')
+pod2man = Builder(action = 'pod2man $SOURCE $TARGET')
env.Append(BUILDERS = {'Man': pod2man})
env.Man('mmseg.1', 'mmseg.pod')

View file

@ -1,11 +0,0 @@
--- src/SConscript.orig 2014-11-14 14:17:48 UTC
+++ src/SConscript
@@ -53,7 +53,7 @@ env.Substfile('sunpinyin-dictgen.mk.in', SUBST_DICT={
})
env.Command('sunpinyin-dictgen', 'sunpinyin-dictgen.mk', [
Copy("$TARGET", "$SOURCE"),
- Chmod("$TARGET", 0755),
+ Chmod("$TARGET", 0o755),
])
# -*- indent-tabs-mode: nil -*- vim:et:ts=4

View file

@ -1,18 +0,0 @@
--- src/ime-core/imi_winHandler.cpp.orig 2014-11-14 14:17:48 UTC
+++ src/ime-core/imi_winHandler.cpp
@@ -87,6 +87,7 @@ CIMIWinHandler::throwBackKey(unsigned ke
void
CIMIWinHandler::updateStatus(int key, int value)
{
+#ifdef DEBUG
switch (key) {
case STATUS_ID_CN:
printf("CN status is "); break;
@@ -101,6 +102,7 @@ CIMIWinHandler::updateStatus(int key, in
printf("%d\n", value);
fflush(stdout);
+#endif
}
// -*- indent-tabs-mode: nil -*- vim:et:ts=4

View file

@ -1,10 +0,0 @@
--- src/portability.h.orig 2014-11-14 14:17:48 UTC
+++ src/portability.h
@@ -42,6 +42,7 @@
#include <stdio.h>
#include <math.h>
#include <stdint.h>
+#include <stdlib.h>
#include <string>
#include <cstring>

View file

@ -1,17 +0,0 @@
--- src/slm/thread/slmthread.cpp.orig 2014-11-14 14:17:48 UTC
+++ src/slm/thread/slmthread.cpp
@@ -250,10 +250,10 @@ main(int argc, char* argv[])
bool usingLogPr = slm.isUseLogPr();
- #define EffectivePr(a) (float((usingLogPr) ? ((a) / log(2.0)) : (-log2((a)))))
- #define OriginalPr(b) (float((usingLogPr) ? ((b) * log(2.0)) : (exp2(-(b)))))
- #define EffectiveBow(a) (float((usingLogPr) ? (exp(-(a))) : ((a))))
- #define OriginalBow(b) (float((usingLogPr) ? (-log((b))) : ((b))))
+ #define EffectivePr(a) (float((usingLogPr) ? ((a) / logf(2.0f)) : (-log2f((a)))))
+ #define OriginalPr(b) (float((usingLogPr) ? ((b) * logf(2.0f)) : (exp2f(-(b)))))
+ #define EffectiveBow(a) (float((usingLogPr) ? (expf(-(a))) : ((a))))
+ #define OriginalBow(b) (float((usingLogPr) ? (-logf((b))) : ((b))))
printf("\nfirst pass..."); fflush(stdout);
for (int lvl = 0; lvl <= slm.getN(); ++lvl) {

View file

@ -1,26 +0,0 @@
--- src/sunpinyin-dictgen.mk.in.orig 2014-11-14 14:17:48 UTC
+++ src/sunpinyin-dictgen.mk.in
@@ -42,22 +42,7 @@ DL_ROOT = ${DL_HOST}/open-gram
DICT_PAT = 'dict\.utf8-[0-9]\+.tar.bz2'
SLM_PAT = 'lm_sc\.3gm\.arpa-[0-9]\+.tar.bz2'
-DICT_AR = $(shell ${W3M} ${DL_LIST} | grep -o ${DICT_PAT} | sort | tail -n 1)
-SLM_AR = $(shell ${W3M} ${DL_LIST} | grep -o ${SLM_PAT} | sort | tail -n 1)
-
-all: install
-
-${DICT_AR}:
- ${WGET} ${DL_ROOT}/$@
-
-dict.utf8: ${DICT_AR}
- ${TAR} xmf $^
-
-${SLM_AR}:
- ${WGET} ${DL_ROOT}/$@
-
-lm_sc.3gm.arpa: ${SLM_AR}
- ${TAR} xmf $^
+all: lm_sc.t3g pydict_sc.bin
lm_sc.3gm: lm_sc.3gm.arpa dict.utf8
slmpack $^ $@

View file

@ -1,35 +0,0 @@
--- src/ime-core/imi_options.cpp.orig 2014-11-14 14:17:48 UTC
+++ src/ime-core/imi_options.cpp
@@ -73,12 +73,15 @@ CSimplifiedChinesePolicy::loadResources(
if (!m_user_data_dir.size()) {
char path[256];
- const char *home = getenv("HOME");
- snprintf(path,
- sizeof(path),
- "%s/%s",
- home,
- SUNPINYIN_USERDATA_DIR_PREFIX);
+ const char *home = getenv("XDG_CONFIG_HOME");
+ if (home == NULL)
+ snprintf(path, sizeof(path),
+ "%s/.config/%s", getenv("HOME"),
+ SUNPINYIN_USERDATA_DIR_PREFIX);
+ else
+ snprintf(path, sizeof(path),
+ "%s/%s", home,
+ SUNPINYIN_USERDATA_DIR_PREFIX);
m_user_data_dir = path;
}
--- src/ime-core/imi_options.h.orig 2014-11-14 14:17:48 UTC
+++ src/ime-core/imi_options.h
@@ -52,7 +52,7 @@
#include "pinyin/hunpin_seg.h"
#ifndef SUNPINYIN_USERDATA_DIR_PREFIX
-#define SUNPINYIN_USERDATA_DIR_PREFIX ".sunpinyin"
+#define SUNPINYIN_USERDATA_DIR_PREFIX "sunpinyin"
#endif
struct CSimplifiedChinesePolicy : public IConfigurable {

View file

@ -1,5 +0,0 @@
SunPinyin is a statistical language model based Chinese input method, which
was firstly developed by Sun Beijing Globalization team, and opensource'd
to community with OpenSolaris project, with LGPLv2 and CDDL dual-licenses.
WWW: http://code.google.com/p/sunpinyin/

View file

@ -1,51 +0,0 @@
include/sunpinyin-2.0/ime-core/ic_history.h
include/sunpinyin-2.0/ime-core/imi_context.h
include/sunpinyin-2.0/ime-core/imi_data.h
include/sunpinyin-2.0/ime-core/imi_defines.h
include/sunpinyin-2.0/ime-core/imi_funcobjs.h
include/sunpinyin-2.0/ime-core/imi_glibHandler.h
include/sunpinyin-2.0/ime-core/imi_keys.h
include/sunpinyin-2.0/ime-core/imi_option_event.h
include/sunpinyin-2.0/ime-core/imi_option_keys.h
include/sunpinyin-2.0/ime-core/imi_options.h
include/sunpinyin-2.0/ime-core/imi_uiobjects.h
include/sunpinyin-2.0/ime-core/imi_view.h
include/sunpinyin-2.0/ime-core/imi_view_classic.h
include/sunpinyin-2.0/ime-core/imi_winHandler.h
include/sunpinyin-2.0/ime-core/lattice_states.h
include/sunpinyin-2.0/ime-core/userdict.h
include/sunpinyin-2.0/ime-core/utils.h
include/sunpinyin-2.0/lexicon/pytrie.h
include/sunpinyin-2.0/lexicon/pytrie_gen.h
include/sunpinyin-2.0/lexicon/trie_writer.h
include/sunpinyin-2.0/pinyin/datrie.h
include/sunpinyin-2.0/pinyin/datrie_impl.h
include/sunpinyin-2.0/pinyin/hunpin_seg.h
include/sunpinyin-2.0/pinyin/pinyin_data.h
include/sunpinyin-2.0/pinyin/pinyin_seg.h
include/sunpinyin-2.0/pinyin/quanpin_trie.h
include/sunpinyin-2.0/pinyin/segmentor.h
include/sunpinyin-2.0/pinyin/shuangpin_data.h
include/sunpinyin-2.0/pinyin/shuangpin_seg.h
include/sunpinyin-2.0/pinyin/syllable.h
include/sunpinyin-2.0/portability.h
include/sunpinyin-2.0/slm/ids2ngram/idngram.h
include/sunpinyin-2.0/slm/ids2ngram/idngram_merge.h
include/sunpinyin-2.0/slm/sim_dict.h
include/sunpinyin-2.0/slm/sim_fmerge.h
include/sunpinyin-2.0/slm/sim_sen.h
include/sunpinyin-2.0/slm/sim_slm.h
include/sunpinyin-2.0/slm/slm.h
include/sunpinyin-2.0/slm/slmbuild/sim_slmbuilder.h
include/sunpinyin-2.0/slm/slmpack/arpa_slm.h
include/sunpinyin-2.0/slm/slmpack/common.h
include/sunpinyin-2.0/slm/thread/ValueCompress.h
include/sunpinyin-2.0/slm/tslmendian/slm_file.h
include/sunpinyin-2.0/slm/tslmendian/writer.h
include/sunpinyin-2.0/sunpinyin.h
lib/libsunpinyin.so
lib/libsunpinyin.so.3
lib/libsunpinyin.so.3.0
libdata/pkgconfig/sunpinyin-2.0.pc
%%DATADIR%%/lm_sc.t3g
%%DATADIR%%/pydict_sc.bin