cleanup: Remove expired ports:

2022-06-30 security/ruby-bitwarden: Broken with all supported versions of Ruby
2022-06-30 mail/rubygem-tmail: Broken with all supported versions of Ruby
2022-06-30 www/redmine4: Deprecated by upstream. Please consider using www/redmine42
This commit is contained in:
Rene Ladan 2022-06-30 21:47:23 +02:00
parent f599046f3b
commit 67fa95f7c4
26 changed files with 3 additions and 2758 deletions

3
MOVED
View file

@ -17365,3 +17365,6 @@ security/libgringotts||2022-06-30|Has expired: Abandonware, upstream dead and la
deskutils/osmo||2022-06-30|Has expired: Depends on expired security/libgringotts
devel/itext||2022-06-30|Has expired: Outdated version and deprecated by upstream
audio/tuxguitar||2022-06-30|Has expired: Depends on expired devel/itext
security/ruby-bitwarden||2022-06-30|Has expired: Broken with all supported versions of Ruby
mail/rubygem-tmail||2022-06-30|Has expired: Broken with all supported versions of Ruby
www/redmine4|www/redmine42|2022-06-30|Has expired: Deprecated by upstream. Please consider using www/redmine42

View file

@ -611,7 +611,6 @@
SUBDIR += rubygem-roadie-rails-rails52
SUBDIR += rubygem-roadie3
SUBDIR += rubygem-ruby-qmail
SUBDIR += rubygem-tmail
SUBDIR += rubygem-valid_email
SUBDIR += rubygem-vmail
SUBDIR += s-nail

View file

@ -1,23 +0,0 @@
# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
PORTNAME= tmail
PORTVERSION= 1.2.7.1
CATEGORIES= mail rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= RFC2822/MIME compliant mail manipulating library for Ruby
DEPRECATED= Broken with all supported versions of Ruby
EXPIRATION_DATE= 2022-06-30
# Seems to be a dead project, last upgrade 2010-02-07 and homepage does not load anymore:
# https://rubygems.org/gems/tmail, http://tmail.rubyforge.org/
BROKEN_RUBY27= yes
BROKEN_RUBY30= yes
BROKEN_RUBY31= yes
USE_RUBY= yes
USES= gem
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (rubygem/tmail-1.2.7.1.gem) = 9e4153e48c7f618ce6b22a44b5671ec5b9e49d16c693c3ee8b93397e9d78ca41
SIZE (rubygem/tmail-1.2.7.1.gem) = 446464

View file

@ -1,4 +0,0 @@
TMail is a mail manipulating library for Ruby, with RFC822 and MIME
multipart support.
WWW: https://rubygems.org/gems/tmail

View file

@ -1015,7 +1015,6 @@
SUBDIR += rkhunter
SUBDIR += rndpassw
SUBDIR += rnp
SUBDIR += ruby-bitwarden
SUBDIR += rubygem-acme-client
SUBDIR += rubygem-aes_key_wrap
SUBDIR += rubygem-airbrussh

View file

@ -1,43 +0,0 @@
# Created by: Mark Felder <feld@FreeBSD.org>
PORTNAME= rubywarden
DISTVERSION= 0.0.0.20200226
PORTREVISION= 0
CATEGORIES= security www
MAINTAINER= mr@FreeBSD.org
COMMENT= Ruby implementation of the BitWarden API
LICENSE= ISCL
DEPRECATED= Broken with all supported versions of Ruby
EXPIRATION_DATE= 2022-06-30
# Port is not maintained anymore:
# https://github.com/jcs/rubywarden
BROKEN_RUBY27= yes
BROKEN_RUBY30= yes
BROKEN_RUBY31= yes
RUN_DEPENDS= rubygem-bundler>=1.16:sysutils/rubygem-bundler
USES= sqlite
USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
USE_GITHUB= yes
GH_ACCOUNT= jcs
GH_TAGNAME= 549f66466ca753ee2f3c007b6e242d59dae05fdd
NO_ARCH= yes
NO_BUILD= yes
USE_RC_SUBR= rubywarden-api
SUB_FILES= pkg-message
SUB_LIST+= RUBY_WITH_SUFFIX="${RUBY_WITH_SUFFIX}"
do-install:
${MKDIR} ${STAGEDIR}/${WWWDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}/${WWWDIR})
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
TIMESTAMP = 1584823928
SHA256 (jcs-rubywarden-0.0.0.20200226-549f66466ca753ee2f3c007b6e242d59dae05fdd_GH0.tar.gz) = c5ba2fbbdbf1cb444e2cb654c67feff104af2922aefe76099a9ae1ac9a54b378
SIZE (jcs-rubywarden-0.0.0.20200226-549f66466ca753ee2f3c007b6e242d59dae05fdd_GH0.tar.gz) = 39239

View file

@ -1,10 +0,0 @@
[
{ type: install
message: <<EOM
After installation of this port you have to install the necessary
rubygem dependencies.
Follow the instructions in %%WWWDIR%%/README.md
EOM
}
]

View file

@ -1,47 +0,0 @@
#!/bin/sh
#
# Created by: Mark Felder <feld@FreeBSD.org>
# PROVIDE: rubywarden-api
# REQUIRE: LOGIN
# KEYWORD: shutdown
#
# Add the following line to /etc/rc.conf to enable `rubywarden-api':
#
# rubywarden_api_enable="YES"
. /etc/rc.subr
name=rubywarden_api
rcvar=rubywarden_api_enable
load_rc_config ${name}
: ${rubywarden_api_enable:=NO}
: ${rubywarden_api_host:=localhost}
: ${rubywarden_api_port:=4567}
: ${rubywarden_api_signups:=NO}
: ${rubywarden_api_user:=www}
: ${rubywarden_api_group:=www}
: ${rubywarden_api_chdir=/usr/local/www/rubywarden}
pidfile="/var/run/rubywarden/${name}.pid"
procname=%%RUBY_WITH_SUFFIX%%
command="%%PREFIX%%/bin/rackup"
command_args="-P ${pidfile} -o ${rubywarden_api_host} -p ${rubywarden_api_port} -E production config.ru 2>&1 | logger -t rubywarden &"
start_precmd="start_precmd"
start_precmd()
{
if [ ! -e /var/run/rubywarden ] ; then
install -d -o ${rubywarden_api_user} -g ${rubywarden_api_group} /var/run/rubywarden;
fi
checkyesno rubywarden_api_signups
if [ "$?" -eq 0 ]; then
export ALLOW_SIGNUPS=1
echo "Bitwarden Signups Enabled"
fi
}
run_rc_command "$1"

View file

@ -1,4 +0,0 @@
A small, self-contained API server written in Ruby and Sinatra to
provide a private backend for the open-source Bitwarden apps.
WWW: https://github.com/jcs/rubywarden

View file

@ -1,60 +0,0 @@
%%WWWDIR%%/.gitignore
%%WWWDIR%%/API.md
%%WWWDIR%%/AR-MIGRATE.md
%%WWWDIR%%/Gemfile
%%WWWDIR%%/Gemfile.lock
%%WWWDIR%%/LICENSE
%%WWWDIR%%/README.md
%%WWWDIR%%/Rakefile
%%WWWDIR%%/config.ru
%%WWWDIR%%/db/.gitkeep
%%WWWDIR%%/db/config.yml
%%WWWDIR%%/db/migrate/20180324145941_create_users.rb
%%WWWDIR%%/db/migrate/20180324151103_create_devices.rb
%%WWWDIR%%/db/migrate/20180324151113_create_folders.rb
%%WWWDIR%%/db/migrate/20180324151117_create_ciphers.rb
%%WWWDIR%%/db/migrate/20180518070354_set_default_value_for_favorite.rb
%%WWWDIR%%/db/migrate/20180818095054_create_attachments.rb
%%WWWDIR%%/db/migrate/20180818201731_user_kdf_iterations.rb
%%WWWDIR%%/db/migrate/20180818212323_add_user_kdf_type.rb
%%WWWDIR%%/db/migrate/20190419171915_drop_attachments_url.rb
%%WWWDIR%%/db/migrate/201905%%RUBY_SUFFIX%%014920_password_history.rb
%%WWWDIR%%/db/migrate/20190724163354_no_null_kdf_iterations.rb
%%WWWDIR%%/lib/app.rb
%%WWWDIR%%/lib/attachment.rb
%%WWWDIR%%/lib/bitwarden.rb
%%WWWDIR%%/lib/cipher.rb
%%WWWDIR%%/lib/db.rb
%%WWWDIR%%/lib/dbmodel.rb
%%WWWDIR%%/lib/device.rb
%%WWWDIR%%/lib/folder.rb
%%WWWDIR%%/lib/helper.rb
%%WWWDIR%%/lib/helpers/attachment_helpers.rb
%%WWWDIR%%/lib/helpers/request_helpers.rb
%%WWWDIR%%/lib/routes/api.rb
%%WWWDIR%%/lib/routes/attachments.rb
%%WWWDIR%%/lib/routes/icons.rb
%%WWWDIR%%/lib/routes/identity.rb
%%WWWDIR%%/lib/rubywarden.rb
%%WWWDIR%%/lib/user.rb
%%WWWDIR%%/spec/attachment_spec.rb
%%WWWDIR%%/spec/bitwarden_importer_spec.rb
%%WWWDIR%%/spec/cipher_spec.rb
%%WWWDIR%%/spec/cipherstring_spec.rb
%%WWWDIR%%/spec/db_spec.rb
%%WWWDIR%%/spec/fixtures/bitwarden_export.csv
%%WWWDIR%%/spec/folder_spec.rb
%%WWWDIR%%/spec/icon_spec.rb
%%WWWDIR%%/spec/identity_spec.rb
%%WWWDIR%%/spec/spec_helper.rb
%%WWWDIR%%/spec/support/factories.rb
%%WWWDIR%%/spec/support/request_helpers.rb
%%WWWDIR%%/spec/user_spec.rb
%%WWWDIR%%/tools/1password_import.rb
%%WWWDIR%%/tools/activate_totp.rb
%%WWWDIR%%/tools/bitwarden_import.rb
%%WWWDIR%%/tools/change_master_password.rb
%%WWWDIR%%/tools/keepass_import.rb
%%WWWDIR%%/tools/lastpass_import.rb
%%WWWDIR%%/tools/migrate_to_ar.rb
%%WWWDIR%%/tools/mitm.rb

View file

@ -1827,7 +1827,6 @@
SUBDIR += qutebrowser
SUBDIR += radicale
SUBDIR += rearx
SUBDIR += redmine4
SUBDIR += redmine42
SUBDIR += rejik
SUBDIR += reportmagic

View file

@ -1,106 +0,0 @@
PORTNAME= redmine
PORTVERSION= 4.1.7
CATEGORIES= www
MASTER_SITES= https://www.redmine.org/releases/
PKGNAMESUFFIX= 4
MAINTAINER= mikael@FreeBSD.org
COMMENT= Flexible project management web application
DEPRECATED= Deprecated by upstream. Please consider using www/redmine42
EXPIRATION_DATE=2022-06-30
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/doc/COPYING
PORTSCOUT= limit:^4\.1\.
RUN_DEPENDS= rubygem-bundler>=1.5.0:sysutils/rubygem-bundler \
rubygem-rails52>=5.2.6<5.3:www/rubygem-rails52 \
rubygem-rouge312>=3.12.0:textproc/rubygem-rouge312 \
rubygem-request_store14>=1.0.5:devel/rubygem-request_store14 \
rubygem-mini_mime>=1.0.1:mail/rubygem-mini_mime \
rubygem-actionpack-xml_parser-rails52>=0:textproc/rubygem-actionpack-xml_parser-rails52 \
rubygem-roadie-rails-rails52>=2.1.0:mail/rubygem-roadie-rails-rails52 \
rubygem-mail>=2.7.1:mail/rubygem-mail \
rubygem-csv>=3.1.1:devel/rubygem-csv \
rubygem-nokogiri111>=1.11.0:textproc/rubygem-nokogiri111 \
rubygem-i18n>=0.7:devel/rubygem-i18n \
rubygem-rbpdf>=1.19.6:print/rubygem-rbpdf \
rubygem-net-ldap>=0.16:net/rubygem-net-ldap \
rubygem-ruby-openid>=2.9.2:net/rubygem-ruby-openid \
rubygem-rack-openid>=0:www/rubygem-rack-openid \
rubygem-rake>=0:devel/rubygem-rake
USES= cpe
USE_RUBY= yes
BROKEN_RUBY30= yes
BROKEN_RUBY31= yes
CONFLICTS_INSTALL= redmine42
NO_ARCH= yes
NO_BUILD= yes
USERS= ${WWWOWN}
GROUPS= ${WWWGRP}
PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
SUB_LIST= RUBY_SUFFIX=${RUBY_SUFFIX}
OPTIONS_DEFINE= MYSQL POSTGRESQL MARKDOWN RMAGIC THIN
OPTIONS_DEFAULT=MYSQL MARKDOWN RMAGIC THIN
OPTIONS_SUB= yes
POSTGRESQL_DESC=Enable PostgreSQL support
MARKDOWN_DESC= Enable Markdown support
RMAGIC_DESC= Enable Gantt charts support
THIN_DESC= Use Thin WEB server
MYSQL_DESC= MySQL database support (via mysql2 rubygem)
NO_OPTIONS_SORT= yes
MYSQL_RUN_DEPENDS= rubygem-mysql2>=0.5.0:databases/rubygem-mysql2
POSTGRESQL_RUN_DEPENDS= rubygem-pg>=1.1.4:databases/rubygem-pg
MARKDOWN_RUN_DEPENDS= rubygem-redcarpet>=3.4.0:textproc/rubygem-redcarpet
RMAGIC_RUN_DEPENDS= rubygem-mini_magick>=4.9.5:graphics/rubygem-mini_magick
THIN_RUN_DEPENDS= rubygem-thin>=1.6.2:www/rubygem-thin
THIN_SUB_LIST= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
THIN_VARS= USE_RC_SUBR=redmine
.include <bsd.port.options.mk>
post-extract:
@${RM} -r ${WRKSRC}/.hgignore ${WRKSRC}/.gitignore ${WRKSRC}/.github \
${WRKSRC}/files/delete.me ${WRKSRC}/log/delete.me
@${MV} ${WRKSRC}/config/settings.yml ${WRKSRC}/config/settings.yml.sample
@${MV} ${WRKSRC}/config/database.yml.example ${WRKSRC}/config/database.yml.sample
post-patch:
@${RM} ${WRKSRC}/Gemfile.orig
do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
${MKDIR} ${STAGEDIR}${WWWDIR}/bundler.d
${MKDIR} ${STAGEDIR}${WWWDIR}/log
${MKDIR} ${STAGEDIR}${WWWDIR}/public/plugin_assets
${MKDIR} ${STAGEDIR}${WWWDIR}/tmp
cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
${TOUCH} ${STAGEDIR}${WWWDIR}/Gemfile.lock
do-install-MYSQL-on:
${CP} ${FILESDIR}/mysql.rb ${STAGEDIR}${WWWDIR}/bundler.d
do-install-POSTGRESQL-on:
${CP} ${FILESDIR}/pg.rb ${STAGEDIR}${WWWDIR}/bundler.d
do-install-MARKDOWN-on:
${CP} ${FILESDIR}/markdown.rb ${STAGEDIR}${WWWDIR}/bundler.d
do-install-RMAGIC-on:
${CP} ${FILESDIR}/mini_magick.rb ${STAGEDIR}${WWWDIR}/bundler.d
do-install-THIN-on:
${CP} ${FILESDIR}/thin.rb ${STAGEDIR}${WWWDIR}/bundler.d
post-install:
(cd ${STAGEDIR}${WWWDIR} && ${RM} Gemfile.lock && bundle install --local)
.include <bsd.port.mk>

View file

@ -1,78 +0,0 @@
# Module that simplifies installation of Redmine plugins.
#
# Date created: 2010-09-12
# Whom: Eygene Ryabinkin <rea-fbsd@codelabs.ru>
#
# We're assuming standard plugin installation sequence that is described
# in the https://www.redmine.org/projects/redmine/wiki/Plugins
#
# Basically, we need the following variables to be defined:
# - REDMINE_PLUGIN_NAME: the name of the plugin;
# - WWWDIR: the location of the Redmine installation;
# the default value is ${PREFIX}/www/redmine;
# the directory must lie under ${PREFIX} or such configuration
# will be IGNORE'd;
# - WRKSRC must be set to the root directory of the plugin contents:
# we will copy all objects in this directory to the plugin's
# destination directory, excluding all files named *.orig.
#
# PLIST will be generated automatically, there is no need to worry
# about it. But if you will need to use your own (even the standard
# packaging list in ${PORTDIR}/pkg-plist), set the variable PLIST
# pointing to that file.
#
# You can override the target 'do-build', but in this case, you should
# remember that the target named 'redmine-plugin-plist' does the
# automated generation of the PLIST: use it if you need.
#
#
# Here is an example of a simple Makefile for Redmine plugin:
# {{{
# PORTNAME= me-the-plugin
# PORTVERSION= 1.0
# CATEGORIES= www
# MASTER_SITES= http://cool.org.name/some/path/
#
# MAINTAINER= you@your.org
# COMMENT= Another cool plugin for Redmine
#
# REDMINE_PLUGIN_NAME= redmine_http_auth
#
# .include "${.CURDIR}/../../www/redmine/bsd.redmine.mk"
# }}}
PKGNAMEPREFIX?= redmine4-
RUN_DEPENDS+= redmine4>=4.0:www/redmine4
USE_RUBY= yes
.if !defined(PLIST)
PLIST= ${WRKDIR}/PLIST
_GEN_PLIST= YesPlease
.endif
WWWDIR?= ${PREFIX}/www/redmine
WWWDIR_REL= ${WWWDIR:S|^${PREFIX}/||}
.if ${WWWDIR_REL} == ${WWWDIR}
IGNORE= WWWDIR is not a child of PREFIX (${PREFIX})
.endif
.if !defined(do-build)
do-build: redmine-plugin-plist
@${DO_NADA}
.endif
redmine-plugin-plist:
.if defined(_GEN_PLIST)
cd ${WRKSRC} && ${FIND} . -type f | ${GREP} -v '\.orig$$' | ${SED} -e's|^\.|${WWWDIR_REL}/plugins/${REDMINE_PLUGIN_NAME}|' >> ${PLIST}
cd ${WRKSRC} && ${FIND} -d . -empty -type d | ${SED} -e's|^\.|@dir ${WWWDIR_REL}/plugins/${REDMINE_PLUGIN_NAME}|' >> ${PLIST}
.else
@${DO_NADA}
.endif
do-install:
${MKDIR} "${STAGEDIR}${WWWDIR}/plugins/${REDMINE_PLUGIN_NAME}"
${TAR} -C "${WRKSRC}" -cf - --exclude '*.orig' . | ${TAR} -C "${STAGEDIR}${WWWDIR}/plugins/${REDMINE_PLUGIN_NAME}" -xf -
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
TIMESTAMP = 1648644318
SHA256 (redmine-4.1.7.tar.gz) = bf56cade5d0a6623af590652bffe2865208f399fe77746d4e1bbd9d1a995a38a
SIZE (redmine-4.1.7.tar.gz) = 2723718

View file

@ -1 +0,0 @@
gem "redcarpet", ">= 3.4.0"

View file

@ -1 +0,0 @@
gem "mini_magick", ">= 4.9.5"

View file

@ -1 +0,0 @@
gem "mysql2", "~> 0.5.0"

View file

@ -1,116 +0,0 @@
--- Gemfile.orig 2021-04-22 10:46:10 UTC
+++ Gemfile
@@ -1,21 +1,21 @@ source 'https://rubygems.org'
source 'https://rubygems.org'
-ruby '>= 2.3.0', '< 2.7.0' if Bundler::VERSION >= '1.12.0'
+ruby '>= 2.3.0', '< 2.8.0' if Bundler::VERSION >= '1.12.0'
gem "bundler", ">= 1.5.0"
-gem 'rails', '5.2.6.3'
+gem 'rails', '~> 5.2.6'
gem 'sprockets', '~> 3.7.2' if RUBY_VERSION < '2.5'
gem 'globalid', '~> 0.4.2' if Gem.ruby_version < Gem::Version.new('2.6.0')
gem "rouge", "~> 3.12.0"
gem "request_store", "~> 1.4.1"
-gem "mini_mime", "~> 1.0.1"
+gem "mini_mime", ">= 1.0.1"
gem "actionpack-xml_parser"
-gem "roadie-rails", (RUBY_VERSION < "2.5" ? "~> 1.3.0" : "~> 2.1.0")
+gem "roadie-rails", (RUBY_VERSION < "2.5" ? "~> 1.3.0" : "~> 2.2.0")
gem 'marcel'
gem "mail", "~> 2.7.1"
-gem 'csv', (RUBY_VERSION < '2.5' ? ['>= 3.1.1', '<= 3.1.5'] : '~> 3.1.1')
+gem 'csv', (RUBY_VERSION < '2.5' ? ['>= 3.1.1', '<= 3.1.5'] : '~> 3.2.0')
gem 'nokogiri', (RUBY_VERSION < '2.5' ? '~> 1.10.0' : '~> 1.11.1')
-gem "i18n", "~> 1.6.0"
+gem "i18n", ">= 1.6.0"
gem "rbpdf", "~> 1.20.0"
# Windows does not include zoneinfo files, so bundle the tzinfo-data gem
@@ -23,7 +23,7 @@ group :ldap do
# Optional gem for LDAP authentication
group :ldap do
- gem "net-ldap", "~> 0.16.0"
+ gem "net-ldap", ">= 0.17.0"
end
# Optional gem for OpenID authentication
@@ -32,67 +32,6 @@ end
gem "rack-openid"
end
-# Optional gem for exporting the gantt to a PNG file
-group :minimagick do
- gem "mini_magick", "~> 4.9.5"
-end
-
-# Optional Markdown support, not for JRuby
-group :markdown do
- gem 'redcarpet', '~> 3.5.1'
-end
-
-# Include database gems for the adapters found in the database
-# configuration file
-require 'erb'
-require 'yaml'
-database_file = File.join(File.dirname(__FILE__), "config/database.yml")
-if File.exist?(database_file)
- yaml_config = ERB.new(IO.read(database_file)).result
- database_config = YAML.respond_to?(:unsafe_load) ? YAML.unsafe_load(yaml_config) : YAML.load(yaml_config)
- adapters = database_config.values.map {|c| c['adapter']}.compact.uniq
- if adapters.any?
- adapters.each do |adapter|
- case adapter
- when 'mysql2'
- gem "mysql2", "~> 0.5.0", :platforms => [:mri, :mingw, :x64_mingw]
- when /postgresql/
- gem "pg", "~> 1.1.4", :platforms => [:mri, :mingw, :x64_mingw]
- when /sqlite3/
- gem "sqlite3", "~> 1.4.0", :platforms => [:mri, :mingw, :x64_mingw]
- when /sqlserver/
- gem "tiny_tds", "~> 2.1.2", :platforms => [:mri, :mingw, :x64_mingw]
- gem "activerecord-sqlserver-adapter", "~> 5.2.1", :platforms => [:mri, :mingw, :x64_mingw]
- else
- warn("Unknown database adapter `#{adapter}` found in config/database.yml, use Gemfile.local to load your own database gems")
- end
- end
- else
- warn("No adapter found in config/database.yml, please configure it first")
- end
-else
- warn("Please configure your config/database.yml first")
-end
-
-group :development do
- gem "yard"
-end
-
-group :test do
- gem "rails-dom-testing"
- gem 'mocha', '>= 1.4.0'
- gem "simplecov", "~> 0.17.0", :require => false
- gem "ffi", platforms: [:mingw, :x64_mingw, :mswin]
- # For running system tests
- gem 'puma', '~> 3.7'
- gem "capybara", (RUBY_VERSION < "2.4" ? "~> 3.15.1" : "~> 3.25.0")
- gem "selenium-webdriver"
- # RuboCop
- gem 'rubocop', '~> 0.76.0'
- gem 'rubocop-performance', '~> 1.5.0'
- gem 'rubocop-rails', '~> 2.3.0'
-end
-
local_gemfile = File.join(File.dirname(__FILE__), "Gemfile.local")
if File.exists?(local_gemfile)
eval_gemfile local_gemfile
@@ -101,4 +40,8 @@ Dir.glob File.expand_path("../plugins/*/{Gemfile,Plugi
# Load plugins' Gemfiles
Dir.glob File.expand_path("../plugins/*/{Gemfile,PluginGemfile}", __FILE__) do |file|
eval_gemfile file
+end
+
+Dir["#{File.dirname(__FILE__)}/bundler.d/*.rb"].each do |bundle|
+ self.instance_eval(Bundler.read_file(bundle))
end

View file

@ -1 +0,0 @@
gem "pg", "> 1.1.4"

View file

@ -1,38 +0,0 @@
#!/bin/sh
# PROVIDE: redmine
# REQUIRE: LOGIN
# KEYWORD: shutdown
# Add the following line to /etc/rc.conf[.local] to enable redmine
#
# redmine_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable redmine.
# redmine_flags (str): Custom additional arguments to be passed
# to redmine.
# redmine_user (str): User account to run thin with. (default: %%WWWOWN%%)
# redmine_group (str): Group to run thin with. (default: %%WWWGRP%%)
. /etc/rc.subr
name="redmine"
rcvar=redmine_enable
command=ruby%%RUBY_SUFFIX%%
pidfile="%%WWWDIR%%/tmp/pids/thin.pid"
load_rc_config $name
# add /usr/local/bin to path
export PATH=$PATH:%%PREFIX%%/bin
# set defaults
: ${redmine_enable="NO"}
: ${redmine_flags="-a 0.0.0.0 -p 3000 -e production"}
: ${redmine_user="%%WWWOWN%%"}
: ${redmine_group="%%WWWGRP%%"}
command_args="-d -D -c %%WWWDIR%% -u ${redmine_user} -g ${redmine_group}"
start_cmd="%%PREFIX%%/bin/thin ${command_args} ${redmine_flags} start"
run_rc_command "$1"

View file

@ -1 +0,0 @@
gem "thin", ">= 1.6.2"

View file

@ -1,23 +0,0 @@
Redmine is a flexible project management web application
written using Ruby on Rails framework, it is cross-platform
and cross-database.
Feature Overview:
* Multiple projects support
* Flexible role based access control
* Flexible issue tracking system
* Gantt chart and calendar
* News, documents & files management
* Feeds & email notifications
* Per project wiki
* Per project forums
* Time tracking
* Custom fields for issues, time-entries, projects and users
* SCM integration (SVN, CVS, Git, Mercurial, Bazaar and Darcs)
* Issue creation via email
* Multiple LDAP authentication support
* User self-registration support
* Multilanguage support
* Multiple databases support
WWW: https://www.redmine.org/

View file

@ -1,18 +0,0 @@
[
{ type: install
message: <<EOM
Redmine was installed.
You now need to setup your Redmine installation so
please have a look at the Installation Guide.
https://www.redmine.org/projects/redmine/wiki/RedmineInstall
If you are upgrading please read the Upgrading Guide
before starting the new version.
https://www.redmine.org/projects/redmine/wiki/RedmineUpgrade
EOM
}
]

File diff suppressed because it is too large Load diff