devel/gmake: Update to 4.4.1

Some ports required patches.

PR:		272216
Exp-run by:	antoine
This commit is contained in:
Kenji Takefu 2023-07-12 10:58:28 +02:00 committed by Tijl Coosemans
parent 8236c093d4
commit 687edfacdc
20 changed files with 168 additions and 192 deletions

View File

@ -12,7 +12,7 @@ _INCLUDE_USES_GMAKE_MK= yes
IGNORE= Incorrect 'USES+= gmake:${gmake_ARGS}' gmake takes no arguments
. endif
BUILD_DEPENDS+= gmake>=4.3:devel/gmake
BUILD_DEPENDS+= gmake>=4.4.1:devel/gmake
CONFIGURE_ENV+= MAKE=gmake
MAKE_CMD= gmake

View File

@ -1,6 +1,15 @@
--- main/Makefile.orig 2017-10-21 14:01:07 UTC
+++ main/Makefile
@@ -133,15 +133,15 @@ $(BINDIR)/flite_${VOICE}: flite_main.o flite_lang_list
@@ -49,7 +49,7 @@ ALL = shared_libs \
$(BINDIR)/flite$(EXEEXT) \
$(BINDIR)/t2p$(EXEEXT) $(BINDIR)/compile_regexes$(EXEEXT) \
$(BINDIR)/flitevox_info$(EXEEXT) \
- flite_voice_list.c each $(EXTRABINS)
+ each $(EXTRABINS)
VOICES=$(VOXES)
VOICELIBS=$(VOICES:%=flite_%)
@@ -133,15 +133,15 @@ install:
install:
# The basic binaries

View File

@ -17,6 +17,7 @@ BUILD_DEPENDS= nasm:devel/nasm
USES= gmake
USE_GCC= yes
MAKE_ARGS= OS="${OPSYS:tu}" KERNEL="${OSREL:S/.//g}" CC="${CC}" LD="${LD}"
MAKE_JOBS_UNSAFE=yes
# This will play merry hell with portlint(1)
BINARIES= bonus/asmutils basename cal cat chmod chown chroot cmp cp \

View File

@ -1,6 +1,24 @@
--- src/Makefile.orig 2019-11-04 16:42:35 UTC
+++ src/Makefile
@@ -207,12 +207,13 @@ mkerr:
@@ -153,7 +153,7 @@ build/%.o: %.cpp
# Dependency generation rules
# See https://www.gnu.org/software/make/manual/html_node/Automatic-Prerequisites.html
-dep/%.d: %.cpp
+dep/%.d: %.cpp parse.tab.h
@set -e; rm -f $@; \
mkdir -p dep ; \
$(CXX) -MM $(CPPFLAGS) $< > $@.$$$$; \
@@ -167,6 +167,8 @@ dep/%.d: %.c
sed 's,\($*\)\.o[ :]*,build/\1.o $@ : ,g' < $@.$$$$ > $@; \
rm -f $@.$$$$
+dep/html.d: css.c
+
# Serialize execution order to ensure the dependencies are built before
# compiling the object files in make -j invocations
all:
@@ -207,12 +209,13 @@ mkerr:
# This ensures that the version.cpp is regenerated iff its SHA doesn't
# match the current one.
@ -17,7 +35,7 @@
test:
@@ -264,6 +265,7 @@ obfuscation:
@@ -264,6 +267,7 @@ install: build/cscout
)
install: build/cscout

View File

@ -141,8 +141,8 @@ do-install:
${STAGEDIR}${PREFIX}/bin/gdb${VER}
${INSTALL_MAN} ${WRKSRC}/gdb/doc/gdb.1 \
${STAGEDIR}${PREFIX}/share/man/man1/gdb${VER}.1
(cd ${INSTALL_WRKSRC}/gdb/data-directory ; \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install-syscalls )
(cd ${INSTALL_WRKSRC}/gdb/data-directory ; ${SETENVI} ${WRK_ENV} \
${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install-syscalls )
do-install-KGDB-on:
${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/gdb/kgdb \
@ -162,18 +162,18 @@ do-install-GDB_LINK-on:
.endif
do-install-PYTHON-on:
(cd ${INSTALL_WRKSRC}/gdb ; \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install-python )
(cd ${INSTALL_WRKSRC}/gdb/data-directory ; \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install-python )
(cd ${INSTALL_WRKSRC}/gdb ; ${SETENVI} ${WRK_ENV} \
${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install-python )
(cd ${INSTALL_WRKSRC}/gdb/data-directory ; ${SETENVI} ${WRK_ENV} \
${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install-python )
@(cd ${STAGEDIR}${PREFIX}/share/gdb/python && \
${PYTHON_CMD} -m compileall .)
. for f in gdb gdb/command gdb/function gdb/printer
@(cd ${STAGEDIR}${PREFIX}/share/gdb/python/${f} ; ${CHMOD} 644 *.py* )
. endfor
.if exists(/usr/lib/libc++.so.1) || exists(/lib/libc++.so.1)
@(cd ${WRKSRC_libcxx} ; \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} \
@(cd ${WRKSRC_libcxx} ; ${SETENVI} ${WRK_ENV} \
${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} \
LIBCXX_DIR="${LIBCXX_DIR}" install )
@(cd ${STAGEDIR}${PREFIX}/share/gdb/auto-load/${LIBCXX_DIR} && \
${PYTHON_CMD} -m compileall .)
@ -187,9 +187,9 @@ do-install-PYTHON-on:
# breakage at run time.
do-install-GUILE-on:
(cd ${INSTALL_WRKSRC}/gdb ; \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install-guile )
(cd ${INSTALL_WRKSRC}/gdb/data-directory ; \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install-guile )
(cd ${INSTALL_WRKSRC}/gdb ; ${SETENVI} ${WRK_ENV} \
${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install-guile )
(cd ${INSTALL_WRKSRC}/gdb/data-directory ; ${SETENVI} ${WRK_ENV} \
${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} install-guile )
.include <bsd.port.post.mk>

View File

@ -1,9 +1,8 @@
PORTNAME= gmake
PORTVERSION= 4.3
PORTREVISION= 3
PORTNAME= make
DISTVERSION= 4.4.1
CATEGORIES= devel
MASTER_SITES= GNU/make
DISTNAME= make-${PORTVERSION}
MASTER_SITES= GNU
PKGNAMEPREFIX= g
# note: before committing to this port, contact portmgr to arrange for an
# experimental ports run. Untested commits may be backed out at portmgr's
@ -15,14 +14,15 @@ WWW= https://www.gnu.org/software/make/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
USES= cpe tar:lz
CPE_VENDOR= gnu
GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ARGS= --program-prefix=g \
--without-guile
USES= cpe tar:lz
CPE_VENDOR= gnu
CPE_PRODUCT= make
INFO= make
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
@ -30,6 +30,4 @@ OPTIONS_SUB= yes
NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
INFO= make
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1587222848
SHA256 (make-4.3.tar.lz) = de1a441c4edf952521db30bfca80baae86a0ff1acd0a00402999344f04c45e82
SIZE (make-4.3.tar.lz) = 1266180
TIMESTAMP = 1687757277
SHA256 (make-4.4.1.tar.lz) = 8814ba072182b605d156d7589c19a43b89fc58ea479b9355146160946f8cf6e9
SIZE (make-4.4.1.tar.lz) = 1305648

View File

@ -1,127 +0,0 @@
From: Bruno Haible <bruno@clisp.org>
Date: Sat, 23 May 2020 10:19:34 +0000 (+0200)
Subject: findprog-in: Ignore directories.
X-Git-Url: https://git.savannah.gnu.org/gitweb/?p=gnulib.git;a=commitdiff_plain;h=6e6abd0cdfe4bb96f6412aebc511f10bf254a820
findprog-in: Ignore directories.
Reported by Frederick Eaton via Dmitry Goncharov in
<https://lists.gnu.org/archive/html/bug-gnulib/2020-03/msg00003.html>.
* lib/findprog-in.c (find_in_given_path): When the file found is a
directory, set errno to EACCES and, during a PATH search, continue
searching.
* modules/findprog-in (Depends-on): Add sys_stat, stat.
---
diff --git a/lib/findprog-in.c b/lib/findprog-in.c
index c254f2f..0f76e36 100644
--- lib/findprog-in.c
+++ lib/findprog-in.c
@@ -26,6 +26,7 @@
#include <stdlib.h>
#include <string.h>
#include <unistd.h>
+#include <sys/stat.h>
#include "filename.h"
#include "concat-filename.h"
@@ -58,8 +59,8 @@ static const char * const suffixes[] =
/* Note: The cmd.exe program does a different lookup: It searches according
to the PATHEXT environment variable.
See <https://stackoverflow.com/questions/7839150/>.
- Also, it executes files ending .bat and .cmd directly without letting the
- kernel interpret the program file. */
+ Also, it executes files ending in .bat and .cmd directly without letting
+ the kernel interpret the program file. */
#elif defined __CYGWIN__
"", ".exe", ".com"
#elif defined __EMX__
@@ -136,14 +137,26 @@ find_in_given_path (const char *progname, const char *path,
call access() despite its design flaw. */
if (eaccess (progpathname, X_OK) == 0)
{
- /* Found! */
- if (strcmp (progpathname, progname) == 0)
+ /* Check that the progpathname does not point to a
+ directory. */
+ struct stat statbuf;
+
+ if (stat (progpathname, &statbuf) >= 0)
{
- free (progpathname);
- return progname;
+ if (! S_ISDIR (statbuf.st_mode))
+ {
+ /* Found! */
+ if (strcmp (progpathname, progname) == 0)
+ {
+ free (progpathname);
+ return progname;
+ }
+ else
+ return progpathname;
+ }
+
+ errno = EACCES;
}
- else
- return progpathname;
}
if (errno != ENOENT)
@@ -210,25 +223,37 @@ find_in_given_path (const char *progname, const char *path,
call access() despite its design flaw. */
if (eaccess (progpathname, X_OK) == 0)
{
- /* Found! */
- if (strcmp (progpathname, progname) == 0)
+ /* Check that the progpathname does not point to a
+ directory. */
+ struct stat statbuf;
+
+ if (stat (progpathname, &statbuf) >= 0)
{
- free (progpathname);
-
- /* Add the "./" prefix for real, that
- xconcatenated_filename() optimized away. This
- avoids a second PATH search when the caller uses
- execl/execv/execlp/execvp. */
- progpathname =
- XNMALLOC (2 + strlen (progname) + 1, char);
- progpathname[0] = '.';
- progpathname[1] = NATIVE_SLASH;
- memcpy (progpathname + 2, progname,
- strlen (progname) + 1);
- }
+ if (! S_ISDIR (statbuf.st_mode))
+ {
+ /* Found! */
+ if (strcmp (progpathname, progname) == 0)
+ {
+ free (progpathname);
+
+ /* Add the "./" prefix for real, that
+ xconcatenated_filename() optimized away.
+ This avoids a second PATH search when the
+ caller uses execl/execv/execlp/execvp. */
+ progpathname =
+ XNMALLOC (2 + strlen (progname) + 1, char);
+ progpathname[0] = '.';
+ progpathname[1] = NATIVE_SLASH;
+ memcpy (progpathname + 2, progname,
+ strlen (progname) + 1);
+ }
+
+ free (path_copy);
+ return progpathname;
+ }
- free (path_copy);
- return progpathname;
+ errno = EACCES;
+ }
}
if (errno != ENOENT)

View File

@ -0,0 +1,11 @@
--- configure.orig 2023-02-26 18:46:38 UTC
+++ configure
@@ -6741,7 +6741,7 @@ fi
-printf "%s\n" "#define MAKE_CXX \"$CXX\"" >>confdefs.h
+printf "%s\n" "#define MAKE_CXX \"c++\"" >>confdefs.h
# Configure gnulib

View File

@ -1,10 +0,0 @@
--- lib/glob.c.orig 2020-01-03 07:11:27 UTC
+++ lib/glob.c
@@ -203,7 +203,6 @@ my_realloc (p, n)
return (char *) malloc (n);
return (char *) realloc (p, n);
}
-# define realloc my_realloc
# endif /* __SASC */
#endif /* __GNU_LIBRARY__ || __DJGPP__ */

View File

@ -1,11 +0,0 @@
--- src/default.c.orig 2020-01-03 07:11:27 UTC
+++ src/default.c
@@ -530,7 +530,7 @@ static const char *default_variables[] =
"OBJC", "gcc",
#else
"CC", "cc",
- "CXX", "g++",
+ "CXX", "c++",
"OBJC", "cc",
#endif

View File

@ -1,10 +0,0 @@
--- src/makeint.h.orig 2020-01-19 20:32:59 UTC
+++ src/makeint.h
@@ -116,7 +116,6 @@ extern int errno;
/* Some systems define _POSIX_VERSION but are not really POSIX.1. */
#if (defined (butterfly) || defined (__arm) || (defined (__mips) && defined (_SYSTYPE_SVR3)) || (defined (sequent) && defined (i386)))
-# undef POSIX
#endif
#if !defined (POSIX) && defined (_AIX) && defined (_POSIX_SOURCE)

View File

@ -21,6 +21,7 @@ include/gnumake.h
%%NLS%%share/locale/pl/LC_MESSAGES/make.mo
%%NLS%%share/locale/pt/LC_MESSAGES/make.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/make.mo
%%NLS%%share/locale/ro/LC_MESSAGES/make.mo
%%NLS%%share/locale/ru/LC_MESSAGES/make.mo
%%NLS%%share/locale/sr/LC_MESSAGES/make.mo
%%NLS%%share/locale/sv/LC_MESSAGES/make.mo

View File

@ -0,0 +1,17 @@
--- jfaudiolib/Makefile.shared.orig 2021-12-25 07:53:32 UTC
+++ jfaudiolib/Makefile.shared
@@ -7,8 +7,12 @@ JFAUDIOLIB_LDFLAGS=
JFAUDIOLIB=libjfaudiolib.a
JFAUDIOLIB_LDFLAGS=
-SDL2CONFIG?=$(shell which sdl2-config || which false)
-PKGCONFIG?=$(shell which pkg-config || which false)
+ifndef SDL2CONFIG
+SDL2CONFIG!=which sdl2-config || which false
+endif
+ifndef PKGCONFIG
+PKGCONFIG!=which pkg-config || which false
+endif
machine=$(strip $(shell $(CC) -dumpmachine))

View File

@ -0,0 +1,17 @@
--- jfbuild/Makefile.shared.orig 2021-12-09 08:50:13 UTC
+++ jfbuild/Makefile.shared
@@ -3,8 +3,12 @@ EDITORLIB=src/libbuild.a
ENGINELIB=src/libengine.a
EDITORLIB=src/libbuild.a
-SDL2CONFIG?=$(shell which sdl2-config || which false)
-PKGCONFIG?=$(shell which pkg-config || which false)
+ifndef SDL2CONFIG
+SDL2CONFIG!=which sdl2-config || which false
+endif
+ifndef PKGCONFIG
+PKGCONFIG!=which pkg-config || which false
+endif
export SDL2CONFIG PKGCONFIG
# Path to the included libsquish

View File

@ -20,7 +20,7 @@ SHEBANG_FILES= make/*.pl
MAKE_ENV= OPENGLINCDIR="${LOCALBASE}/include" \
OPENGLLIBDIR="${LOCALBASE}/lib"
MAKE_JOBS_UNSAFE=yes
ALL_TARGET= freebsd
post-patch:

View File

@ -0,0 +1,11 @@
--- apron/Makefile.orig 2020-09-11 15:30:57 UTC
+++ apron/Makefile
@@ -163,7 +163,7 @@ ap_version.h: ../version.mk
echo "#define AP_VERSION \"${VERSION_STR}\"" >> $@
echo "#endif" >> $@
-.PHONY : dep depend
+.PHONY : dep
#--------------------------------------------------------------
# IMPLICIT RULES AND DEPENDENCIES

View File

@ -13,15 +13,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS_BUILD= libfmt # bundled libfmt conflicts with package-installed headers
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
bash:shells/bash \
gmake:devel/gmake
bash:shells/bash
LIB_DEPENDS= libecm.so:math/gmp-ecm \
libgf2x.so:math/gf2x \
libgmp.so:math/gmp \
libhwloc.so:devel/hwloc2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
USES= cmake:noninja compiler:c++11-lang perl5 python shebangfix # noninja because: bad $-escape (literal $ must be written as $$)
USES= cmake:noninja compiler:c++11-lang gmake perl5 python shebangfix # noninja because: bad $-escape (literal $ must be written as $$)
USE_GITLAB= yes
GL_SITE= https://gitlab.inria.fr
@ -33,7 +32,7 @@ CXXFLAGS_i386= -msse2 # workaround for error: always_inline function '_mm_setzer
TEST_TARGET= check # 'test' does the same but is less verbose
BINARY_ALIAS= python3=${PYTHON_CMD} make=${GMAKE}
BINARY_ALIAS= python3=${PYTHON_CMD}
.include <bsd.port.options.mk>

View File

@ -23,6 +23,7 @@ SUB_FILES= pkg-message
ADMIN?= admin@example.com
CFLAGS+= -x c++ -std=gnu++98
MAKE_JOBS_UNSAFE=yes
PLIST_FILES= sbin/delegated etc/rc.d/delegated.sh-dist
PORTDOCS= CHANGES COPYRIGHT HowToDG.html IPv6NOTE.txt \

View File

@ -0,0 +1,51 @@
--- Mk/main.mk.orig 2022-12-26 01:44:45 UTC
+++ Mk/main.mk
@@ -302,11 +302,13 @@ endif
&& echo sqlite3)
endif
endif
+PKGS:= $(PKGS)
TPKGS:=
ifndef CHECK_BASE
TPKGS+= $(shell $(PKGCONFIG) $(PCFLAGS) --exists check \
&& echo check)
endif
+TPKGS:= $(TPKGS)
# Function: Generate list of base paths to search when locating packages
# $1 packagename
@@ -422,18 +424,24 @@ ifneq (,$(strip $(PKGS)))
endif
ifneq (,$(strip $(PKGS)))
-PKG_CFLAGS+= $(shell $(PKGCONFIG) $(PCFLAGS) --cflags-only-other $(PKGS))
-PKG_CPPFLAGS+= $(shell $(PKGCONFIG) $(PCFLAGS) --cflags-only-I $(PKGS))
-PKG_LDFLAGS+= $(shell $(PKGCONFIG) $(PCFLAGS) --libs-only-L \
- --libs-only-other $(PKGS))
-PKG_LIBS+= $(shell $(PKGCONFIG) $(PCFLAGS) --libs-only-l $(PKGS))
+PKGS_CFLAGS!= $(PKGCONFIG) $(PCFLAGS) --cflags-only-other $(PKGS)
+PKG_CFLAGS+= $(PKGS_CFLAGS)
+PKGS_CPPFLAGS!= $(PKGCONFIG) $(PCFLAGS) --cflags-only-I $(PKGS)
+PKG_CPPFLAGS+= $(PKGS_CPPFLAGS)
+PKGS_LDFLAGS!= $(PKGCONFIG) $(PCFLAGS) --libs-only-L --libs-only-other $(PKGS)
+PKG_LDFLAGS+= $(PKGS_LDFLAGS)
+PKGS_LIBS!= $(PKGCONFIG) $(PCFLAGS) --libs-only-l $(PKGS)
+PKG_LIBS+= $(PKGS_LIBS)
endif
ifneq (,$(strip $(TPKGS)))
-TPKG_CFLAGS+= $(shell $(PKGCONFIG) $(PCFLAGS) --cflags-only-other $(TPKGS))
-TPKG_CPPFLAGS+= $(shell $(PKGCONFIG) $(PCFLAGS) --cflags-only-I $(TPKGS))
-TPKG_LDFLAGS+= $(shell $(PKGCONFIG) $(PCFLAGS) --libs-only-L \
- --libs-only-other $(TPKGS))
-TPKG_LIBS+= $(shell $(PKGCONFIG) $(PCFLAGS) --libs-only-l $(TPKGS))
+TPKGS_CFLAGS!= $(PKGCONFIG) $(PCFLAGS) --cflags-only-other $(TPKGS)
+TPKG_CFLAGS+= $(TPKGS_CFLAGS)
+TPKGS_CPPFLAGS!=$(PKGCONFIG) $(PCFLAGS) --cflags-only-I $(TPKGS)
+TPKG_CPPFLAGS+=$(TPKGS_CPPFLAGS)
+TPKGS_LDFLAGS!= $(PKGCONFIG) $(PCFLAGS) --libs-only-L --libs-only-other $(TPKGS)
+TPKG_LDFLAGS+= $(TPKGS_LDFLAGS)
+TPKGS_LIBS!= $(PKGCONFIG) $(PCFLAGS) --libs-only-l $(TPKGS)
+TPKG_LIBS+= $(TPKGS_LIBS)
endif
CPPDEFS+= -D_GNU_SOURCE \