biology/bcf-score: Bcftools plugins for GWAS-VCF summary statistics
Score is a set of tools in the form of a bcftools plugin, for handling and converting summary statistics files following the GWAS-VCF specification.
This commit is contained in:
parent
d4bd29fc00
commit
68c12d4ad4
7 changed files with 110 additions and 0 deletions
|
@ -11,6 +11,7 @@
|
||||||
SUBDIR += bamutil
|
SUBDIR += bamutil
|
||||||
SUBDIR += barrnap
|
SUBDIR += barrnap
|
||||||
SUBDIR += bbmap
|
SUBDIR += bbmap
|
||||||
|
SUBDIR += bcf-score
|
||||||
SUBDIR += bcftools
|
SUBDIR += bcftools
|
||||||
SUBDIR += bedtools
|
SUBDIR += bedtools
|
||||||
SUBDIR += bfc
|
SUBDIR += bfc
|
||||||
|
|
51
biology/bcf-score/Makefile
Normal file
51
biology/bcf-score/Makefile
Normal file
|
@ -0,0 +1,51 @@
|
||||||
|
PORTNAME= bcf-score
|
||||||
|
DISTVERSION= 1.16
|
||||||
|
CATEGORIES= biology
|
||||||
|
MASTER_SITES= https://software.broadinstitute.org/software/score/
|
||||||
|
DISTFILES+= score_${DISTVERSION}-20221221.tar.gz
|
||||||
|
|
||||||
|
MAINTAINER= jwb@FreeBSD.org
|
||||||
|
COMMENT= Bcftools plugins for GWAS-VCF summary statistics files
|
||||||
|
WWW= https://software.broadinstitute.org/software/score/
|
||||||
|
|
||||||
|
LICENSE= MIT
|
||||||
|
|
||||||
|
LIB_DEPENDS= libhts.so:biology/htslib
|
||||||
|
BUILD_DEPENDS= bash:shells/bash
|
||||||
|
RUN_DEPENDS= bcftools>=${PORTVERSION}:biology/bcftools
|
||||||
|
|
||||||
|
USES= autoreconf gmake localbase perl5 python:env shebangfix
|
||||||
|
USE_GITHUB= yes
|
||||||
|
USE_PERL5= test
|
||||||
|
|
||||||
|
GH_ACCOUNT= samtools
|
||||||
|
GH_PROJECT= bcftools
|
||||||
|
GH_TAGNAME= 1.17
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
SHEBANG_FILES= misc/* test/test.pl
|
||||||
|
|
||||||
|
post-extract:
|
||||||
|
@${CP} ${WRKDIR}/*.c ${WRKDIR}/*.h ${WRKSRC}/plugins
|
||||||
|
@${MKDIR} ${WRKSRC}/bcf-score
|
||||||
|
@${CP} ${WRKDIR}/*.R ${WRKSRC}/bcf-score
|
||||||
|
|
||||||
|
pre-configure:
|
||||||
|
@${REINPLACE_CMD} -e 's|@PORTVERSION@|${PORTVERSION}|g' \
|
||||||
|
${WRKSRC}/configure.ac
|
||||||
|
|
||||||
|
# One .so for each .c in the score distfile
|
||||||
|
do-install:
|
||||||
|
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/bcftools
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/plugins/blupx.so \
|
||||||
|
${STAGEDIR}${PREFIX}/libexec/bcftools
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/plugins/liftover.so \
|
||||||
|
${STAGEDIR}${PREFIX}/libexec/bcftools
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/plugins/metal.so \
|
||||||
|
${STAGEDIR}${PREFIX}/libexec/bcftools
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/plugins/munge.so \
|
||||||
|
${STAGEDIR}${PREFIX}/libexec/bcftools
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/plugins/score.so \
|
||||||
|
${STAGEDIR}${PREFIX}/libexec/bcftools
|
||||||
|
(cd ${WRKSRC}/bcf-score && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
5
biology/bcf-score/distinfo
Normal file
5
biology/bcf-score/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
||||||
|
TIMESTAMP = 1677335027
|
||||||
|
SHA256 (score_1.16-20221221.tar.gz) = f5f7331f2f670ea26cbc48a924e1467ac13c69aaf3b2a56599e3decda9375c0b
|
||||||
|
SIZE (score_1.16-20221221.tar.gz) = 61927
|
||||||
|
SHA256 (samtools-bcftools-1.16-1.17_GH0.tar.gz) = e6fdb4c94b531671ea8a0b00cb9245aa2602f6c4480621e45dac76338f590b9e
|
||||||
|
SIZE (samtools-bcftools-1.16-1.17_GH0.tar.gz) = 3481344
|
33
biology/bcf-score/files/patch-Makefile
Normal file
33
biology/bcf-score/files/patch-Makefile
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
--- Makefile.orig 2021-03-17 09:16:18 UTC
|
||||||
|
+++ Makefile
|
||||||
|
@@ -58,13 +58,14 @@ pluginpath = $(plugindir)
|
||||||
|
# Installation location for $(MISC_PROGRAMS) and $(MISC_SCRIPTS)
|
||||||
|
misc_bindir = $(bindir)
|
||||||
|
|
||||||
|
-MKDIR_P = mkdir -p
|
||||||
|
-INSTALL = install -p
|
||||||
|
-INSTALL_DATA = $(INSTALL) -m 644
|
||||||
|
-INSTALL_DIR = $(MKDIR_P) -m 755
|
||||||
|
-INSTALL_MAN = $(INSTALL_DATA)
|
||||||
|
-INSTALL_PROGRAM = $(INSTALL)
|
||||||
|
-INSTALL_SCRIPT = $(INSTALL_PROGRAM)
|
||||||
|
+# Use BSD_INSTALL_PROGRAM to strip when WITH_DEBUG not set
|
||||||
|
+MKDIR_P = mkdir -p
|
||||||
|
+INSTALL = install -p
|
||||||
|
+INSTALL_DATA = ${BSD_INSTALL_DATA}
|
||||||
|
+INSTALL_DIR = $(MKDIR_P)
|
||||||
|
+INSTALL_MAN = ${BSD_INSTALL_MAN}
|
||||||
|
+INSTALL_PROGRAM = ${BSD_INSTALL_PROGRAM}
|
||||||
|
+INSTALL_SCRIPT = ${BSD_INSTALL_SCRIPT}
|
||||||
|
|
||||||
|
PROGRAMS = bcftools
|
||||||
|
MISC_SCRIPTS = \
|
||||||
|
@@ -142,7 +143,7 @@ print-version:
|
||||||
|
ifdef USE_GPL
|
||||||
|
main.o : EXTRA_CPPFLAGS += -DUSE_GPL
|
||||||
|
OBJS += polysomy.o peakfit.o
|
||||||
|
- GSL_LIBS ?= -lgsl -lcblas
|
||||||
|
+ GSL_LIBS ?= -lgslcblas
|
||||||
|
endif
|
||||||
|
|
||||||
|
print-%:
|
11
biology/bcf-score/files/patch-configure.ac
Normal file
11
biology/bcf-score/files/patch-configure.ac
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- configure.ac.orig 2018-07-18 08:34:29 UTC
|
||||||
|
+++ configure.ac
|
||||||
|
@@ -23,7 +23,7 @@
|
||||||
|
# DEALINGS IN THE SOFTWARE.
|
||||||
|
|
||||||
|
dnl Process this file with autoconf to produce a configure script
|
||||||
|
-AC_INIT([BCFtools], m4_esyscmd_s([./version.sh 2>/dev/null]),
|
||||||
|
+AC_INIT([BCFtools], [@PORTVERSION@],
|
||||||
|
[samtools-help@lists.sourceforge.net], [], [http://www.htslib.org/])
|
||||||
|
AC_PREREQ([2.63]) dnl This version introduced 4-argument AC_CHECK_HEADER
|
||||||
|
AC_CONFIG_SRCDIR([main.c])
|
3
biology/bcf-score/pkg-descr
Normal file
3
biology/bcf-score/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
||||||
|
Score is a set of tools in the form of a bcftools plugin, for handling
|
||||||
|
and converting summary statistics files following the GWAS-VCF
|
||||||
|
specification.
|
6
biology/bcf-score/pkg-plist
Normal file
6
biology/bcf-score/pkg-plist
Normal file
|
@ -0,0 +1,6 @@
|
||||||
|
libexec/bcftools/blupx.so
|
||||||
|
libexec/bcftools/liftover.so
|
||||||
|
libexec/bcftools/metal.so
|
||||||
|
libexec/bcftools/munge.so
|
||||||
|
libexec/bcftools/score.so
|
||||||
|
%%DATADIR%%/assoc_plot.R
|
Loading…
Reference in a new issue