- Update to 1.5
- Install README file
This commit is contained in:
parent
75f9e548c6
commit
691349d4ed
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=421915
3 changed files with 15 additions and 10 deletions
|
@ -1,8 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pastebinit
|
||||
PORTVERSION= 1.4.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.5
|
||||
CATEGORIES= misc python
|
||||
MASTER_SITES= https://launchpad.net/pastebinit/trunk/${PORTVERSION}/+download/
|
||||
|
||||
|
@ -22,13 +21,14 @@ NO_ARCH= yes
|
|||
|
||||
PLIST_FILES= bin/pastebinit
|
||||
PORTDATA= *
|
||||
PORTDOCS= *
|
||||
|
||||
OPTIONS_DEFINE= PASTEBINS
|
||||
OPTIONS_DEFINE= PASTEBINS DOCS
|
||||
OPTIONS_DEFAULT=PASTEBINS
|
||||
PASTEBINS_DESC= Install default pastebins
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|/usr/share/pastebin.d|${DATADIR}/pastebin.d|' \
|
||||
@${REINPLACE_CMD} -e 's|/usr/share/pastebin.d|${DATADIR}/pastebin.d|' \
|
||||
${WRKSRC}/pastebinit
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
|
||||
|
@ -36,4 +36,8 @@ do-install:
|
|||
do-install-PASTEBINS-on:
|
||||
(cd ${WRKSRC} && ${COPYTREE_SHARE} pastebin.d ${STAGEDIR}${DATADIR})
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (pastebinit-1.4.1.tar.bz2) = c23720ff19d239f7ae62dd7dc28f453aaea4823af29b1595ba2e58fe232988e6
|
||||
SIZE (pastebinit-1.4.1.tar.bz2) = 39202
|
||||
TIMESTAMP = 1473635387
|
||||
SHA256 (pastebinit-1.5.tar.bz2) = 42e5a84ce7e46825fb3b6478e11893fad357197327257e474bd0d3549f438457
|
||||
SIZE (pastebinit-1.5.tar.bz2) = 42941
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- pastebinit.orig 2014-01-18 04:52:04 UTC
|
||||
--- pastebinit.orig 2016-09-11 23:10:22 UTC
|
||||
+++ pastebinit
|
||||
@@ -33,7 +33,7 @@ else:
|
||||
@@ -34,7 +34,7 @@ else:
|
||||
from urllib.request import FancyURLopener
|
||||
|
||||
# Set the default pastebin
|
||||
-defaultPB = "http://pastebin.com"
|
||||
+defaultPB = "http://paste2.org"
|
||||
-defaultPB = "pastebin.com"
|
||||
+defaultPB = "paste2.org"
|
||||
|
||||
# Now try to override it with a distributor pastebin
|
||||
try:
|
||||
|
|
Loading…
Reference in a new issue