Update security/cryptopp to 8.2.0

Remove THREADS option - upstream recommends building with threads and the
build system now adds the appropriate flags automatically

Bump PORTREVISION on consumers due to shared lib version increase

PR:		241132
Submitted by:	Farid Hajji <farid@hajji.name>
This commit is contained in:
Jason E. Hale 2019-12-10 03:38:48 +00:00
parent 0c566ada26
commit 692da6425d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=519643
15 changed files with 53 additions and 61 deletions

View file

@ -2,6 +2,7 @@
PORTNAME= urbackup-client
DISTVERSION= 2.4.8
PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= https://hndl.urbackup.org/Client/${DISTVERSION}/

View file

@ -2,6 +2,7 @@
PORTNAME= urbackup-server
DISTVERSION= 2.4.11
PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= https://hndl.urbackup.org/Server/${DISTVERSION}/

View file

@ -4,7 +4,7 @@
PORTNAME= clementine
DISTVERSION= 1.3.1-661
DISTVERSIONSUFFIX= -g4ff370ce1
PORTREVISION= 8
PORTREVISION= 9
CATEGORIES= audio
PKGNAMESUFFIX= -player

View file

@ -2,6 +2,7 @@
PORTNAME= xeus
DISTVERSION= 0.23.2
PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org

View file

@ -3,7 +3,7 @@
PORTNAME= kvazaar
DISTVERSIONPREFIX= v
DISTVERSION?= 1.3.0
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= multimedia
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/

View file

@ -3,7 +3,7 @@
PORTNAME= amule
PORTVERSION= 11004
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= net-p2p
MASTER_SITES= http://amule.sourceforge.net/tarballs/
PKGNAMESUFFIX= -devel

View file

@ -3,7 +3,7 @@
PORTNAME= amule
PORTVERSION= 2.3.2
PORTREVISION= 7
PORTREVISION= 8
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/aMule/${PORTVERSION}
DISTNAME= aMule-${PORTVERSION}

View file

@ -4,7 +4,7 @@
PORTNAME= ceph
DISTVERSIONPREFIX= v
DISTVERSION= 13.2.6
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= net
PKGNAMESUFFIX= 13

View file

@ -4,6 +4,7 @@
PORTNAME= ceph
DISTVERSIONPREFIX= v
DISTVERSION= 14.2.4
PORTREVISION= 1
CATEGORIES= net
PKGNAMESUFFIX= 14

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cryptopp
PORTVERSION= 7.0.0
PORTREVISION= 2
PORTVERSION= 8.2.0
CATEGORIES= security
MASTER_SITES= http://www.cryptopp.com/
DISTNAME= cryptopp${PORTVERSION:S/.//g}
@ -30,12 +29,12 @@ SOVERSION= ${PORTVERSION:R:R}
PLIST_SUB+= SOVERSION=${SOVERSION} \
PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= DEBUG DOCS FULL_DEBUG THREADS TOOLS
OPTIONS_DEFINE= DEBUG DOCS FULL_DEBUG TOOLS
OPTIONS_DEFINE_amd64= SIMD
OPTIONS_DEFINE_i386= SIMD
OPTIONS_DEFINE_powerpc= SIMD
OPTIONS_DEFINE_powerpc64= SIMD
OPTIONS_DEFAULT= THREADS TOOLS
OPTIONS_DEFAULT= TOOLS
OPTIONS_SUB= yes
# Always compile with -DNDEBUG for release. Otherwise, sensitive
@ -52,8 +51,6 @@ TOOLS_MAKE_ENV= CRYPTOPP_DATA_DIR=${DATADIR}/
TOOLS_ALL_TARGET= cryptest.exe
TOOLS_TEST_TARGET_OFF= test
THREADS_LDFLAGS= -lpthread
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSIMD}

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1534123149
SHA256 (cryptopp700.zip) = a4bc939910edd3d29fb819a6fc0dfdc293f686fa62326f61c56d72d0a366ceb0
SIZE (cryptopp700.zip) = 7296665
TIMESTAMP = 1575820181
SHA256 (cryptopp820.zip) = 03f0e2242e11b9d19b28d0ec5a3fa8ed5cc7b27640e6bed365744f593e858058
SIZE (cryptopp820.zip) = 8859815

View file

@ -2,19 +2,28 @@ We need to export the CRYPTOPP_DISABLE_ASM flag if cryptopp was not built
with SIMD support. Certain functions prototypes are guarded by this
flag and build failures will arise in other ports if not set appropriately.
--- GNUmakefile.orig 2018-04-08 08:47:12 UTC
--- GNUmakefile.orig 2019-04-28 23:36:50 UTC
+++ GNUmakefile
@@ -90,7 +90,7 @@ SUNCC_512_OR_LATER := $(shell echo "$(SUNCC_VERSION)"
SUNCC_513_OR_LATER := $(shell echo "$(SUNCC_VERSION)" | $(GREP) -i -c -E "CC: (Sun|Studio) .* (5\.1[3-9]|5\.[2-9]|6\.)")
@@ -57,7 +57,7 @@ ifeq ($(SYSTEMX),)
SYSTEMX := $(shell uname -s 2>/dev/null)
endif
# Enable shared object versioning for Linux
-HAS_SOLIB_VERSION := $(IS_LINUX)
+HAS_SOLIB_VERSION := 1
-IS_LINUX := $(shell echo "$(SYSTEMX)" | $(GREP) -i -c "Linux")
+IS_LINUX := $(shell echo "$(SYSTEMX)" | $(GREP) -i -c -E "Linux|FreeBSD")
IS_HURD := $(shell echo "$(SYSTEMX)" | $(GREP) -i -c -E "GNU|Hurd")
IS_MINGW := $(shell echo "$(SYSTEMX)" | $(GREP) -i -c "MinGW")
IS_CYGWIN := $(shell echo "$(SYSTEMX)" | $(GREP) -i -c "Cygwin")
@@ -742,7 +742,7 @@ endif
# Fixup SunOS
ifeq ($(IS_SUN),1)
@@ -957,7 +957,7 @@ libcryptopp.pc:
@echo 'Version: 7.0' >> libcryptopp.pc
# Use -pthread whenever it is available. See http://www.hpl.hp.com/techreports/2004/HPL-2004-209.pdf
# http://stackoverflow.com/questions/2127797/gcc-significance-of-pthread-flag-when-compiling
-ifeq ($(DETECT_FEATURES),1)
+ifeq (1,1)
ifeq ($(XLC_COMPILER),1)
ifeq ($(findstring -qthreaded,$(CXXFLAGS)),)
TPROG = TestPrograms/test_pthreads.cxx
@@ -1341,7 +1341,7 @@ libcryptopp.pc:
@echo 'Version: 8.2' >> libcryptopp.pc
@echo 'URL: https://cryptopp.com/' >> libcryptopp.pc
@echo '' >> libcryptopp.pc
- @echo 'Cflags: -I$${includedir}' >> libcryptopp.pc

View file

@ -1,17 +0,0 @@
Fix build with SIMD on FreeBSD 10.x
--- cpu.h.orig 2018-04-08 08:47:11 UTC
+++ cpu.h
@@ -614,7 +614,12 @@ inline int GetCacheLineSize()
#define GNU_AS2(x, y) #x ", " #y ";" NEW_LINE
#define GNU_AS3(x, y, z) #x ", " #y ", " #z ";" NEW_LINE
#define GNU_ASL(x) "\n" #x ":" NEW_LINE
+ // clang 5.0.0 and apple clang 9.0.0 don't support numerical backward jumps
+#if (CRYPTOPP_LLVM_CLANG_VERSION >= 30000) || (CRYPTOPP_APPLE_CLANG_VERSION >= 90000)
+ #define GNU_ASJ(x, y, z) ATT_PREFIX ";" NEW_LINE #x " " #y #z ";" NEW_LINE INTEL_PREFIX ";" NEW_LINE
+#else
#define GNU_ASJ(x, y, z) #x " " #y #z ";" NEW_LINE
+#endif
#define AS1(x) GNU_AS1(x)
#define AS2(x, y) GNU_AS2(x, y)
#define AS3(x, y, z) GNU_AS3(x, y, z)

View file

@ -1,13 +0,0 @@
Fix build without SIMD on FreeBSD 10.x
--- sse-simd.cpp.orig 2018-04-08 08:47:12 UTC
+++ sse-simd.cpp
@@ -23,7 +23,7 @@
#endif
// Needed by SunCC and MSVC
-#if (CRYPTOPP_BOOL_X86 || CRYPTOPP_BOOL_X32 || CRYPTOPP_BOOL_X64)
+#if (CRYPTOPP_BOOL_X86 || CRYPTOPP_BOOL_X32 || CRYPTOPP_BOOL_X64) && defined(CRYPTOPP_SSE2_ASM_AVAILABLE)
# include <emmintrin.h>
#endif

View file

@ -1,13 +1,15 @@
%%TOOLS%%bin/cryptest
include/cryptopp/3way.h
include/cryptopp/adler32.h
include/cryptopp/adv-simd.h
include/cryptopp/adv_simd.h
include/cryptopp/aes.h
include/cryptopp/aes_armv4.h
include/cryptopp/algebra.h
include/cryptopp/algparam.h
include/cryptopp/arc4.h
include/cryptopp/argnames.h
include/cryptopp/aria.h
include/cryptopp/arm_simd.h
include/cryptopp/asn.h
include/cryptopp/authenc.h
include/cryptopp/base32.h
@ -22,17 +24,24 @@ include/cryptopp/cast.h
include/cryptopp/cbcmac.h
include/cryptopp/ccm.h
include/cryptopp/chacha.h
include/cryptopp/chachapoly.h
include/cryptopp/cham.h
include/cryptopp/channels.h
include/cryptopp/cmac.h
include/cryptopp/config.h
include/cryptopp/cpu.h
include/cryptopp/crc.h
include/cryptopp/cryptlib.h
include/cryptopp/darn.h
include/cryptopp/default.h
include/cryptopp/des.h
include/cryptopp/dh.h
include/cryptopp/dh2.h
include/cryptopp/dmac.h
include/cryptopp/donna.h
include/cryptopp/donna_32.h
include/cryptopp/donna_64.h
include/cryptopp/donna_sse.h
include/cryptopp/drbg.h
include/cryptopp/dsa.h
include/cryptopp/eax.h
@ -58,7 +67,10 @@ include/cryptopp/gfpcrypt.h
include/cryptopp/gost.h
include/cryptopp/gzip.h
include/cryptopp/hashfwd.h
include/cryptopp/hc128.h
include/cryptopp/hc256.h
include/cryptopp/hex.h
include/cryptopp/hight.h
include/cryptopp/hkdf.h
include/cryptopp/hmac.h
include/cryptopp/hmqv.h
@ -69,6 +81,7 @@ include/cryptopp/integer.h
include/cryptopp/iterhash.h
include/cryptopp/kalyna.h
include/cryptopp/keccak.h
include/cryptopp/lea.h
include/cryptopp/lubyrack.h
include/cryptopp/luc.h
include/cryptopp/mars.h
@ -85,7 +98,6 @@ include/cryptopp/mqueue.h
include/cryptopp/mqv.h
include/cryptopp/naclite.h
include/cryptopp/nbtheory.h
include/cryptopp/network.h
include/cryptopp/nr.h
include/cryptopp/oaep.h
include/cryptopp/oids.h
@ -97,11 +109,12 @@ include/cryptopp/pch.h
include/cryptopp/pkcspad.h
include/cryptopp/poly1305.h
include/cryptopp/polynomi.h
include/cryptopp/ppc-simd.h
include/cryptopp/ppc_simd.h
include/cryptopp/pssr.h
include/cryptopp/pubkey.h
include/cryptopp/pwdbased.h
include/cryptopp/queue.h
include/cryptopp/rabbit.h
include/cryptopp/rabin.h
include/cryptopp/randpool.h
include/cryptopp/rc2.h
@ -125,7 +138,9 @@ include/cryptopp/serpentp.h
include/cryptopp/sha.h
include/cryptopp/sha3.h
include/cryptopp/shacal2.h
include/cryptopp/shake.h
include/cryptopp/shark.h
include/cryptopp/simeck.h
include/cryptopp/simon.h
include/cryptopp/simple.h
include/cryptopp/siphash.h
@ -133,7 +148,6 @@ include/cryptopp/skipjack.h
include/cryptopp/sm3.h
include/cryptopp/sm4.h
include/cryptopp/smartptr.h
include/cryptopp/socketft.h
include/cryptopp/sosemanuk.h
include/cryptopp/speck.h
include/cryptopp/square.h
@ -143,18 +157,16 @@ include/cryptopp/tea.h
include/cryptopp/threefish.h
include/cryptopp/tiger.h
include/cryptopp/trap.h
include/cryptopp/trdlocal.h
include/cryptopp/trunhash.h
include/cryptopp/ttmac.h
include/cryptopp/tweetnacl.h
include/cryptopp/twofish.h
include/cryptopp/validate.h
include/cryptopp/vmac.h
include/cryptopp/wait.h
include/cryptopp/wake.h
include/cryptopp/whrlpool.h
include/cryptopp/winpipes.h
include/cryptopp/words.h
include/cryptopp/xed25519.h
include/cryptopp/xtr.h
include/cryptopp/xtrcrypt.h
include/cryptopp/zdeflate.h