- Update to 0.20110708.0, which now builds under clang.

This commit is contained in:
Wesley Shields 2011-07-10 15:34:47 +00:00
parent 348c483d41
commit 692e9aad2e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=277455
3 changed files with 3 additions and 45 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= keynav
DISTVERSION= 0.20101224.3183
DISTVERSION= 0.20110708.0
PORTEPOCH= 1
CATEGORIES= x11
MASTER_SITES= http://semicomplete.googlecode.com/files/
@ -27,10 +27,6 @@ MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
.if (${OSVERSION} <= 700000)
IGNORE= does not build on 6.x
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/keynav ${PREFIX}/bin
.if !defined(NOPORTEXAMPLES)

View file

@ -1,2 +1,2 @@
SHA256 (keynav-0.20101224.3183.tar.gz) = 76707752702023a0930807c0dcd52f2e79fd8bf0a1b78c5baee02bfb3761b56d
SIZE (keynav-0.20101224.3183.tar.gz) = 21095
SHA256 (keynav-0.20110708.0.tar.gz) = 1f39c7181bf2f6185946afc35bdcca28ec15fed012a4b57bef57fb1125943fbe
SIZE (keynav-0.20110708.0.tar.gz) = 21124

View file

@ -1,38 +0,0 @@
--- ./keynav.c.orig 2011-06-29 20:24:04.335382341 -0400
+++ ./keynav.c 2011-06-29 21:21:31.846377864 -0400
@@ -10,6 +10,7 @@
#include <unistd.h>
#include <string.h>
#include <errno.h>
+#include <ctype.h>
#include <sys/types.h>
#include <sys/wait.h>
#include <signal.h>
@@ -174,6 +175,8 @@
void query_screen_normal();
int viewport_sort(const void *a, const void *b);
int query_current_screen();
+int query_current_screen_xinerama();
+int query_current_screen_normal();
void viewport_left();
void viewport_right();
int pointinrect(int px, int py, int rx, int ry, int rw, int rh);
@@ -1029,7 +1032,8 @@
Window curwin;
Window rootwin;
Window dummy_win;
- int x, y, width, height, border_width, depth;
+ int x, y;
+ unsigned int width, height, border_width, depth;
xdo_window_get_active(xdo, &curwin);
XGetGeometry(xdo->xdpy, curwin, &rootwin, &x, &y, &width, &height,
@@ -1469,7 +1473,7 @@
//printf("Recording as keycode:%d\n", e->keycode);
active_recording->keycode = e->keycode;
- return;
+ return HANDLE_CONTINUE;
}
handler_info_t handle_gridnav(XKeyEvent *e) {