databases/py-caterva: Add py-caterva 0.6.0
Python wrapper for Caterva. WWW: https://github.com/Blosc/python-caterva
This commit is contained in:
parent
89a9ec0598
commit
696c766113
5 changed files with 61 additions and 0 deletions
|
@ -757,6 +757,7 @@
|
|||
SUBDIR += py-bsddb3
|
||||
SUBDIR += py-carbon
|
||||
SUBDIR += py-cassandra-driver
|
||||
SUBDIR += py-caterva
|
||||
SUBDIR += py-couchdb
|
||||
SUBDIR += py-dbf
|
||||
SUBDIR += py-dbutils
|
||||
|
|
32
databases/py-caterva/Makefile
Normal file
32
databases/py-caterva/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
||||
|
||||
PORTNAME= caterva
|
||||
PORTVERSION= 0.6.0
|
||||
CATEGORIES= databases python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Caterva for Python (multidimensional compressed data containers)
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= cmake:devel/cmake \
|
||||
ninja:devel/ninja \
|
||||
${PYTHON_PKGNAMEPREFIX}scikit-build>=0:devel/py-scikit-build@${PY_FLAVOR}
|
||||
LIB_DEPENDS= libblosc2.so:archivers/c-blosc2 \
|
||||
libcaterva.so:databases/caterva
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ndindex>=0:math/py-ndindex@${PY_FLAVOR}
|
||||
|
||||
USES= localbase:ldflags python:3.7+
|
||||
USE_PYTHON= autoplist concurrent cython distutils
|
||||
|
||||
post-patch:
|
||||
# Clean up bundled libraries
|
||||
@${RM} -fr ${WRKSRC}/caterva/caterva/
|
||||
|
||||
post-install:
|
||||
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
|
||||
|
||||
.include <bsd.port.mk>
|
3
databases/py-caterva/distinfo
Normal file
3
databases/py-caterva/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1635730873
|
||||
SHA256 (caterva-0.6.0.tar.gz) = 08aedc5c7a342babab0771dfcd6bdc18d7212e9dd9b77b513b00e1ba07d4023e
|
||||
SIZE (caterva-0.6.0.tar.gz) = 1443173
|
22
databases/py-caterva/files/patch-caterva-CMakeLists.txt
Normal file
22
databases/py-caterva/files/patch-caterva-CMakeLists.txt
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- caterva/CMakeLists.txt.orig 2021-07-14 09:59:59 UTC
|
||||
+++ caterva/CMakeLists.txt
|
||||
@@ -1,18 +1,7 @@
|
||||
-set(STATIC_LIB ON CACHE BOOL "Build a static version of the blosc library.")
|
||||
-set(SHARED_LIB ON CACHE BOOL "Build a shared library version of the blosc
|
||||
- library.")
|
||||
-set(CATERVA_BUILD_TESTS OFF CACHE BOOL "Build Caterva tests")
|
||||
-set(CATERVA_BUILD_EXAMPLES OFF CACHE BOOL "Build Caterva examples")
|
||||
-set(CMAKE_POSITION_INDEPENDENT_CODE ON)
|
||||
-add_subdirectory(caterva)
|
||||
-include_directories("${CMAKE_CURRENT_SOURCE_DIR}/caterva/caterva")
|
||||
-include_directories("${CMAKE_CURRENT_SOURCE_DIR}/caterva/contribs/c-blosc2/include")
|
||||
-
|
||||
-
|
||||
add_cython_target(caterva_ext caterva_ext.pyx)
|
||||
add_library(caterva_ext MODULE ${caterva_ext})
|
||||
|
||||
-target_link_libraries(caterva_ext caterva_static)
|
||||
+target_link_libraries(caterva_ext caterva)
|
||||
|
||||
python_extension_module(caterva_ext)
|
||||
|
3
databases/py-caterva/pkg-descr
Normal file
3
databases/py-caterva/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
Python wrapper for Caterva.
|
||||
|
||||
WWW: https://github.com/Blosc/python-caterva
|
Loading…
Reference in a new issue