Upgrade to upstream bugfix release 0.64.

This fixes a security bug, various other bugs, and supports SSH
connection sharing between multiple instances of PuTTY and its tools.

MFH:		2015Q1
Security:	92fc2e2b-c383-11e4-8ef7-080027ef73ec
Security:	CVE-2015-2157
This commit is contained in:
Matthias Andree 2015-03-05 22:15:08 +00:00
parent 371c596738
commit 696ebd912f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=380554
4 changed files with 23 additions and 20 deletions

View file

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= putty
PORTVERSION= 0.63
PORTVERSION= 0.64
CATEGORIES= security ipv6
MASTER_SITES= http://the.earth.li/~sgtatham/putty/%SUBDIR%/ \
ftp://ftp.chiark.greenend.org.uk/users/sgtatham/putty-latest/
@ -12,6 +12,9 @@ MASTER_SITE_SUBDIR= ${PORTVERSION}
MAINTAINER= mandree@FreeBSD.org
COMMENT= Secure shell and telnet client
LICENSE= MIT
LICENSE_FILE= ${FILESDIR}/LICENSE
USES= gmake pkgconfig
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
MAKEFILE= Makefile.gtk

View file

@ -1,2 +1,2 @@
SHA256 (putty-0.63.tar.gz) = 81e8eaaf31be7d9a46b4f3fb80d1d9540776f142cd89d0a11f2f8082dc68f8b5
SIZE (putty-0.63.tar.gz) = 1887913
SHA256 (putty-0.64.tar.gz) = 2a46c97a184144e3ec2392aca9acc64d062317a3a38b9a5f623a147eda5f3821
SIZE (putty-0.64.tar.gz) = 1977448

View file

@ -0,0 +1,9 @@
PuTTY is copyright 1997-2015 Simon Tatham.
Portions copyright Robert de Bath, Joris van Rantwijk, Delian Delchev, Andreas Schultz, Jeroen Massar, Wez Furlong, Nicolas Barry, Justin Bradford, Ben Harris, Malcolm Smith, Ahmad Khalifa, Markus Kuhn, Colin Watson, Christopher Staite, and CORE SDI S.A.
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL SIMON TATHAM BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

View file

@ -1,6 +1,6 @@
--- ./Makefile.gtk.orig 2011-07-12 20:29:31.000000000 +0200
+++ ./Makefile.gtk 2011-07-17 14:56:18.000000000 +0200
@@ -119,7 +119,7 @@
--- Makefile.gtk.orig 2015-02-28 15:33:27 UTC
+++ Makefile.gtk
@@ -110,7 +110,7 @@ GTK_CONFIG = sh -c 'pkg-config gtk+-2.0
unexport CFLAGS # work around a weird issue with krb5-config
@ -9,7 +9,7 @@
-I../macosx/ $(shell $(GTK_CONFIG) --cflags) -D _FILE_OFFSET_BITS=64
XLDFLAGS = $(LDFLAGS) $(shell $(GTK_CONFIG) --libs)
ULDFLAGS = $(LDFLAGS)
@@ -146,7 +146,11 @@
@@ -137,7 +137,11 @@ man1dir=$(mandir)/man1
.SUFFIXES:
@ -19,18 +19,9 @@
+all: plink pscp psftp puttygen
+endif
plink: be_all_s.o cmdline.o cproxy.o ldisc.o logging.o misc.o pgssapi.o \
pinger.o portfwd.o proxy.o raw.o rlogin.o settings.o ssh.o \
@@ -851,7 +855,7 @@
$(CC) $(COMPAT) $(CFLAGS) $(XFLAGS) -c ../unix/xpmputty.c
version.o: FORCE
- if test -z "$(VER)" && (cd ..; md5sum -c manifest); then \
+ if test -z "$(VER)" ; then \
$(CC) $(COMPAT) $(XFLAGS) $(CFLAGS) `cat ../version.def` -c ../version.c; \
else \
$(CC) $(COMPAT) $(XFLAGS) $(CFLAGS) $(VER) -c ../version.c; \
@@ -861,6 +865,8 @@
plink: be_all_s.o callback.o cmdline.o conf.o cproxy.o ldisc.o logging.o \
misc.o noterm.o pgssapi.o pinger.o portfwd.o proxy.o raw.o \
@@ -920,6 +924,8 @@ install:
$(INSTALL_PROGRAM) -m 755 plink $(DESTDIR)$(bindir)/plink
$(INSTALL_PROGRAM) -m 755 pscp $(DESTDIR)$(bindir)/pscp
$(INSTALL_PROGRAM) -m 755 psftp $(DESTDIR)$(bindir)/psftp
@ -39,7 +30,7 @@
$(INSTALL_PROGRAM) -m 755 pterm $(DESTDIR)$(bindir)/pterm
if test -n "$(UTMP_GROUP)"; then \
chgrp $(UTMP_GROUP) $(DESTDIR)$(bindir)/pterm && \
@@ -870,15 +876,17 @@
@@ -929,15 +935,17 @@ install:
chmod 4755 $(DESTDIR)$(bindir)/pterm; \
fi
$(INSTALL_PROGRAM) -m 755 putty $(DESTDIR)$(bindir)/putty