Add gnomesword, a GNOME interface to the SWORD project.

PR:		44145
Submitted by:	J Shoemaker <shoemaker@softhome.net>
This commit is contained in:
Joe Marcus Clarke 2002-10-16 18:40:16 +00:00
parent 1d625b6381
commit 698106c8d8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=68159
15 changed files with 211 additions and 0 deletions

View file

@ -94,6 +94,7 @@
SUBDIR += gnomehier
SUBDIR += gnomemimedata
SUBDIR += gnomepm
SUBDIR += gnomesword
SUBDIR += gnomeuserdocs
SUBDIR += gnomeuserdocs2
SUBDIR += gnomeutils

38
misc/gnomesword/Makefile Normal file
View file

@ -0,0 +1,38 @@
# New ports collection makefile for: gnomesword
# Date created: Oct 26, 2002
# Whom: J Shoemaker <shoemaker@softhome.net>
#
# $FreeBSD$
#
PORTNAME= gnomesword
PORTVERSION= 0.7.5
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= shoemaker@softhome.net
LIB_DEPENDS= sword.1:${PORTSDIR}/misc/sword
BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
USE_GNOMENG= yes
USE_GNOME= gal gnomehack gnomeprefix
USE_X_PREFIX= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
DOC_FILES= AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
post-configure:
${ECHO} "#define PACKAGE_PIXMAPS_DIR \"${PREFIX}/share/gnome/pixmaps/gnomesword\"">> ${WRKSRC}/config.h
post-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ${DOC_FILES}
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

1
misc/gnomesword/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (gnomesword-0.7.5.tar.gz) = 674d410cc64ef76c570ed657e521c7aa

View file

@ -0,0 +1,18 @@
--- Makefile.in.orig Wed Oct 16 11:05:14 2002
+++ Makefile.in Wed Oct 16 11:06:31 2002
@@ -136,13 +136,13 @@
EXTRA_DIST = gnomesword.desktop
gnomesworddocdir = $(prefix)/doc/gnomesword
-gnomesworddoc_DATA = README COPYING AUTHORS ChangeLog INSTALL NEWS TODO
+gnomesworddoc_DATA = # README COPYING AUTHORS ChangeLog INSTALL NEWS TODO
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = config.h
CONFIG_CLEAN_FILES =
-DATA = $(gnomesworddoc_DATA)
+DATA = # $(gnomesworddoc_DATA)
DIST_COMMON = README ./stamp-h.in ABOUT-NLS AUTHORS COPYING ChangeLog \
INSTALL Makefile.am Makefile.in NEWS TODO acconfig.h aclocal.m4 \

View file

@ -0,0 +1 @@
A bible interface utilizing the sword framework

11
misc/gnomesword/pkg-descr Normal file
View file

@ -0,0 +1,11 @@
The GnomeSword GUI is a frontend to the SWORD project.
The SWORD Project is an effort to create an ever expanding software package
for research and study of God and His Word. The SWORD Bible Framework allows
easy manipulation of Bible texts, commentaries, lexicons, dictionaries, etc.
Many frontends are build using this framework. An installed module set may be
shared between any frontend using the framework.
WWW: http://www.crosswire.org/
// J Shoemaker <shoemaker@softhome.net>

View file

@ -0,0 +1,2 @@
To use gnomesword, you need to have bible, commentary and/or lexicon
modules. Those are available in the sword-modules package/port.

34
misc/gnomesword/pkg-plist Normal file
View file

@ -0,0 +1,34 @@
bin/gnomesword
%%PORTDOCS%%share/doc/gnomesword/AUTHORS
%%PORTDOCS%%share/doc/gnomesword/COPYING
%%PORTDOCS%%share/doc/gnomesword/ChangeLog
%%PORTDOCS%%share/doc/gnomesword/INSTALL
%%PORTDOCS%%share/doc/gnomesword/NEWS
%%PORTDOCS%%share/doc/gnomesword/README
%%PORTDOCS%%share/doc/gnomesword/TODO
share/gnome/apps/Applications/gnomesword.desktop
share/gnome/help/gnomesword/C/index.html
share/gnome/help/gnomesword/C/intro.html
share/gnome/pixmaps/gnomesword/GnomeSword.png
share/gnome/pixmaps/gnomesword/GnomeSword.xpm
share/gnome/pixmaps/gnomesword/about.png
share/gnome/pixmaps/gnomesword/book-bl.png
share/gnome/pixmaps/gnomesword/book-gold.png
share/gnome/pixmaps/gnomesword/book-green.png
share/gnome/pixmaps/gnomesword/book-un.png
share/gnome/pixmaps/gnomesword/dock.xpm
share/gnome/pixmaps/gnomesword/exit2.xpm
share/gnome/pixmaps/gnomesword/footnote3.xpm
share/gnome/pixmaps/gnomesword/gnome-fontsel.xpm
share/gnome/pixmaps/gnomesword/morphs.xpm
share/gnome/pixmaps/gnomesword/search1.xpm
share/gnome/pixmaps/gnomesword/splash.png
share/gnome/pixmaps/gnomesword/strongs.xpm
share/gnome/pixmaps/gnomesword/sword.xpm
share/gnome/pixmaps/gnomesword/sword2.xpm
share/gnome/pixmaps/gnomesword/sword3.xpm
share/gnome/pixmaps/gnomesword/yes.xpm
@dirrm share/gnome/pixmaps/gnomesword
@dirrm share/gnome/help/gnomesword/C
@dirrm share/gnome/help/gnomesword
%%PORTDOCS%%@dirrm share/doc/gnomesword

38
misc/xiphos/Makefile Normal file
View file

@ -0,0 +1,38 @@
# New ports collection makefile for: gnomesword
# Date created: Oct 26, 2002
# Whom: J Shoemaker <shoemaker@softhome.net>
#
# $FreeBSD$
#
PORTNAME= gnomesword
PORTVERSION= 0.7.5
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= shoemaker@softhome.net
LIB_DEPENDS= sword.1:${PORTSDIR}/misc/sword
BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
USE_GNOMENG= yes
USE_GNOME= gal gnomehack gnomeprefix
USE_X_PREFIX= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
DOC_FILES= AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
post-configure:
${ECHO} "#define PACKAGE_PIXMAPS_DIR \"${PREFIX}/share/gnome/pixmaps/gnomesword\"">> ${WRKSRC}/config.h
post-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ${DOC_FILES}
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

1
misc/xiphos/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (gnomesword-0.7.5.tar.gz) = 674d410cc64ef76c570ed657e521c7aa

View file

@ -0,0 +1,18 @@
--- Makefile.in.orig Wed Oct 16 11:05:14 2002
+++ Makefile.in Wed Oct 16 11:06:31 2002
@@ -136,13 +136,13 @@
EXTRA_DIST = gnomesword.desktop
gnomesworddocdir = $(prefix)/doc/gnomesword
-gnomesworddoc_DATA = README COPYING AUTHORS ChangeLog INSTALL NEWS TODO
+gnomesworddoc_DATA = # README COPYING AUTHORS ChangeLog INSTALL NEWS TODO
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = config.h
CONFIG_CLEAN_FILES =
-DATA = $(gnomesworddoc_DATA)
+DATA = # $(gnomesworddoc_DATA)
DIST_COMMON = README ./stamp-h.in ABOUT-NLS AUTHORS COPYING ChangeLog \
INSTALL Makefile.am Makefile.in NEWS TODO acconfig.h aclocal.m4 \

1
misc/xiphos/pkg-comment Normal file
View file

@ -0,0 +1 @@
A bible interface utilizing the sword framework

11
misc/xiphos/pkg-descr Normal file
View file

@ -0,0 +1,11 @@
The GnomeSword GUI is a frontend to the SWORD project.
The SWORD Project is an effort to create an ever expanding software package
for research and study of God and His Word. The SWORD Bible Framework allows
easy manipulation of Bible texts, commentaries, lexicons, dictionaries, etc.
Many frontends are build using this framework. An installed module set may be
shared between any frontend using the framework.
WWW: http://www.crosswire.org/
// J Shoemaker <shoemaker@softhome.net>

2
misc/xiphos/pkg-message Normal file
View file

@ -0,0 +1,2 @@
To use gnomesword, you need to have bible, commentary and/or lexicon
modules. Those are available in the sword-modules package/port.

34
misc/xiphos/pkg-plist Normal file
View file

@ -0,0 +1,34 @@
bin/gnomesword
%%PORTDOCS%%share/doc/gnomesword/AUTHORS
%%PORTDOCS%%share/doc/gnomesword/COPYING
%%PORTDOCS%%share/doc/gnomesword/ChangeLog
%%PORTDOCS%%share/doc/gnomesword/INSTALL
%%PORTDOCS%%share/doc/gnomesword/NEWS
%%PORTDOCS%%share/doc/gnomesword/README
%%PORTDOCS%%share/doc/gnomesword/TODO
share/gnome/apps/Applications/gnomesword.desktop
share/gnome/help/gnomesword/C/index.html
share/gnome/help/gnomesword/C/intro.html
share/gnome/pixmaps/gnomesword/GnomeSword.png
share/gnome/pixmaps/gnomesword/GnomeSword.xpm
share/gnome/pixmaps/gnomesword/about.png
share/gnome/pixmaps/gnomesword/book-bl.png
share/gnome/pixmaps/gnomesword/book-gold.png
share/gnome/pixmaps/gnomesword/book-green.png
share/gnome/pixmaps/gnomesword/book-un.png
share/gnome/pixmaps/gnomesword/dock.xpm
share/gnome/pixmaps/gnomesword/exit2.xpm
share/gnome/pixmaps/gnomesword/footnote3.xpm
share/gnome/pixmaps/gnomesword/gnome-fontsel.xpm
share/gnome/pixmaps/gnomesword/morphs.xpm
share/gnome/pixmaps/gnomesword/search1.xpm
share/gnome/pixmaps/gnomesword/splash.png
share/gnome/pixmaps/gnomesword/strongs.xpm
share/gnome/pixmaps/gnomesword/sword.xpm
share/gnome/pixmaps/gnomesword/sword2.xpm
share/gnome/pixmaps/gnomesword/sword3.xpm
share/gnome/pixmaps/gnomesword/yes.xpm
@dirrm share/gnome/pixmaps/gnomesword
@dirrm share/gnome/help/gnomesword/C
@dirrm share/gnome/help/gnomesword
%%PORTDOCS%%@dirrm share/doc/gnomesword