add tcpsg 0.02

A simple TCP port forwarder

PR:		44751
Submitted by:	Michael L. Hostbaek <mich@freebsdcluster.org>
This commit is contained in:
Ying-Chieh Liao 2002-11-20 13:44:51 +00:00
parent 5d824297fb
commit 698ced054e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=70596
7 changed files with 71 additions and 0 deletions

View file

@ -561,6 +561,7 @@
SUBDIR += tcpmssd
SUBDIR += tcpreen
SUBDIR += tcpreplay
SUBDIR += tcpsg
SUBDIR += tcpshow
SUBDIR += tcpslice
SUBDIR += tcpstat

33
net/tcpsg/Makefile Normal file
View file

@ -0,0 +1,33 @@
# ex:ts=8
# Ports collection makefile for: tcpsg
# Date created: Tue Oct 30, 2002
# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
#
# $FreeBSD$
#
PORTNAME= tcpsg
PORTVERSION= 0.0.2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mich@freebsdcluster.org
USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/tcpsg.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
post-install:
${INSTALL_DATA} ${WRKSRC}/tcpsg.conf ${PREFIX}/etc/
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
${INSTALL_DATA} ${WRKSRC}/tcpsg.ctl ${DOCSDIR}/tcpsg.ctl
.endif
.include <bsd.port.mk>

1
net/tcpsg/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (tcpsg-0.0.2.tar.gz) = 796c4abceb14b7fc1447bad7397aa630

View file

@ -0,0 +1,21 @@
--- tcpsg.c.orig Wed Oct 30 13:14:39 2002
+++ tcpsg.c Wed Oct 30 13:41:13 2002
@@ -39,8 +39,8 @@
/* Network Headers */
#include <sys/socket.h>
-#include <arpa/inet.h>
#include <netinet/in.h>
+#include <arpa/inet.h>
#include <netdb.h>
/*
@@ -229,7 +229,7 @@
int set_config()
{
int i,j;
- i=read_config("/etc/tcpsg.conf");
+ i=read_config("%%PREFIX%%/etc/tcpsg.conf");
if (i==0)
{
for (i=0;i<main_opt.num_servers;i++)

1
net/tcpsg/pkg-comment Normal file
View file

@ -0,0 +1 @@
A simple TCP port forwarder

9
net/tcpsg/pkg-descr Normal file
View file

@ -0,0 +1,9 @@
TCPSG is just a simple TCP port forwarder designed to distribute a service
like a virtual server. It can be used to protect servers using the port
forwarder to receive requests.
AUTHOR: Juan Fajardo <jfajardo@unillanos.edu.co>
WWW: http://tcpsg.sourceforge.net/
- Michael L. Hostbaek
mich@freebsdcluster.org

5
net/tcpsg/pkg-plist Normal file
View file

@ -0,0 +1,5 @@
sbin/tcpsg
etc/tcpsg.conf
%%PORTDOCS%%share/doc/tcpsg/README
%%PORTDOCS%%share/doc/tcpsg/tcpsg.ctl
%%PORTDOCS%%@dirrm share/doc/tcpsg