dekagen is a front-end to several tools for the ripping, converting, and

naming of MP3 and Ogg-Vorbis files. It automates the whole process of ripping
data from music compact discs (CD), the naming of the files, their converting
into MP3 or Ogg-Vorbis format and the labelling of the MP3 files with an ID3
tag. dekagen uses dialog for a user interface that is intended to be
"intuitive".

Music data is read from CDs using cdda2wav, cdparanoia, dagrab, or tosha, and
stored on your harddisk in wav-format. Note that this will have an excessive
need of disk space. After this, the wav-data is converted into MP3 format
using 8hz-mp3, bladeenc, l3enc, lame, mp3enc, or notlame, or into Ogg-Vorbis
format using oggenc. This will take a while. To avoid manual naming and
tagging for all the files, cda is used for CDDB lookups. To label the MP3
files with ID3 tags, id3ed, id3tag, id3tool, or mp3info, or the built-in
capabilities of some encoders (lame, notlame) are used. Ogg-Vorbis files can
be labelled with oggenc.

WWW: http://userpage.fu-berlin.de/~mbayer/tools/dekagen.html
This commit is contained in:
Dirk Meyer 2003-08-17 10:00:34 +00:00
parent 42e475653b
commit 69c80d4e97
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=87122
6 changed files with 79 additions and 0 deletions

View file

@ -50,6 +50,7 @@
SUBDIR += dagrab
SUBDIR += dap
SUBDIR += darkice
SUBDIR += dekagen
SUBDIR += denemo
SUBDIR += discid
SUBDIR += easytag

43
audio/dekagen/Makefile Normal file
View file

@ -0,0 +1,43 @@
# New ports collection makefile for: dekagen
# Date created: 12 August 2003
# Whom: Martin Kraft <martin.kraft@fal.de>
#
# $FreeBSD$
#
PORTNAME= dekagen
PORTVERSION= 1.0
CATEGORIES= audio
MASTER_SITES= http://userpage.fu-berlin.de/~mbayer/tools/
MAINTAINER= martin.kraft@fal.de
COMMENT= A frontend to rip, convert and name MP3/Ogg
# The only reason for installing xmcd is, that dekagen uses cda
# for CDDB inquiries. You can safely 'make -DWITHOUT_XMCD', if you
# can do without inquiring the CDDB database. Dependencies of
# the xmcd package will install the encoders lame and oggenc (vorbis-tools),
# both of them are supported bye dekagen.
.if !defined(WITHOUT_XMCD)
RUN_DEPENDS+= cda:${PORTSDIR}/audio/xmcd
.endif
# If you want to use another ripper, eg. tosha or dagrab,
# you can safely 'make -DWITHOUT_CDPARANOIA'.
.if !defined(WITHOUT_CDPARANOIA)
RUN_DEPENDS+= cdparanoia:${PORTSDIR}/audio/cdparanoia
.endif
MAN1= dekagen.1
MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
NO_BUILD= Shell Script
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/dekagen ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/dekagen.1.gz ${PREFIX}/man/man1
.include <bsd.port.post.mk>

1
audio/dekagen/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (dekagen-1.0.tar.gz) = 2e8cc4216e7fe482594964d836587308

View file

@ -0,0 +1,12 @@
--- dekagen.orig Sat Jul 19 13:00:19 2003
+++ dekagen Tue Aug 12 23:02:30 2003
@@ -42,7 +42,8 @@
BITRATE='128' # MP3/Ogg nominal encoding bitrate (KBits)
METHOD='manual' # 'manual' or 'cddb'
XMCDLIB='' # $XMCD_LIBDIR
-DEVICE='/dev/cdrom' # device used for ripping
+# Adapted DEVICE to a reasonabe FreeBSD default. Martin Kraft.
+DEVICE='/dev/acd0c' # device used for ripping
NCONVENT='artist-name_of_song.mp3'
SELEC='1' # MP3/Ogg naming convention
WHOLE='no' # rip whole CD ('yes' or 'no')

21
audio/dekagen/pkg-descr Normal file
View file

@ -0,0 +1,21 @@
dekagen is a front-end to several tools for the ripping, converting, and
naming of MP3 and Ogg-Vorbis files. It automates the whole process of ripping
data from music compact discs (CD), the naming of the files, their converting
into MP3 or Ogg-Vorbis format and the labelling of the MP3 files with an ID3
tag. dekagen uses dialog for a user interface that is intended to be
"intuitive".
Music data is read from CDs using cdda2wav, cdparanoia, dagrab, or tosha, and
stored on your harddisk in wav-format. Note that this will have an excessive
need of disk space. After this, the wav-data is converted into MP3 format
using 8hz-mp3, bladeenc, l3enc, lame, mp3enc, or notlame, or into Ogg-Vorbis
format using oggenc. This will take a while. To avoid manual naming and
tagging for all the files, cda is used for CDDB lookups. To label the MP3
files with ID3 tags, id3ed, id3tag, id3tool, or mp3info, or the built-in
capabilities of some encoders (lame, notlame) are used. Ogg-Vorbis files can
be labelled with oggenc.
WWW: http://userpage.fu-berlin.de/~mbayer/tools/dekagen.html
- Martin Kraft
martin.kraft@fal.de

1
audio/dekagen/pkg-plist Normal file
View file

@ -0,0 +1 @@
bin/dekagen