Update to version 10.2.5

For the most part this is just to track upstream for FreeBSD.
In particular 10.2.0 introduced a regression whereby UFS support
was dropped.  The fix was backported to the FreeBSD port of 10.2.0
in lieu of waiting for 10.2.5 to be released.

PR:	227124
Submitted by:	John Wolfe <jwolfe@vmware.com>
This commit is contained in:
Josh Paetzel 2018-05-28 02:04:36 +00:00
parent 8869a77315
commit 69f24b93f5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=471014
13 changed files with 46 additions and 75 deletions

View file

@ -4,7 +4,6 @@
PORTNAME= open-vm-tools
PORTVERSION= ${RELEASE_VER}
DISTVERSIONPREFIX= stable-
PORTREVISION= 6
PORTEPOCH= 2
CATEGORIES= emulators
@ -18,8 +17,8 @@ ONLY_FOR_ARCHS= amd64 i386
LIB_DEPENDS= libmspack.so:archivers/libmspack
RELEASE_VER= 10.2.0
BUILD_VER= 7253323
RELEASE_VER= 10.2.5
BUILD_VER= 8068406
OPTIONS_DEFINE= DNET LIBNOTIFY OPENSSL X11
OPTIONS_DEFAULT= DNET LIBNOTIFY OPENSSL X11
@ -65,10 +64,6 @@ INSTALL_TARGET= install-strip
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1200063
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-modules_freebsd_vmxnet_net__compat.h
.endif
.if ${PORT_OPTIONS:MX11}
CONFLICTS= open-vm-tools-nox11-[0-9]*
.else

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1513787562
SHA256 (vmware-open-vm-tools-stable-10.2.0_GH0.tar.gz) = 40dccff0630034b4985ac7a0d3bfcf89025e9a57f518e561db8c6fd7322bf029
SIZE (vmware-open-vm-tools-stable-10.2.0_GH0.tar.gz) = 3200084
TIMESTAMP = 1524018090
SHA256 (vmware-open-vm-tools-stable-10.2.5_GH0.tar.gz) = c0f182c0c422fca8f8b3e5c21802f724256dfe5907383db28ec7e4d5b6d52b0f
SIZE (vmware-open-vm-tools-stable-10.2.5_GH0.tar.gz) = 3207633

View file

@ -1,13 +0,0 @@
--- modules/freebsd/vmxnet/net_compat.h.orig 2018-05-23 22:11:09 UTC
+++ modules/freebsd/vmxnet/net_compat.h
@@ -38,8 +38,8 @@
#define VXN_IFMULTI_FIRST LIST_FIRST
#define VXN_IFMULTI_NEXT LIST_NEXT
#else /* >= 500016 */
- #define VXN_IFMULTI_FIRST TAILQ_FIRST
- #define VXN_IFMULTI_NEXT TAILQ_NEXT
+ #define VXN_IFMULTI_FIRST CK_STAILQ_FIRST
+ #define VXN_IFMULTI_NEXT CK_STAILQ_NEXT
#endif /* 500016 */
#if __FreeBSD_version < 500043

View file

@ -1,6 +1,6 @@
--- configure.ac.orig 2017-02-24 22:15:37 UTC
--- configure.ac.orig 2018-03-30 18:44:35 UTC
+++ configure.ac
@@ -1082,7 +1082,7 @@ AC_CHECK_HEADERS([sys/user.h],
@@ -1095,7 +1095,7 @@ AC_CHECK_HEADERS([sys/user.h],
])
AC_CHECK_HEADERS([sys/vfs.h])
AC_CHECK_HEADERS([syslimits.h])
@ -9,7 +9,7 @@
AC_CHECK_HEADER(
[wchar.h],
@@ -1137,7 +1137,7 @@ AC_C_VOLATILE
@@ -1142,7 +1142,7 @@ AC_C_VOLATILE
### General flags / actions
CFLAGS="$CFLAGS -Wall"

View file

@ -1,4 +1,4 @@
--- lib/guestApp/guestApp.c.orig 2017-02-24 22:15:37 UTC
--- lib/guestApp/guestApp.c.orig 2018-03-30 18:44:35 UTC
+++ lib/guestApp/guestApp.c
@@ -63,7 +63,7 @@
#elif defined __APPLE__

View file

@ -1,6 +1,6 @@
--- lib/include/vm_basic_types.h.orig 2017-02-24 22:15:37 UTC
--- lib/include/vm_basic_types.h.orig 2018-03-30 18:44:35 UTC
+++ lib/include/vm_basic_types.h
@@ -415,6 +415,7 @@ typedef int64 VmTimeVirtualClock; /* Vi
@@ -418,6 +418,7 @@ typedef int64 VmTimeVirtualClock; /* Virtual Clock ke
#endif
#elif defined(__linux__) || \
(defined(__FreeBSD__) && (__FreeBSD__ + 0))\

View file

@ -1,6 +1,6 @@
--- lib/misc/util_misc.c.orig 2017-02-24 22:15:37 UTC
--- lib/misc/util_misc.c.orig 2018-03-30 18:44:35 UTC
+++ lib/misc/util_misc.c
@@ -307,7 +307,7 @@ Util_CanonicalPathsIdentical(const char
@@ -303,7 +303,7 @@ Util_CanonicalPathsIdentical(const char *path1, // IN
return (strcmp(path1, path2) == 0);
#elif defined(_WIN32)
return (_stricmp(path1, path2) == 0);

View file

@ -1,6 +1,6 @@
--- lib/vmCheck/vmcheck.c.orig 2017-02-24 22:15:37 UTC
--- lib/vmCheck/vmcheck.c.orig 2018-03-30 18:44:35 UTC
+++ lib/vmCheck/vmcheck.c
@@ -134,6 +134,7 @@ VmCheckSafe(SafeCheckFn checkFn)
@@ -135,6 +135,7 @@ VmCheckSafe(SafeCheckFn checkFn)
#else
do {
int signals[] = {

View file

@ -1,10 +0,0 @@
--- lib/wiper/wiperPosix.c.orig 2018-02-24 17:51:48 UTC
+++ lib/wiper/wiperPosix.c
@@ -143,6 +143,7 @@ static const PartitionInfo gKnownPartitions[] = {
{ "ntfs", PARTITION_NTFS, NULL, TRUE },
{ "pcfs", PARTITION_PCFS, NULL, TRUE },
{ "reiserfs", PARTITION_REISERFS, NULL, TRUE },
+ { "ufs", PARTITION_UFS, NULL, TRUE },
{ "vfat", PARTITION_FAT, NULL, TRUE },
{ "zfs", PARTITION_ZFS, NULL, FALSE },
{ "xfs", PARTITION_XFS, NULL, TRUE },

View file

@ -1,6 +1,6 @@
--- modules/Makefile.am.orig 2017-04-25 03:59:07 UTC
--- modules/Makefile.am.orig 2018-04-18 02:28:12 UTC
+++ modules/Makefile.am
@@ -63,11 +63,11 @@ if SOLARIS
@@ -48,11 +48,11 @@ if SOLARIS
done
endif
if FREEBSD
@ -15,5 +15,5 @@
+# $(DESTDIR)$(MODULES_DIR); \
+# done
endif
if LINUX
for MOD in $(MODULES); do \
uninstall-hook:

View file

@ -1,6 +1,6 @@
--- modules/freebsd/vmblock/vfsops.c.orig 2017-02-24 22:15:37 UTC
--- modules/freebsd/vmblock/vfsops.c.orig 2018-03-30 18:44:35 UTC
+++ modules/freebsd/vmblock/vfsops.c
@@ -124,6 +124,11 @@ VMBlockVFSMount(struct mount *mp,
@@ -124,6 +124,11 @@ VMBlockVFSMount(struct mount *mp, // IN: mount(
char *pathname;
int len, error = 0;
@ -12,15 +12,15 @@
VMBLOCKDEBUG("VMBlockVFSMount(mp = %p)\n", (void *)mp);
/*
@@ -277,6 +282,11 @@ VMBlockVFSUnmount(struct mount *mp, /
@@ -276,6 +281,11 @@ VMBlockVFSUnmount(struct mount *mp, // IN: filesyst
void *mntdata;
int error;
int flags = 0, removed = 0;
+
+#if __FreeBSD_version >= 800087
+ struct thread *td;
+ td = curthread;
+#endif
+
VMBLOCKDEBUG("VMBlockVFSUnmount: mp = %p\n", (void *)mp);
xmp = MNTTOVMBLOCKMNT(mp);

View file

@ -0,0 +1,18 @@
--- modules/freebsd/vmxnet/net_compat.h.orig 2018-03-30 18:44:35 UTC
+++ modules/freebsd/vmxnet/net_compat.h
@@ -37,9 +37,14 @@
#if __FreeBSD_version < 500016
#define VXN_IFMULTI_FIRST LIST_FIRST
#define VXN_IFMULTI_NEXT LIST_NEXT
-#else /* >= 500016 */
+#else
+#if __FreeBSD_version <= 1200063
#define VXN_IFMULTI_FIRST TAILQ_FIRST
#define VXN_IFMULTI_NEXT TAILQ_NEXT
+#else /* > 1200063 */
+ #define VXN_IFMULTI_FIRST CK_STAILQ_FIRST
+ #define VXN_IFMULTI_NEXT CK_STAILQ_NEXT
+#endif /* 1200063 */
#endif /* 500016 */
#if __FreeBSD_version < 500043

View file

@ -1,4 +1,4 @@
--- services/plugins/vix/vixTools.c.orig 2017-12-15 21:11:49 UTC
--- services/plugins/vix/vixTools.c.orig 2018-03-30 18:44:35 UTC
+++ services/plugins/vix/vixTools.c
@@ -52,6 +52,7 @@
#include <stdarg.h>
@ -8,26 +8,7 @@
#ifdef _WIN32
#include <WTypes.h>
@@ -7330,7 +7331,7 @@ VixToolsRunScript(VixCommandRequestHeader *requestMsg,
goto abort;
}
}
- for (var = 0; var <= 0xFFFFFFFF; var++) {
+ for (var = 0; ; var++) {
free(tempScriptFilePath);
tempScriptFilePath = Str_SafeAsprintf(NULL,
"%s"DIRSEPS"%s%d%s",
@@ -7373,6 +7374,9 @@ VixToolsRunScript(VixCommandRequestHeader *requestMsg,
*/
break;
}
+ if (var == INT_MAX) {
+ break;
+ }
}
if (fd < 0) {
/*
@@ -10131,7 +10135,7 @@ abort:
@@ -10133,7 +10134,7 @@ abort:
struct passwd pwd;
struct passwd *ppwd = &pwd;
char *buffer = NULL; // a pool of memory for Posix_Getpwnam_r() to use.
@ -36,7 +17,7 @@
/*
* For POSIX systems, look up the uid of 'username', and compare
@@ -10144,9 +10148,15 @@ abort:
@@ -10146,9 +10147,15 @@ abort:
* Multiply by 4 to compensate for the conversion to UTF-8 by
* the Posix_Getpwnam_r() wrapper.
*/