WAP::wbxml module implements binarisation of XML file according the
specification: * WAP - Wireless Application Protocol / Binary XML Content Format Specification / Version 1.3 WBXML (15th May 2000 Approved) The binary format was designed to preserve the element structure of XML. WWW: http://search.cpan.org/dist/WAP-wbxml/ Submitted by: Timur I. Bakeyev <timur(at)com.bat.ru> Approved by: krion (mentor)
This commit is contained in:
parent
0d93b98286
commit
6a0c3b2802
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=170903
6 changed files with 68 additions and 0 deletions
|
@ -68,6 +68,7 @@
|
|||
SUBDIR += p5-Unicode-RecursiveDowngrade
|
||||
SUBDIR += p5-Unicode-String
|
||||
SUBDIR += p5-Unicode-UTF8simple
|
||||
SUBDIR += p5-WAP-wbxml
|
||||
SUBDIR += p5-XML-WBXML
|
||||
SUBDIR += pecl-fribidi
|
||||
SUBDIR += php4-iconv
|
||||
|
|
33
converters/p5-WAP-wbxml/Makefile
Normal file
33
converters/p5-WAP-wbxml/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# New ports collection makefile for: converters/p5-WAP-wbxml
|
||||
# Date created: 1 Aug 2006
|
||||
# Whom: Timur I. Bakeyev <bat@cpan.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= WAP-wbxml
|
||||
PORTVERSION= 1.10
|
||||
CATEGORIES= converters perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= WAP/PERRAD
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= bat@cpan.org
|
||||
COMMENT= Binarization of XML file
|
||||
|
||||
BUILD_DEPENDS= ${SITE_PERL}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM \
|
||||
${SITE_PERL}/I18N/Charset.pm:${PORTSDIR}/misc/p5-I18N-Charset \
|
||||
${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
MAN1= wbxmlc.pl.1
|
||||
MAN3= WAP::wbxml.3
|
||||
|
||||
post-patch:
|
||||
.for file in syncml.wbrules.xml wap.wbrules.xml wbxmlc.pl wbxml.pm wv.wbrules.xml
|
||||
@${PERL} -pi -e 's#\r$$##g' ${WRKSRC}/${file}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
3
converters/p5-WAP-wbxml/distinfo
Normal file
3
converters/p5-WAP-wbxml/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (WAP-wbxml-1.10.tar.gz) = 4951247b08a4781d7d5e510cbc5fade8
|
||||
SHA256 (WAP-wbxml-1.10.tar.gz) = 1e113ef6114466132e886d92fbc6a079ef2bfa9aed056b12606196bfb6984d10
|
||||
SIZE (WAP-wbxml-1.10.tar.gz) = 29153
|
13
converters/p5-WAP-wbxml/files/patch-aa
Normal file
13
converters/p5-WAP-wbxml/files/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- wbxml.pm.orig Thu Aug 10 14:50:54 2006
|
||||
+++ wbxml.pm Thu Aug 10 14:51:56 2006
|
||||
@@ -9,7 +9,9 @@
|
||||
|
||||
use vars qw($VERSION);
|
||||
$VERSION = '1.10';
|
||||
-
|
||||
+## Create global package version
|
||||
+$WAP::wbxml::VERSION = $VERSION;
|
||||
+
|
||||
=head1 NAME
|
||||
|
||||
WAP::wbxml - Binarization of XML file
|
9
converters/p5-WAP-wbxml/pkg-descr
Normal file
9
converters/p5-WAP-wbxml/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
WAP::wbxml module implements binarisation of XML file according the
|
||||
specification:
|
||||
|
||||
* WAP - Wireless Application Protocol / Binary XML Content Format
|
||||
Specification / Version 1.3 WBXML (15th May 2000 Approved)
|
||||
|
||||
The binary format was designed to preserve the element structure of XML.
|
||||
|
||||
WWW: http://search.cpan.org/dist/WAP-wbxml/
|
9
converters/p5-WAP-wbxml/pkg-plist
Normal file
9
converters/p5-WAP-wbxml/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
bin/wbxmlc.pl
|
||||
%%SITE_PERL%%/WAP/wbxml.pm
|
||||
%%SITE_PERL%%/WAP/wap.wbrules.xml
|
||||
%%SITE_PERL%%/WAP/syncml.wbrules.xml
|
||||
%%SITE_PERL%%/WAP/wv.wbrules.xml
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/WAP/wbxml/.packlist
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WAP/wbxml
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WAP
|
||||
@dirrmtry %%SITE_PERL%%/WAP
|
Loading…
Reference in a new issue