- Update to 3.2.1

- Add NO_ARCH
- Add py3- counterpart

PR:		216407
Approved by:	wg (maintainer)
This commit is contained in:
Dmitry Marakasov 2017-01-24 12:32:49 +00:00
parent d6862ed573
commit 6a3468d296
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=432331
6 changed files with 23 additions and 26 deletions

View file

@ -4850,6 +4850,7 @@
SUBDIR += py3-babel
SUBDIR += py3-click
SUBDIR += py3-dbus
SUBDIR += py3-flake8
SUBDIR += py3-gobject3
SUBDIR += py3-hgtools
SUBDIR += py3-jsonschema

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= flake8
PORTVERSION= 2.5.4
PORTREVISION= 1
PORTVERSION= 3.2.1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -13,11 +12,13 @@ COMMENT= Code checking using pep8 and pyflakes
LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mccabe>=0.2.1:devel/py-mccabe \
${PYTHON_PKGNAMEPREFIX}pep8>=1.5.7:devel/pep8 \
BUILD_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner
RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}mccabe>=0.5.0:devel/py-mccabe \
${PYTHON_PKGNAMEPREFIX}pycodestyle>=2.0.0:devel/py-pycodestyle \
${PYTHON_PKGNAMEPREFIX}pyflakes>=0.8.1:devel/py-pyflakes
USES= python
USES?= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1463831204
SHA256 (flake8-2.5.4.tar.gz) = cc1e58179f6cf10524c7bfdd378f5536d0a61497688517791639a5ecc867492f
SIZE (flake8-2.5.4.tar.gz) = 81663
TIMESTAMP = 1484910118
SHA256 (flake8-3.2.1.tar.gz) = c7c460b5aff3a2063c798a77af18ec70af3941d35a22e2e76965e3c0e0b36055
SIZE (flake8-3.2.1.tar.gz) = 129458

View file

@ -1,7 +0,0 @@
--- flake8.egg-info/requires.txt.orig 2016-02-11 17:54:19 UTC
+++ flake8.egg-info/requires.txt
@@ -1,3 +1,3 @@
-pyflakes >= 0.8.1, < 1.1
+pyflakes >= 0.8.1
pep8 >= 1.5.7, != 1.6.0, != 1.6.1, != 1.6.2
mccabe >= 0.2.1, < 0.5

View file

@ -1,11 +0,0 @@
--- setup.py.orig 2016-02-10 22:07:13 UTC
+++ setup.py
@@ -49,7 +49,7 @@ setup(
url="https://gitlab.com/pycqa/flake8",
packages=["flake8", "flake8.tests"],
install_requires=[
- "pyflakes >= 0.8.1, < 1.1",
+ "pyflakes >= 0.8.1",
"pep8 >= 1.5.7, != 1.6.0, != 1.6.1, != 1.6.2",
"mccabe >= 0.2.1, < 0.5",
],

13
devel/py3-flake8/Makefile Normal file
View file

@ -0,0 +1,13 @@
# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
MASTERDIR= ${.CURDIR}/../py-flake8
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py3-pytest-runner
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mccabe>=0.5.0:devel/py3-mccabe \
${PYTHON_PKGNAMEPREFIX}pycodestyle>=2.0.0:devel/py3-pycodestyle \
${PYTHON_PKGNAMEPREFIX}pyflakes>=0.8.1:devel/py3-pyflakes
USES= python:3
.include "${MASTERDIR}/Makefile"