devel/py-pympler: update to 0.4.2
This commit is contained in:
parent
b5a80049b9
commit
6a4830fcc2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=401522
3 changed files with 3 additions and 25 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= Pympler
|
||||
PORTVERSION= 0.3.1
|
||||
PORTVERSION= 0.4.2
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (Pympler-0.3.1.tar.gz) = 8cb170fddfe592342856590e2239e8c20ac61eacf18bc4f65a95ccaf74475e3e
|
||||
SIZE (Pympler-0.3.1.tar.gz) = 382158
|
||||
SHA256 (Pympler-0.4.2.tar.gz) = 3c3f9d8eb3dddf4f29c433433ea77c9c3f2f0dcc06575c0c2a9d81b2602893b2
|
||||
SIZE (Pympler-0.4.2.tar.gz) = 395765
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
--- setup.py.orig 2012-12-29 14:55:15.000000000 -0200
|
||||
+++ setup.py 2014-07-02 17:24:26.639875716 -0300
|
||||
@@ -21,8 +21,8 @@
|
||||
_not_supported('Pympler requires Python 2.4 or newer')
|
||||
|
||||
import os
|
||||
-from distutils.command.build_py import build_py
|
||||
-from distutils.command.install_lib import install_lib
|
||||
+from setuptools.command.build_py import build_py
|
||||
+from setuptools.command.install_lib import install_lib
|
||||
from distutils.core import Command
|
||||
from distutils.core import setup
|
||||
from distutils.dist import Distribution
|
||||
@@ -53,7 +53,7 @@
|
||||
data_path = cobj.install_data
|
||||
for line in fileinput.FileInput(module_file, inplace=True):
|
||||
if line.startswith("DATA_PATH = "):
|
||||
- line = "DATA_PATH = '%s'\n" % data_path
|
||||
+ line = "DATA_PATH = '%s'\n" % data_path.replace('%%STAGEDIR%%', '')
|
||||
sys.stdout.write(line)
|
||||
build_py.build_module(self, module, module_file, package)
|
||||
|
Loading…
Reference in a new issue