- p5-libapreq2 has been committed by kuriyama.
- apply kuriyama's modified patch to www/p5-MasonX-Apche2Handler. PR: ports/72037 Submitted by: maintainer (Autrijus Tang <autrijus AT not.autrijus dot org>) Reviewed by: kuriyama Approved by: co-mentor (vanilla)
This commit is contained in:
parent
3bb4a284ac
commit
6a7189eebe
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=119425
3 changed files with 28 additions and 2 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= MasonX-Apache2Handler
|
||||
PORTVERSION= 0.05
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= www perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= MasonX
|
||||
|
@ -15,14 +16,16 @@ PKGNAMEPREFIX= p5-
|
|||
MAINTAINER= autrijus@autrijus.org
|
||||
COMMENT= Mason/mod_perl2 interface
|
||||
|
||||
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2:${PORTSDIR}/www/mod_perl2 \
|
||||
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2/ModPerl/Config.pm:${PORTSDIR}/www/mod_perl2 \
|
||||
${SITE_PERL}/${PERL_ARCH}/Apache2/Apache/Cookie.pm:${PORTSDIR}/www/p5-libapreq2 \
|
||||
${SITE_PERL}/HTML/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason
|
||||
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
MAN3= MasonX::Apache2Handler.3 MasonX::Mason-with-mod_perl2.3
|
||||
|
||||
post-patch:
|
||||
${FIND} ${WRKSRC} -name '*.orig' | ${XARGS} ${RM}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
12
www/p5-MasonX-Apache2Handler/files/patch-Makefile.PL
Normal file
12
www/p5-MasonX-Apache2Handler/files/patch-Makefile.PL
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- Makefile.PL.orig Thu Sep 23 18:16:48 2004
|
||||
+++ Makefile.PL Thu Sep 23 18:17:14 2004
|
||||
@@ -14,6 +14,9 @@
|
||||
*EOF*
|
||||
sleep 3;
|
||||
|
||||
+# Detect PREREQ_PM if they are installed in Apache2/.
|
||||
+eval { require Apache2 };
|
||||
+
|
||||
WriteMakefile(
|
||||
NAME => 'MasonX::Apache2Handler',
|
||||
VERSION_FROM => 'lib/MasonX/Apache2Handler.pm', # finds $VERSION
|
|
@ -0,0 +1,11 @@
|
|||
--- lib/MasonX/Apache2Handler.pm Thu Sep 23 17:26:41 2004
|
||||
+++ lib/MasonX/Apache2Handler.pm Thu Sep 23 17:26:54 2004
|
||||
@@ -615,7 +615,7 @@
|
||||
if (exists $allowed_params->{data_dir} and not exists $params{data_dir})
|
||||
{
|
||||
# constructs path to <server root>/mason
|
||||
- my $def = $defaults{data_dir} = Apache->server->server_root_relative('mason');
|
||||
+ my $def = $defaults{data_dir} = File::Spec->catfile(Apache::ServerUtil::server_root(), 'mason');
|
||||
param_error "Default data_dir (MasonDataDir) '$def' must be an absolute path"
|
||||
unless File::Spec->file_name_is_absolute($def);
|
||||
|
Loading…
Reference in a new issue