databases/mydumper: Update to 0.15.1-2
Changes: https://github.com/mydumper/mydumper/releases
This commit is contained in:
parent
12092ad379
commit
6a807d45ee
4 changed files with 23 additions and 26 deletions
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= mydumper
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.14.5-3
|
||||
DISTVERSION= 0.15.1-2
|
||||
CATEGORIES= databases
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1689398769
|
||||
SHA256 (mydumper-mydumper-v0.14.5-3_GH0.tar.gz) = 5eff8fac10551db7e43592e13397d089d014a926ec910151501ccf79ddba0c71
|
||||
SIZE (mydumper-mydumper-v0.14.5-3_GH0.tar.gz) = 178919
|
||||
TIMESTAMP = 1691069922
|
||||
SHA256 (mydumper-mydumper-v0.15.1-2_GH0.tar.gz) = c9d6bab6593bfe716e8c4ed30be2bf7d309c1211bd7b8ed27387d373e9932742
|
||||
SIZE (mydumper-mydumper-v0.15.1-2_GH0.tar.gz) = 165179
|
||||
|
|
|
@ -1,15 +1,11 @@
|
|||
--- CMakeLists.txt.orig 2023-01-13 19:52:59 UTC
|
||||
--- CMakeLists.txt.orig 2023-08-02 14:40:15 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -31,10 +31,10 @@ if (WITH_ZSTD)
|
||||
endif (WITH_ZSTD)
|
||||
@@ -30,7 +30,7 @@ if (MARIADB_FOUND AND NOT MARIADB_SSL AND WITH_SSL)
|
||||
set(WITH_SSL OFF)
|
||||
endif()
|
||||
|
||||
if (WITH_ZSTD)
|
||||
- set(CMAKE_C_FLAGS "-Wall -Wno-deprecated-declarations -Wunused -Wwrite-strings -Wno-strict-aliasing -Wextra -Wshadow -g -DZWRAP_USE_ZSTD=1 -Werror -Wno-discarded-qualifiers ${MYSQL_CFLAGS}")
|
||||
+ set(CMAKE_C_FLAGS "-Wall -Wno-deprecated-declarations -Wunused -Wwrite-strings -Wno-strict-aliasing -Wextra -Wshadow -g -DZWRAP_USE_ZSTD=1 -Wno-discarded-qualifiers ${MYSQL_CFLAGS}")
|
||||
include_directories(${MYDUMPER_SOURCE_DIR} ${MYSQL_INCLUDE_DIR} ${GLIB2_INCLUDE_DIR} ${PCRE_INCLUDE_DIR} ${ZLIB_INCLUDE_DIRS} ${ZSTD_INCLUDE_DIR} )
|
||||
else (WITH_ZSTD)
|
||||
- set(CMAKE_C_FLAGS "-Wall -Wno-deprecated-declarations -Wunused -Wwrite-strings -Wno-strict-aliasing -Wextra -Wshadow -g -Werror ${MYSQL_CFLAGS}")
|
||||
+ set(CMAKE_C_FLAGS "-Wall -Wno-deprecated-declarations -Wunused -Wwrite-strings -Wno-strict-aliasing -Wextra -Wshadow -g ${MYSQL_CFLAGS}")
|
||||
include_directories(${MYDUMPER_SOURCE_DIR} ${MYSQL_INCLUDE_DIR} ${GLIB2_INCLUDE_DIR} ${PCRE_INCLUDE_DIR} ${ZLIB_INCLUDE_DIRS} )
|
||||
endif (WITH_ZSTD)
|
||||
-set(CMAKE_C_FLAGS "-Wall -Wno-deprecated-declarations -Wunused -Wwrite-strings -Wno-strict-aliasing -Wextra -Wshadow -g -Werror ${MYSQL_CFLAGS}")
|
||||
+set(CMAKE_C_FLAGS "-Wall -Wno-deprecated-declarations -Wunused -Wwrite-strings -Wno-strict-aliasing -Wextra -Wshadow -g ${MYSQL_CFLAGS}")
|
||||
include_directories(${MYDUMPER_SOURCE_DIR} ${MYSQL_INCLUDE_DIR} ${GLIB2_INCLUDE_DIR} ${PCRE_INCLUDE_DIR} ${ZLIB_INCLUDE_DIRS} )
|
||||
|
||||
OPTION(WITH_ASAN "Build with ASAN" OFF)
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
--- src/myloader_common.c.orig 2023-05-24 12:16:48 UTC
|
||||
+++ src/myloader_common.c
|
||||
@@ -21,6 +21,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <sys/wait.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#ifdef ZWRAP_USE_ZSTD
|
||||
#include "../zstd/zstd_zlibwrapper.h"
|
||||
--- src/mydumper_common.c.orig 2023-08-02 14:40:15 UTC
|
||||
+++ src/mydumper_common.c
|
||||
@@ -123,7 +123,7 @@ int m_close_pipe(guint thread_id, void *file, gchar *f
|
||||
g_mutex_lock(fifo_table_mutex);
|
||||
struct fifo *f=g_hash_table_lookup(fifo_hash,file);
|
||||
g_mutex_unlock(fifo_table_mutex);
|
||||
- int r=close(fileno(file));
|
||||
+ int r=close(fileno((FILE *) file));
|
||||
if (f != NULL){
|
||||
int status=0;
|
||||
waitpid(f->pid, &status, 0);
|
||||
|
|
Loading…
Reference in a new issue