Remove, renamed to games/warmux

This commit is contained in:
Max Brazhnikov 2011-03-21 21:43:38 +00:00
parent 76fe8040a4
commit 6a8b0d70cf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=271437
7 changed files with 0 additions and 1759 deletions

View file

@ -1,66 +0,0 @@
# Ports collection makefile for: wormux
# Date created: Thu Dec 16 18:46:55 EET 2004
# Whom: Anton Yudin <toha@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= wormux
DISTVERSION= 0.9.2.1
PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://download.gna.org/wormux/ \
http://download.gna.org/wormux/archive/
MAINTAINER= makc@FreeBSD.org
COMMENT= Wormux game
LIB_DEPENDS= xml++-2.6.2:${PORTSDIR}/textproc/libxml++26 \
curl:${PORTSDIR}/ftp/curl
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SDL= sdl image mixer ttf gfx net
MAKE_JOBS_SAFE= yes
USE_DOS2UNIX= fixed_class.h
MANCOMPRESSED= no
MAN6= wormux.6
OPTIONS+= NLS "Native Language Support via gettext utilities" on \
FRIBIDI "Enable bi-directional unicode support" off \
SERVER "Enable dedicated server" off
.include <bsd.port.options.mk>
post-patch:
${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/Makefile.in \
${WRKSRC}/src/Makefile.in
${FIND} -d ${WRKSRC}/data/ -name "*.*~" -delete
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
.if defined(WITH_SERVER)
PLIST_SUB+= SERVER=""
CONFIGURE_ARGS+= --enable-servers
.else
PLIST_SUB+= SERVER="@comment "
.endif
.if defined(WITH_FRIBIDI)
LIB_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
CONFIGURE_ARGS+= --enable-fribidi
.else
CONFIGURE_ARGS+= --disable-fribidi
.endif
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (wormux-0.9.2.1.tar.bz2) = e49621b9b4ac7c8d1b11657989df61db
SHA256 (wormux-0.9.2.1.tar.bz2) = 01372e5eefb20f95d984c5b4376b71e8cde58d2e7ec8d30de6585ce05ea90140
SIZE (wormux-0.9.2.1.tar.bz2) = 99679696

View file

@ -1,11 +0,0 @@
--- src/game/config.h.orig 2008-08-20 13:36:54.000000000 +0300
+++ src/game/config.h 2008-08-20 13:35:42.000000000 +0300
@@ -126,7 +126,7 @@
const std::string& GetTtfFilename();
- std::string GetDataDir() const { return data_dir; };
+ std::string GetDataDir() const { return data_dir + "/"; };
std::string GetLocaleDir() const { return locale_dir; };
std::string GetPersonalDataDir() const { return personal_data_dir; };
std::string GetChatLogDir() const { return chat_log_dir; };

View file

@ -1,11 +0,0 @@
--- configure.orig 2008-06-28 20:02:41.000000000 +0400
+++ configure 2008-07-01 04:33:14.000000000 +0400
@@ -6825,8 +6825,6 @@
DATADIR="$withval"
fi;
-# ensure a trailing slash (r4255)
-DATADIR="${DATADIR}/"
if test "${WIN32}" = "yes"; then LOCALEDIR="locale"

View file

@ -1,15 +0,0 @@
--- ./lib/fixedpoint/fixed_class.h.orig 2010-04-18 21:42:49.000000000 +0400
+++ ./lib/fixedpoint/fixed_class.h 2010-04-24 14:38:36.456848203 +0400
@@ -50,6 +50,12 @@
#ifdef __APPLE__
#define SIZE_T_FIXEDPOINT_METHODS
#endif
+
+#ifdef __FreeBSD__
+ #include <machine/elf.h>
+ #define __WORDSIZE __ELF_WORD_SIZE
+#endif
+
#if __WORDSIZE == 64
#define SIZE_T_FIXEDPOINT_METHODS
#endif

View file

@ -1,14 +0,0 @@
Almost everyone has heard of the Worms(R) series of games, developed by Team17.
Worms was created in 1990, the goal of the game consisting of a several teams of
"worms" fighting to the death on a 2D map. Wormux is heavily influenced by all
games in this genre, including Scorched Earth and Liero.
Wormux is free software clone of this game concept. Though currently under heavy
development, it is already very playable, with lots of weapons (Dynamite,
Baseball Bat, Teleportation, etc.). There are also lots of maps available for
your battling pleasure! Wormux takes the genre to the next level, with great
customisation options leading to great gameplay. There is a wide selection of
teams, from the Aliens to the Chickens. Also, new battlefields can be downloaded
from the Internet, making strategy an important part of each battle.
WWW: http://www.wormux.org/

File diff suppressed because it is too large Load diff