- Update to 1.5

Changes:	http://www.open-mpi.org/community/lists/hwloc-announce/2012/07/0043.php
PR:		ports/170314
Submitted by:	Eijiro Shibusawa <phd_kimberlite@yahoo.co.jp> (maintainer)
This commit is contained in:
Frederic Culot 2012-08-01 19:22:27 +00:00
parent aec4614ca6
commit 6a97563370
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=301839
6 changed files with 62 additions and 37 deletions

View file

@ -6,10 +6,10 @@
#
PORTNAME= hwloc
PORTVERSION= 1.4.2
PORTVERSION= 1.5
CATEGORIES= devel
MASTER_SITES= http://www.open-mpi.org/software/hwloc/v1.4/downloads/ \
http://icl.cs.utk.edu/open-mpi/software/hwloc/v1.4/downloads/
MASTER_SITES= http://www.open-mpi.org/software/hwloc/v1.5/downloads/ \
http://icl.cs.utk.edu/open-mpi/software/hwloc/v1.5/downloads/
MAINTAINER= phd_kimberlite@yahoo.co.jp
COMMENT= The Portable Hardware Locality software package
@ -38,7 +38,7 @@ CONFIGURE_ARGS+= --disable-cairo \
.else
CONFIGURE_ARGS+= --enable-cairo \
--with-x
LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo
USE_XORG= x11
.endif
@ -58,7 +58,7 @@ post-install:
@(cd ${MAN1PREFIX}/man/man1/ ;\
${LN} -sf lstopo.1.gz hwloc-info.1.gz ; \
${LN} -sf lstopo.1.gz hwloc-ls.1.gz ;\
${LN} -sf hwloc-calc.1.gz hwloc-mask.1.gz )
${LN} -sf lstopo.1.gz lstopo-no-graphics.1.gz )
.ifdef !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/html
@${INSTALL_DATA} ${WRKSRC}/doc/doxygen-doc/html/* ${DOCSDIR}/html/.

View file

@ -1,2 +1,2 @@
SHA256 (hwloc-1.4.2.tar.bz2) = bcb917dfa5b5ccc150f54afef74d77ee11cb4c6fcd402273d828b83c97655575
SIZE (hwloc-1.4.2.tar.bz2) = 2703403
SHA256 (hwloc-1.5.tar.bz2) = ba8519c27eb5637d184a0673a701265a94c4e8ab1ca6bfcf903bcd1f627474ea
SIZE (hwloc-1.5.tar.bz2) = 2887977

View file

@ -1,5 +1,5 @@
MAN1= hwloc-assembler.1 \
hwloc-assembler-remote.1 \
MAN1= hwloc-assembler-remote.1 \
hwloc-assembler.1 \
hwloc-bind.1 \
hwloc-calc.1 \
hwloc-distances.1 \
@ -28,6 +28,9 @@ MAN3= HWLOC_API_VERSION.3 \
HWLOC_OBJ_BRIDGE_HOST.3 \
HWLOC_OBJ_BRIDGE_PCI.3 \
HWLOC_OBJ_CACHE.3 \
HWLOC_OBJ_CACHE_DATA.3 \
HWLOC_OBJ_CACHE_INSTRUCTION.3 \
HWLOC_OBJ_CACHE_UNIFIED.3 \
HWLOC_OBJ_CORE.3 \
HWLOC_OBJ_GROUP.3 \
HWLOC_OBJ_MACHINE.3 \
@ -47,6 +50,7 @@ MAN3= HWLOC_API_VERSION.3 \
HWLOC_RESTRICT_FLAG_ADAPT_DISTANCES.3 \
HWLOC_RESTRICT_FLAG_ADAPT_IO.3 \
HWLOC_RESTRICT_FLAG_ADAPT_MISC.3 \
HWLOC_TOPOLOGY_FLAG_ICACHES.3 \
HWLOC_TOPOLOGY_FLAG_IO_BRIDGES.3 \
HWLOC_TOPOLOGY_FLAG_IO_DEVICES.3 \
HWLOC_TOPOLOGY_FLAG_IS_THISSYSTEM.3 \
@ -120,14 +124,12 @@ MAN3= HWLOC_API_VERSION.3 \
hwloc_cpubind_flags_t.3 \
hwloc_cpuset_from_glibc_sched_affinity.3 \
hwloc_cpuset_from_linux_libnuma_bitmask.3 \
hwloc_cpuset_from_linux_libnuma_nodemask.3 \
hwloc_cpuset_from_linux_libnuma_ulongs.3 \
hwloc_cpuset_from_nodeset.3 \
hwloc_cpuset_from_nodeset_strict.3 \
hwloc_cpuset_t.3 \
hwloc_cpuset_to_glibc_sched_affinity.3 \
hwloc_cpuset_to_linux_libnuma_bitmask.3 \
hwloc_cpuset_to_linux_libnuma_nodemask.3 \
hwloc_cpuset_to_linux_libnuma_ulongs.3 \
hwloc_cpuset_to_nodeset.3 \
hwloc_cpuset_to_nodeset_strict.3 \
@ -150,6 +152,7 @@ MAN3= HWLOC_API_VERSION.3 \
hwloc_get_area_membind.3 \
hwloc_get_area_membind_nodeset.3 \
hwloc_get_cache_covering_cpuset.3 \
hwloc_get_cache_type_depth.3 \
hwloc_get_child_covering_cpuset.3 \
hwloc_get_closest_objs.3 \
hwloc_get_common_ancestor_obj.3 \
@ -203,6 +206,7 @@ MAN3= HWLOC_API_VERSION.3 \
hwloc_get_whole_distance_matrix_by_depth.3 \
hwloc_get_whole_distance_matrix_by_type.3 \
hwloc_ibv_get_device_cpuset.3 \
hwloc_ibv_get_device_osdev_by_name.3 \
hwloc_linux_get_tid_cpubind.3 \
hwloc_linux_parse_cpumap_file.3 \
hwloc_linux_set_tid_cpubind.3 \
@ -211,11 +215,9 @@ MAN3= HWLOC_API_VERSION.3 \
hwloc_mx_board_get_device_cpuset.3 \
hwloc_mx_endpoint_get_device_cpuset.3 \
hwloc_nodeset_from_linux_libnuma_bitmask.3 \
hwloc_nodeset_from_linux_libnuma_nodemask.3 \
hwloc_nodeset_from_linux_libnuma_ulongs.3 \
hwloc_nodeset_t.3 \
hwloc_nodeset_to_linux_libnuma_bitmask.3 \
hwloc_nodeset_to_linux_libnuma_nodemask.3 \
hwloc_nodeset_to_linux_libnuma_ulongs.3 \
hwloc_obj.3 \
hwloc_obj_add_info.3 \
@ -228,6 +230,8 @@ MAN3= HWLOC_API_VERSION.3 \
hwloc_obj_attr_u_hwloc_pcidev_attr_s.3 \
hwloc_obj_bridge_type_e.3 \
hwloc_obj_bridge_type_t.3 \
hwloc_obj_cache_type_e.3 \
hwloc_obj_cache_type_t.3 \
hwloc_obj_cpuset_snprintf.3 \
hwloc_obj_get_info_by_name.3 \
hwloc_obj_info_s.3 \
@ -314,7 +318,6 @@ MAN3= HWLOC_API_VERSION.3 \
hwlocality_information.3 \
hwlocality_linux.3 \
hwlocality_linux_libnuma_bitmask.3 \
hwlocality_linux_libnuma_nodemask.3 \
hwlocality_linux_libnuma_ulongs.3 \
hwlocality_membinding.3 \
hwlocality_myriexpress.3 \

View file

@ -1,6 +1,6 @@
--- configure.orig 2012-02-28 06:06:52.000000000 +0900
+++ configure 2012-05-06 14:26:15.000000000 +0900
@@ -5569,7 +5569,7 @@
--- configure.orig 2012-07-30 17:36:50.000000000 +0900
+++ configure 2012-08-01 19:12:58.000000000 +0900
@@ -7001,7 +7001,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking which CPU support to include" >&5
$as_echo_n "checking which CPU support to include... " >&6; }
case ${target} in

View file

@ -1,10 +1,12 @@
--- utils/Makefile.in.orig 2012-05-15 23:05:42.000000000 +0900
+++ utils/Makefile.in 2012-05-15 23:09:34.000000000 +0900
@@ -1280,7 +1280,6 @@
@HWLOC_BUILD_UTILS_TRUE@ rm -f $(DESTDIR)$(bindir)/hwloc-ls$(EXEEXT) $(DESTDIR)$(bindir)/hwloc-info$(EXEEXT) $(DESTDIR)$(bindir)/hwloc-mask$(EXEEXT)
@HWLOC_BUILD_UTILS_TRUE@ cd $(DESTDIR)$(bindir) && $(LN_S) lstopo$(EXEEXT) hwloc-ls$(EXEEXT) && $(LN_S) lstopo$(EXEEXT) hwloc-info$(EXEEXT) && $(LN_S) hwloc-calc$(EXEEXT) hwloc-mask$(EXEEXT)
@HWLOC_BUILD_UTILS_TRUE@ rm -f $(DESTDIR)$(man1dir)/hwloc-ls.1 $(DESTDIR)$(man1dir)/hwloc-info.1 $(DESTDIR)$(man1dir)/hwloc-mask.1
-@HWLOC_BUILD_UTILS_TRUE@ cd $(DESTDIR)$(man1dir) && $(LN_S) lstopo.1 hwloc-ls.1 && $(LN_S) lstopo.1 hwloc-info.1 && $(LN_S) hwloc-calc.1 hwloc-mask.1
--- utils/Makefile.in.orig 2012-07-30 17:36:52.000000000 +0900
+++ utils/Makefile.in 2012-08-01 16:17:49.000000000 +0900
@@ -1477,9 +1477,7 @@
@HWLOC_BUILD_UTILS_TRUE@@HWLOC_HAVE_CAIRO_FALSE@@HWLOC_HAVE_WINDOWS_FALSE@ rm -f $(DESTDIR)$(bindir)/lstopo
@HWLOC_BUILD_UTILS_TRUE@@HWLOC_HAVE_CAIRO_FALSE@@HWLOC_HAVE_WINDOWS_FALSE@ cd $(DESTDIR)$(bindir) && $(LN_S) lstopo-no-graphics$(EXEEXT) lstopo$(EXEEXT) || true
@HWLOC_BUILD_UTILS_TRUE@ rm -f $(DESTDIR)$(man1dir)/hwloc-ls.1 $(DESTDIR)$(man1dir)/hwloc-info.1
-@HWLOC_BUILD_UTILS_TRUE@ cd $(DESTDIR)$(man1dir) && $(LN_S) lstopo.1 hwloc-ls.1 && $(LN_S) lstopo.1 hwloc-info.1
@HWLOC_BUILD_UTILS_TRUE@ rm -f $(DESTDIR)$(man1dir)/lstopo-no-graphics.1
-@HWLOC_BUILD_UTILS_TRUE@ cd $(DESTDIR)$(man1dir) && $(LN_S) lstopo.1 lstopo-no-graphics.1
@HWLOC_BUILD_UTILS_TRUE@ $(SED) -e 's/abs_top_builddir\/utils/bindir/' -e '/abs_top_builddir/d' $(DESTDIR)$(bindir)/hwloc-assembler-remote > $(DESTDIR)$(bindir)/hwloc-assembler-remote.tmp && mv -f $(DESTDIR)$(bindir)/hwloc-assembler-remote.tmp $(DESTDIR)$(bindir)/hwloc-assembler-remote
@HWLOC_BUILD_UTILS_TRUE@ chmod +x $(DESTDIR)$(bindir)/hwloc-assembler-remote

View file

@ -1,4 +1,4 @@
lib/libhwloc.so.5
lib/libhwloc.so.6
lib/libhwloc.so
lib/libhwloc.la
lib/libhwloc.a
@ -79,30 +79,51 @@ share/hwloc/hwloc-valgrind.supp
%%PORTDOCS%%%%DOCSDIR%%/html/a00071.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00072.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00073.html
%%PORTDOCS%%%%DOCSDIR%%/html/a00074.html
%%PORTDOCS%%%%DOCSDIR%%/html/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/html/bc_s.png
%%PORTDOCS%%%%DOCSDIR%%/html/bdwn.png
%%PORTDOCS%%%%DOCSDIR%%/html/classes.html
%%PORTDOCS%%%%DOCSDIR%%/html/closed.png
%%PORTDOCS%%%%DOCSDIR%%/html/devel09-pci.png
%%PORTDOCS%%%%DOCSDIR%%/html/diagram.png
%%PORTDOCS%%%%DOCSDIR%%/html/dir_5cb306d949c7931a3b6c77517393dd34.html
%%PORTDOCS%%%%DOCSDIR%%/html/dir_d44c64559bbebec7f509842c48db8b23.html
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.png
%%PORTDOCS%%%%DOCSDIR%%/html/dudley.png
%%PORTDOCS%%%%DOCSDIR%%/html/dynsections.js
%%PORTDOCS%%%%DOCSDIR%%/html/emmett.png
%%PORTDOCS%%%%DOCSDIR%%/html/files.html
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2blank.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2cl.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2doc.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2folderclosed.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2folderopen.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2lastnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2link.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2mlastnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2mnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2mo.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2node.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2ns.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2plastnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2pnode.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2splitbar.png
%%PORTDOCS%%%%DOCSDIR%%/html/ftv2vertline.png
%%PORTDOCS%%%%DOCSDIR%%/html/functions.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars.html
%%PORTDOCS%%%%DOCSDIR%%/html/hagrid.png
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/modules.html
%%PORTDOCS%%%%DOCSDIR%%/html/nav_f.png
%%PORTDOCS%%%%DOCSDIR%%/html/nav_g.png
%%PORTDOCS%%%%DOCSDIR%%/html/nav_h.png
%%PORTDOCS%%%%DOCSDIR%%/html/open.png
%%PORTDOCS%%%%DOCSDIR%%/html/pages.html
%%PORTDOCS%%%%DOCSDIR%%/html/ppc64-full-with-smt.png
%%PORTDOCS%%%%DOCSDIR%%/html/ppc64-with-smt.png
%%PORTDOCS%%%%DOCSDIR%%/html/ppc64-without-smt.png
%%PORTDOCS%%%%DOCSDIR%%/html/sync_off.png
%%PORTDOCS%%%%DOCSDIR%%/html/sync_on.png
%%PORTDOCS%%%%DOCSDIR%%/html/tab_a.png
%%PORTDOCS%%%%DOCSDIR%%/html/tab_b.png
%%PORTDOCS%%%%DOCSDIR%%/html/tab_h.png
@ -110,28 +131,27 @@ share/hwloc/hwloc-valgrind.supp
%%PORTDOCS%%%%DOCSDIR%%/html/tabs.css
man/man1/hwloc-info.1.gz
man/man1/hwloc-ls.1.gz
man/man1/hwloc-mask.1.gz
man/man1/lstopo-no-graphics.1.gz
include/hwloc.h
include/hwloc/autogen/config.h
include/hwloc/bitmap.h
include/hwloc/cpuset.h
include/hwloc/cuda.h
include/hwloc/cudart.h
include/hwloc/helper.h
include/hwloc/myriexpress.h
include/hwloc/openfabrics-verbs.h
include/hwloc/cuda.h
include/hwloc/cudart.h
include/hwloc/rename.h
include/hwloc/autogen/config.h
bin/hwloc-assembler
bin/hwloc-distances
bin/hwloc-assembler-remote
bin/hwloc-calc
bin/hwloc-bind
bin/hwloc-calc
bin/hwloc-distances
bin/hwloc-distrib
bin/hwloc-ps
bin/hwloc-ls
bin/hwloc-info
bin/hwloc-mask
bin/hwloc-ls
bin/hwloc-ps
bin/lstopo
bin/lstopo-no-graphics
@dirrmtry include/hwloc/autogen
@dirrmtry include/hwloc
%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/html