unbreak net/bpgq by adding \n\ to end of printf() statements.
Informed maintainer.
This commit is contained in:
parent
bbd73ace1f
commit
6ac61f9d07
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=91320
4 changed files with 58 additions and 14 deletions
|
@ -6,6 +6,7 @@
|
|||
|
||||
PORTNAME= bgpq
|
||||
PORTVERSION= 1.0.7.6
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/snar/
|
||||
|
||||
|
@ -19,10 +20,4 @@ HAS_CONFIGURE= yes
|
|||
post-install:
|
||||
${STRIP_CMD} ${PREFIX}/bin/bgpq
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 501000
|
||||
BROKEN= "Does not compile"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
27
net-mgmt/bgpq/files/patch-ro.c
Normal file
27
net-mgmt/bgpq/files/patch-ro.c
Normal file
|
@ -0,0 +1,27 @@
|
|||
--- ro.c.orig Wed Oct 15 06:07:13 2003
|
||||
+++ ro.c Wed Oct 15 06:07:38 2003
|
||||
@@ -471,18 +471,18 @@
|
||||
if(extrange) {
|
||||
if(retval<100 || (retval>199 && retval<2000) || retval>2699) {
|
||||
fprintf(f,"\
|
||||
-!=============================================================================
|
||||
-! WARNING ! %s is out of extended access-list ranges (100-199 and 2000-2699)
|
||||
-!=============================================================================
|
||||
+!=============================================================================\n\
|
||||
+! WARNING ! %s is out of extended access-list ranges (100-199 and 2000-2699)\n\
|
||||
+!=============================================================================\n\
|
||||
",string);
|
||||
exit(1);
|
||||
};
|
||||
} else {
|
||||
if((retval>100 && retval<1300) || retval>1999) {
|
||||
fprintf(f,"\
|
||||
-!=============================================================================
|
||||
-! WARNING ! %s is out of standard access-list ranges (1-99 and 1300-1999)
|
||||
-!=============================================================================
|
||||
+!=============================================================================\n\
|
||||
+! WARNING ! %s is out of standard access-list ranges (1-99 and 1300-1999)\n\
|
||||
+!=============================================================================\n\
|
||||
",string);
|
||||
|
||||
exit(1);
|
|
@ -6,6 +6,7 @@
|
|||
|
||||
PORTNAME= bgpq
|
||||
PORTVERSION= 1.0.7.6
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/snar/
|
||||
|
||||
|
@ -19,10 +20,4 @@ HAS_CONFIGURE= yes
|
|||
post-install:
|
||||
${STRIP_CMD} ${PREFIX}/bin/bgpq
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 501000
|
||||
BROKEN= "Does not compile"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
27
net/bgpq/files/patch-ro.c
Normal file
27
net/bgpq/files/patch-ro.c
Normal file
|
@ -0,0 +1,27 @@
|
|||
--- ro.c.orig Wed Oct 15 06:07:13 2003
|
||||
+++ ro.c Wed Oct 15 06:07:38 2003
|
||||
@@ -471,18 +471,18 @@
|
||||
if(extrange) {
|
||||
if(retval<100 || (retval>199 && retval<2000) || retval>2699) {
|
||||
fprintf(f,"\
|
||||
-!=============================================================================
|
||||
-! WARNING ! %s is out of extended access-list ranges (100-199 and 2000-2699)
|
||||
-!=============================================================================
|
||||
+!=============================================================================\n\
|
||||
+! WARNING ! %s is out of extended access-list ranges (100-199 and 2000-2699)\n\
|
||||
+!=============================================================================\n\
|
||||
",string);
|
||||
exit(1);
|
||||
};
|
||||
} else {
|
||||
if((retval>100 && retval<1300) || retval>1999) {
|
||||
fprintf(f,"\
|
||||
-!=============================================================================
|
||||
-! WARNING ! %s is out of standard access-list ranges (1-99 and 1300-1999)
|
||||
-!=============================================================================
|
||||
+!=============================================================================\n\
|
||||
+! WARNING ! %s is out of standard access-list ranges (1-99 and 1300-1999)\n\
|
||||
+!=============================================================================\n\
|
||||
",string);
|
||||
|
||||
exit(1);
|
Loading…
Reference in a new issue