multimedia/openh264: unbreak build on armv6

Disable NEON support for armv6 (softfp). Alas, MACHINE_CPU is
underspecified on arm* to conditionalize NEON check within a port.

PR:		201273
Reported by:	pkg-fallout
Submitted by:	mikael.urankar@gmail.com
MFH:		2015Q3
This commit is contained in:
Jan Beich 2015-08-16 22:16:18 +00:00
parent 800d5a69eb
commit 6ac83e0894
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=394430

View file

@ -0,0 +1,11 @@
--- build/arch.mk.orig 2015-08-09 21:14:55 UTC
+++ build/arch.mk
@@ -1,7 +1,7 @@
ifneq ($(filter %86 x86_64, $(ARCH)),)
include $(SRC_PATH)build/x86-common.mk
endif
-ifneq ($(filter-out arm64, $(filter arm%, $(ARCH))),)
+ifneq ($(filter-out armv6 arm64, $(filter arm%, $(ARCH))),)
ifeq ($(USE_ASM), Yes)
ASM_ARCH = arm
ASMFLAGS += -I$(SRC_PATH)codec/common/arm/