- Fix Build

- Makefile cleanup

PR:		113627
Submitted by:	pointyhat via kris/pav
Thanks to:	Fredrik Lindberg, linimon
Reviewed by:	sat
This commit is contained in:
Martin Wilke 2007-07-14 21:33:04 +00:00
parent d82231dcb7
commit 6b0c72f87f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=195608
7 changed files with 127 additions and 12 deletions

View file

@ -7,17 +7,21 @@
PORTNAME= libamrnb
PORTVERSION= 6.1.0.4
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= http://ftp.penguin.cz/pub/users/utx/amr/
MASTER_SITES= http://ftp.penguin.cz/pub/users/utx/amr/ \
http://www.3gpp.org/ftp/Specs/archive/26_series/26.104/:3GPP
DISTNAME= amrnb-${DISTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${SRC3GPP}:3GPP
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= tatsuki_makino@hotmail.com
COMMENT= Adaptive Multi-Rate (AMR) Speech Codec
COMMENT= 3GPP floating-point Adaptive Multi-Rate (AMR) Speech Codec
BUILD_DEPENDS= wget:${PORTSDIR}/ftp/wget \
${UNZIP_CMD}:${PORTSDIR}/archivers/unzip \
bash:${PORTSDIR}/shells/bash
BUILD_DEPENDS= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
SRC3GPP= 26104-610.zip
USE_BZIP2= yes
USE_GMAKE= yes
@ -25,11 +29,26 @@ USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LANG=C
USE_LDCONFIG= yes
RESTRICTED= See Important legal notice of http://www.penguin.cz/~utx/amr.en.html
RESTRICTED= license prohibits redistribution
RESTRICTED_FILES= ${SRC3GPP}
PORTDOCS= AUTHORS COPYING ChangeLog NEWS README TODO readme.txt
SUB_FILES= pkg-message
MAKE_ENV= LANG=C
post-patch:
@${REINPLACE_CMD} -E \
-e "s!(/bin/bash)!${LOCALBASE}\\1!" \
${WRKSRC}/prepare_sources.sh
post-extract:
@${CP} ${DISTDIR}/${SRC3GPP} ${WRKSRC}
post-install:
.ifndef(NOPORTDOCS)
@${ECHO} -n Install documents:
@${MKDIR} ${DOCSDIR}
. for FILE in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
@${ECHO} -n " ${FILE}"
. endfor
@${ECHO} .
@${ECHO}
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View file

@ -1,3 +1,6 @@
MD5 (amrnb-6.1.0.4.tar.bz2) = f482cdd0584469ba23ff33c6b331acbd
SHA256 (amrnb-6.1.0.4.tar.bz2) = 6f2df7089205cd6127d434e8ec8fac4cccc163d4df5ec4437211c884fbd9fe75
SIZE (amrnb-6.1.0.4.tar.bz2) = 224932
MD5 (26104-610.zip) = cfd9012bff83afdf5ad069b86d3063b6
SHA256 (26104-610.zip) = 8dc9453f9b93202247b4800a1d946ae6eaa3b9d0c48237ae8848144feb88399e
SIZE (26104-610.zip) = 292640

View file

@ -0,0 +1,24 @@
--- Makefile.in.orig Sat May 26 04:34:54 2007
+++ Makefile.in Sun Jul 15 00:48:06 2007
@@ -250,7 +250,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
EXTRA_DIST = amrnb-any-cflags.patch amrnb-intsizes.patch amrnb-strict-aliasing.patch prepare_sources.sh amrnb.spec
-DISTCLEANFILES = 26104-610.zip 26104-610.doc 26104-610_ANSI_C_source_code.zip
+DISTCLEANFILES = 26104-610.doc 26104-610_ANSI_C_source_code.zip
lib_LTLIBRARIES = \
libamrnb.la
@@ -922,10 +922,10 @@
chmod og-w 26104-610.doc
26104-610.zip:
- $(WGET) -N http://www.3gpp.org/ftp/Specs/archive/26_series/26.104/26104-610.zip
+ test -e 26104-610.zip
extraclean:
- rm -f $(distdir)/*.c $(distdir)/*.h $(distdir)/readme.txt $(distdir)/26104-610.zip $(distdir)/26104-610.doc $(distdir)/26104-610_ANSI_C_source_code.zip
+ rm -f $(distdir)/*.c $(distdir)/*.h $(distdir)/readme.txt $(distdir)/26104-610.doc $(distdir)/26104-610_ANSI_C_source_code.zip
# WARNING: These commands use internal automake command and may fail in future version.
extradist-gzip: distdir extraclean

View file

@ -0,0 +1,15 @@
--- configure.orig Fri Jun 22 12:43:20 2007
+++ configure Fri Jun 22 12:43:24 2007
@@ -20338,12 +20338,6 @@
fi
-if test x"$WGET" = x -a ! "(" -f "26104-610.zip" -o -f "sp_enc.c" ")" ; then
- { { echo "$as_me:$LINENO: error: You need wget utility to download sources." >&5
-echo "$as_me: error: You need wget utility to download sources." >&2;}
- { (exit 1); exit 1; }; }
-fi
-
# Checks for libraries.
{ echo "$as_me:$LINENO: checking for library containing sqrt" >&5
echo $ECHO_N "checking for library containing sqrt... $ECHO_C" >&6; }

View file

@ -0,0 +1,31 @@
--- prepare_sources.sh.orig Wed Jun 6 23:52:12 2007
+++ prepare_sources.sh Sat Jul 14 23:35:53 2007
@@ -1,10 +1,10 @@
-#! /bin/bash
+#! /bin/sh
set -o errexit
-trap "rm -rf c-code *.c *.h readme.txt *.new *.def *.all" ERR
+trap "rm -rf c-code *.c *.h readme.txt *.new *.def *.all" 0
if [ "$0" = prepare_sources.sh ] ; then
- cd "$(if ! which 2>/dev/null prepare_sources.sh ; then echo . fi )"
+ cd "$(if ! which 2>/dev/null prepare_sources.sh ; then echo . ; fi )"
else
cd "${0%/*}"
fi
@@ -23,7 +23,7 @@
patch <amrnb-strict-aliasing.patch
patch <amrnb-any-cflags.patch
-for FILE in interf_{dec,enc}.{c,h} ; do
+for FILE in interf_dec.[ch] interf_enc.[ch] ; do
echo "modifying file $FILE"
if test $FILE = ${FILE%.h} ; then
ENDSTRING="^}"
@@ -100,3 +100,5 @@
rm $FILE.def $FILE.all
done
done
+
+trap 0

View file

@ -0,0 +1,17 @@
AMR codecs incorporate several patents, held by Ericsson,
Universite de Sherbrooke (VoiceAge) and Nokia.
VoiceAge claims to provide patent portfolio for AMR codecs. Depending on law in
your country, manufacturers and developers may need to get a license.
Because it is a shared library, you may need a special contract for each one
application, which links against this library, directly or indirectly.
* 3GPP policy on licensing and 3G Patent Platform:
http://www.3gpp.org/faq/faq_2005_2.htm#A3.1
* Intellectual property in ETSI standards:
http://webapp.etsi.org/IPR/home.asp
* On 3GPP legal issues:
http://www.3gpp.org/legal/legal.htm
* On VoiceAge licensing:
http://www.voiceage.com/licensing.php

View file

@ -1,6 +1,12 @@
Adaptive Multi-Rate Narrow-Band decoder and encoder library.
3GPP floating-point Adaptive Multi-Rate (AMR) Speech Codec
(3GPP TS 26.104 V 6.1.0)
http://www.3gpp.org/ftp/Specs/html-info/26104.htm
AMR is an audio data compression scheme optimized for speech coding.
AMR was adopted as the standard speech codec by 3GPP in October 1998
and is now widely used in GSM.
Note that depending on law in your country, you may need a license for
distribution, any use, commercial use or even development.
WWW: http://www.penguin.cz/~utx/amr