security/putty: update to 0.75
https://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html Deprecate -gtk2 version for Mid-December 2021. Clean up a bit.
This commit is contained in:
parent
7e5aebbd1d
commit
6b288be1e6
4 changed files with 31 additions and 57 deletions
|
@ -2,6 +2,9 @@
|
|||
|
||||
PKGNAMESUFFIX= -gtk2
|
||||
|
||||
DEPRECATED= putty-gtk2 is being phased out
|
||||
EXPIRATION_DATE= 2021-12-15
|
||||
|
||||
OPTIONS_SLAVE= GTK2
|
||||
OPTIONS_EXCLUDE= GTK3
|
||||
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
PORTNAME= putty
|
||||
PORTVERSION= 0.74
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.75
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://the.earth.li/~sgtatham/putty/${PORTVERSION}/ \
|
||||
ftp://ftp.chiark.greenend.org.uk/users/sgtatham/putty-latest/
|
||||
|
@ -16,6 +15,7 @@ USES= cpe gmake pkgconfig
|
|||
CPE_VENDOR= simon_tatham
|
||||
|
||||
MAKEFILE= Makefile.gtk
|
||||
MAKE_ARGS+= "prefix=${PREFIX}"
|
||||
|
||||
CONFLICTS_INSTALL?= pssh-[0-9]* putty-gtk2-[0-9]* putty-nogtk-[0-9]*
|
||||
|
||||
|
@ -35,29 +35,28 @@ OPTIONS_DEFAULT= GSSAPI_BASE GTK3
|
|||
OPTIONS_RADIO= TOOLKIT
|
||||
OPTIONS_RADIO_TOOLKIT= GTK2 GTK3
|
||||
OPTIONS_SINGLE= GSSAPI_SELECT
|
||||
OPTIONS_SINGLE_GSSAPI_SELECT= GSSAPI_NONE GSSAPI_BASE GSSAPI_HEIMDAL \
|
||||
GSSAPI_MIT
|
||||
OPTIONS_SINGLE_GSSAPI_SELECT= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT \
|
||||
GSSAPI_NONE
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
CFLAGS+= -DBSD_PTYS -DHAVE_FUTIMES -DIPV6 -DOMIT_UTMP
|
||||
LDFLAGS+= -Wl,--as-needed
|
||||
LDFLAGS+= -lm -Wl,--as-needed
|
||||
|
||||
.if (${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MGTK3}) && !defined(WITHOUT_X11)
|
||||
USES+= xorg
|
||||
USE_XORG= x11
|
||||
.if ${PORT_OPTIONS:MGTK2}
|
||||
USES+= gnome
|
||||
USE_GNOME= cairo gdkpixbuf2 gtk20
|
||||
MAKE_ARGS+= GTK_CONFIG="pkg-config gtk+-2.0 x11 --cflags" \
|
||||
PUTTY_WITH_GTK=yes
|
||||
.endif
|
||||
.if ${PORT_OPTIONS:MGTK3}
|
||||
. if ${PORT_OPTIONS:MGTK3}
|
||||
USES+= gnome
|
||||
USE_GNOME= cairo gdkpixbuf2 gtk30
|
||||
MAKE_ARGS+= GTK_CONFIG="pkg-config gtk+-3.0 x11 --cflags" \
|
||||
PUTTY_WITH_GTK=yes
|
||||
.endif
|
||||
. elif ${PORT_OPTIONS:MGTK2}
|
||||
USES+= gnome
|
||||
USE_GNOME= cairo gdkpixbuf2 gtk20
|
||||
MAKE_ARGS+= GTK_CONFIG="pkg-config gtk+-2.0 x11 --cflags" \
|
||||
PUTTY_WITH_GTK=yes
|
||||
. endif
|
||||
|
||||
PLIST_FILES+= bin/pageant \
|
||||
bin/pterm \
|
||||
|
@ -99,21 +98,12 @@ XFLAGS= -DDEBUG
|
|||
_COMPAT+= -DDEBUG
|
||||
.endif
|
||||
|
||||
# upstream sets -Werror - there are no issues on 9.1-FreeBSD amd64
|
||||
# currently, but override it nonetheless.
|
||||
XFLAGS+= -Wno-error
|
||||
|
||||
MAKE_ARGS+= CC="${CC}" \
|
||||
COMPAT="${_COMPAT}" \
|
||||
INSTALL_DATA="${INSTALL_DATA}" \
|
||||
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
|
||||
XFLAGS="${XFLAGS}"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,prefix=/usr/local,prefix=${PREFIX},;\
|
||||
s,make,${MAKE_CMD},'\
|
||||
${WRKSRC}/${MAKEFILE}
|
||||
|
||||
post-install:
|
||||
.if ${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MGTK3}
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/share/pixmaps
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1593350227
|
||||
SHA256 (putty-0.74.tar.gz) = ddd5d388e51dd9e6e294005b30037f6ae802239a44c9dc9808c779e6d11b847d
|
||||
SIZE (putty-0.74.tar.gz) = 2476513
|
||||
TIMESTAMP = 1620467878
|
||||
SHA256 (putty-0.75.tar.gz) = d3173b037eddbe9349abe978101277b4ba9f9959e25dedd44f87e7b85cc8f9f5
|
||||
SIZE (putty-0.75.tar.gz) = 2731167
|
||||
|
|
|
@ -1,49 +1,30 @@
|
|||
--- unix/Makefile.gtk.orig 2019-03-16 12:26:40 UTC
|
||||
--- unix/Makefile.gtk.orig 2021-05-02 07:21:01 UTC
|
||||
+++ unix/Makefile.gtk
|
||||
@@ -109,7 +109,7 @@ GTK_CONFIG = sh -c 'pkg-config gtk+-3.0 x11 $$0 2>/dev
|
||||
@@ -104,7 +104,7 @@ GTK_CONFIG = sh -c 'pkg-config gtk+-3.0 x11 $$0 2>/dev
|
||||
|
||||
unexport CFLAGS # work around a weird issue with krb5-config
|
||||
|
||||
-CFLAGS = -O2 -Wall -Werror -std=gnu99 -Wvla -g -I.././ -I../charset/ \
|
||||
+CFLAGS := $(CFLAGS) -Wall -Werror -std=gnu99 -Wvla -I.././ -I../charset/ \
|
||||
-I../windows/ -I../unix/ $(shell $(GTK_CONFIG) --cflags) -D _FILE_OFFSET_BITS=64
|
||||
-CFLAGS = -O2 -Wall -std=gnu99 -Wvla -g -I.././ -I../charset/ -I../windows/ \
|
||||
+CFLAGS := $(CFLAGS) -Wall -std=gnu11 -Wvla -I.././ -I../charset/ -I../windows/ \
|
||||
-I../unix/ $(shell $(GTK_CONFIG) --cflags) -D _FILE_OFFSET_BITS=64
|
||||
XLDFLAGS = $(LDFLAGS) $(shell $(GTK_CONFIG) --libs)
|
||||
ULDFLAGS = $(LDFLAGS)
|
||||
@@ -136,8 +136,13 @@ man1dir=$(mandir)/man1
|
||||
@@ -131,9 +131,14 @@ man1dir=$(mandir)/man1
|
||||
.SUFFIXES:
|
||||
|
||||
|
||||
+ifdef PUTTY_WITH_GTK
|
||||
all: cgtest fuzzterm osxlaunch pageant plink pscp psftp pterm ptermapp putty \
|
||||
puttyapp puttygen puttytel testcrypt testsc testzlib uppity
|
||||
all: cgtest fuzzterm osxlaunch pageant plink pscp psftp psocks psusan pterm \
|
||||
ptermapp putty puttyapp puttygen puttytel testcrypt testsc \
|
||||
testzlib uppity
|
||||
+else
|
||||
+all: cgtest fuzzterm osxlaunch plink pscp psftp \
|
||||
+ puttygen testcrypt testsc testzlib uppity
|
||||
+endif
|
||||
|
||||
cgtest: cgtest.o conf.o ecc.o import.o marshal.o memory.o misc.o mpint.o \
|
||||
notiming.o sshaes.o sshauxcrypt.o sshbcrypt.o sshblowf.o \
|
||||
@@ -497,15 +502,15 @@ testsc: ecc.o marshal.o memory.o mpint.o sshaes.o ssha
|
||||
sshblowf.o sshccp.o sshcrc.o sshcrcda.o sshdes.o sshdh.o \
|
||||
sshdss.o sshecc.o sshhmac.o sshmac.o sshmd5.o sshrsa.o \
|
||||
sshsh256.o sshsh512.o sshsha.o testsc.o tree234.o utils.o \
|
||||
- uxutils.o wildcard.o
|
||||
+ uxutils.o wildcard.o uxmisc.o
|
||||
$(CC) -o $@ ecc.o marshal.o memory.o mpint.o sshaes.o ssharcf.o \
|
||||
sshauxcrypt.o sshblowf.o sshccp.o sshcrc.o sshcrcda.o \
|
||||
sshdes.o sshdh.o sshdss.o sshecc.o sshhmac.o sshmac.o \
|
||||
sshmd5.o sshrsa.o sshsh256.o sshsh512.o sshsha.o testsc.o \
|
||||
- tree234.o utils.o uxutils.o wildcard.o $(ULDFLAGS)
|
||||
+ tree234.o utils.o uxutils.o wildcard.o uxmisc.o $(ULDFLAGS)
|
||||
|
||||
-testzlib: marshal.o memory.o sshzlib.o testzlib.o utils.o
|
||||
- $(CC) -o $@ marshal.o memory.o sshzlib.o testzlib.o utils.o \
|
||||
+testzlib: marshal.o memory.o sshzlib.o testzlib.o utils.o uxmisc.o
|
||||
+ $(CC) -o $@ marshal.o memory.o sshzlib.o testzlib.o utils.o uxmisc.o \
|
||||
$(ULDFLAGS)
|
||||
|
||||
uppity: be_misc.o be_none.o callback.o conf.o cproxy.o ecc.o errsock.o \
|
||||
@@ -1602,10 +1607,12 @@ xpmputty.o: ../unix/xpmputty.c
|
||||
cgtest: cgtest.o conf.o console.o ecc.o import.o marshal.o memory.o \
|
||||
millerrabin.o misc.o mpint.o mpunsafe.o notiming.o pockle.o \
|
||||
@@ -1805,10 +1810,12 @@ xpmputty.o: ../unix/xpmputty.c
|
||||
|
||||
install:
|
||||
mkdir -p $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
|
||||
|
@ -57,7 +38,7 @@
|
|||
$(INSTALL_PROGRAM) -m 755 pterm $(DESTDIR)$(bindir)/pterm
|
||||
if test -n "$(UTMP_GROUP)"; then \
|
||||
chgrp $(UTMP_GROUP) $(DESTDIR)$(bindir)/pterm && \
|
||||
@@ -1615,16 +1622,18 @@ install:
|
||||
@@ -1818,16 +1825,18 @@ install:
|
||||
chmod 4755 $(DESTDIR)$(bindir)/pterm; \
|
||||
fi
|
||||
$(INSTALL_PROGRAM) -m 755 putty $(DESTDIR)$(bindir)/putty
|
||||
|
|
Loading…
Reference in a new issue