SquirrelOutlook is a standards-based webmail package written in PHP4. It

includes built-in pure PHP support for the IMAP and SMTP protocols, and
all pages render in pure HTML 4.0 (with no Javascript) for maximum
compatibility across browsers. It has very few requirements and is very
easy to configure and install. SquirrelOutlook has a all the functionality
you would want from an email client, including strong MIME support,
address books, and folder manipulation

WWW: http://sourceforge.net/projects/squirreloutlook/

- Dennis Cabooter
freebsd@rootxs.org

PR:		ports/107303
Submitted by:	Simon Dick <simond at irrelevant.org>
This commit is contained in:
Martin Wilke 2007-01-08 23:03:14 +00:00
parent f0a889f6c8
commit 6b5a7815a1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=181815
10 changed files with 3631 additions and 0 deletions

View file

@ -570,6 +570,7 @@
SUBDIR += squirrelmail-vlogin-plugin
SUBDIR += squirrelmail-websearch-plugin
SUBDIR += squirrelmail-wetteronline-plugin
SUBDIR += squirreloutlook
SUBDIR += sqwebmail
SUBDIR += ssmtp
SUBDIR += surblhost

View file

@ -0,0 +1,103 @@
# New ports collection makefile for: squirrelmailoutlook
# Date created: 28 December 2006
# Whom: Simon Dick <simond@irrelevant.org>
#
# $FreeBSD$
#
PORTNAME= squirreloutlook
PORTVERSION= 1.0.3
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME} \
squirrelmail
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
all_locales-1.5.1-20060409${EXTRACT_SUFX}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= freebsd@rootxs.org
COMMENT= A webmail system which accesses mail over IMAP
USE_PHP= session mhash gettext mbstring pcre openssl xml
WANT_PHP_WEB= yes
USE_GETTEXT= yes
.ifdef WITH_DATABASE
RUN_DEPENDS+= ${PREFIX}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
.endif
.ifdef WITH_LDAP
USE_PHP+= ldap
.endif
SQUIRRELDIR= ${PREFIX}/www/${PORTNAME}
PLIST_SUB= PORTVERSION=${PORTVERSION} \
SQUIRRELDIR="${SQUIRRELDIR:S,^${PREFIX}/,,}"
SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= SQUIRRELDIR=${SQUIRRELDIR}
PORTDOCS= *
pre-everything::
@${ECHO_CMD} "Use WITH_LDAP to ensure PHP LDAP support is installed"
@${ECHO_CMD} "Use WITH_DATABASE to ensure PEAR framework for database support is installed"
@${ECHO_CMD} " (note that this does not install the database specific PEAR support, e.g. MySQL)"
@${ECHO_CMD}
post-patch:
.ifndef PATCH_DEBUG
@${RM} -f ${WRKSRC}/config/config_default.php.orig ${WRKSRC}/functions/global.php.orig
.endif
@${REINPLACE_CMD} -e 's|ispell|${LOCALBASE}/bin/ispell|g' \
${WRKSRC}/plugins/squirrelspell/sqspell_config.php
@${RM} ${WRKSRC}/plugins/squirrelspell/sqspell_config.php.bak
# Rearrange the documentation
do-build:
.for file in AUTHORS ChangeLog COPYING INSTALL README UPGRADE
@${MV} ${WRKSRC}/${file} ${WRKSRC}/doc/
.endfor
@${MV} ${WRKSRC}/ReleaseNotes ${WRKSRC}/doc/ReleaseNotes-${PORTVERSION}.txt
@${MV} ${WRKSRC}/themes/README.themes ${WRKSRC}/doc/
@cd ${WRKSRC} ; for f in `find plugins -name "README*" -or \
-name INSTALL -or -name CHANGES -or -name HISTORY`; \
do \
${MKDIR} doc/`dirname $$f` ; \
${MV} $$f doc/`dirname $$f` ; \
done; \
${MV} doc/plugins/squirrelspell/doc/README doc/plugins/squirrelspell ; \
${RM} -rf doc/plugins/squirrelspell/doc ; \
${MV} plugins/squirrelspell/doc/* doc/plugins/squirrelspell ; \
${RM} -f doc/plugins/squirrelspell/index.php ; \
${RM} -rf plugins/squirrelspell/doc
@${ECHO} "left_refresh=300" >> ${WRKSRC}/data/default_pref
@${CP} -r ${WRKSRC}/../locale ${WRKSRC}
@${CP} -r ${WRKSRC}/../images ${WRKSRC}
@${CP} -r ${WRKSRC}/../help ${WRKSRC}
pre-install:
@${ECHO} "Your umask should be lax while installing this. Like, 022 or something."
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
${MKDIR} ${PREFIX}/etc/periodic/daily
${INSTALL_SCRIPT} ${FILESDIR}/111.clean-squirrelmail ${PREFIX}/etc/periodic/daily
${MKDIR} ${SQUIRRELDIR}
@${CP} -pv ${WRKSRC}/index.php ${SQUIRRELDIR}
@${CP} -pv ${WRKSRC}/configure ${SQUIRRELDIR}
.for DIR in class config data functions help images include locale plugins po src themes
@${CP} -rpv ${WRKSRC}/${DIR} ${SQUIRRELDIR}
.endfor
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/data
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@${CP} -Rv ${WRKSRC}/doc/* ${DOCSDIR}
.endif
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View file

@ -0,0 +1,6 @@
MD5 (squirreloutlook/squirreloutlook-1.0.3.tar.gz) = e0b56f1e79a5609da1da6696784f17f0
SHA256 (squirreloutlook/squirreloutlook-1.0.3.tar.gz) = f584797b2f0f72fd692d675c4c5301f60ee9a0f9f2d7e3a1ea6a55d999abaf3a
SIZE (squirreloutlook/squirreloutlook-1.0.3.tar.gz) = 2007632
MD5 (squirreloutlook/all_locales-1.5.1-20060409.tar.gz) = 32946a396a96c3e2c6619d07f66c2743
SHA256 (squirreloutlook/all_locales-1.5.1-20060409.tar.gz) = c9df273a8777a14b0758d2be7fe532627496d830fb866c164a6e68cc0ef2879d
SIZE (squirreloutlook/all_locales-1.5.1-20060409.tar.gz) = 4046326

View file

@ -0,0 +1,69 @@
#!/bin/sh
#
# $FreeBSD: /tmp/pcvs/ports/mail/squirreloutlook/files/Attic/111.clean-squirrelmail,v 1.1 2007-01-08 23:03:14 miwi Exp $
#
# This script copied from /etc/periodic/daily/110.clean-tmps,v 1.6.2.4 2002/10/13 19:59:01
#
# Perform attachment directory cleaning so that long-lived systems
# don't end up with excessively old files there.
#
# Define these variables in either /etc/periodic.conf or
# /etc/periodic.conf.local to override the default values.
#
# 111.clean-squirrelmail
clean_squirrelmail_enable="NO" # Delete squirrelmail attachments
clean_squirrelmail_dirs="/var/spool/squirrelmail/attach" # Delete under here
clean_squirrelmail_days="10" # If not accessed for
clean_squirrelmail_ignore="quota.user quota.group" # Don't delete these
clean_squirrelmail_verbose="YES" # Mention files deleted
# If there is a global system configuration file, suck it in.
#
if [ -r /etc/defaults/periodic.conf ]
then
. /etc/defaults/periodic.conf
source_periodic_confs
fi
case "$clean_squirrelmail_enable" in
[Yy][Ee][Ss])
if [ -z "$clean_squirrelmail_days" ]
then
echo '$clean_squirrelmail_enable is set but' \
'$clean_squirrelmail_days is not'
rc=2
else
echo ""
echo "Removing old SquirrelOutlook Attachment files:"
set -f noglob
args="-atime +$clean_squirrelmail_days -mtime +$clean_squirrelmail_days"
args="${args} -ctime +$clean_squirrelmail_days"
[ -n "$clean_squirrelmail_ignore" ] &&
args="$args "`echo " ${clean_squirrelmail_ignore% }" |
sed 's/[ ][ ]*/ ! -name /g'`
case "$clean_squirrelmail_verbose" in
[Yy][Ee][Ss])
print=-print;;
*)
print=;;
esac
rc=$(for dir in $clean_squirrelmail_dirs
do
[ ."${dir#/}" != ."$dir" -a -d $dir ] && cd $dir && {
find -d . -type f $args -delete $print
find -d . ! -name . -type d -empty -mtime \
+$clean_squirrelmail_days -delete $print
} | sed "s,^\\., $dir,"
done | tee /dev/stderr | wc -l)
[ -z "$print" ] && rc=0
[ $rc -gt 1 ] && rc=1
set -f glob
fi;;
*) rc=0;;
esac
exit $rc

View file

@ -0,0 +1,20 @@
--- config/config_default.php.orig Wed Jun 2 10:49:41 2004
+++ config/config_default.php Wed Jun 2 10:50:21 2004
@@ -442,7 +442,7 @@
* $data_dir = SM_PATH . 'data/';
* @global string $data_dir
*/
-$data_dir = SM_PATH . 'data/';
+$data_dir = '/var/spool/squirrelmail/pref/';
/**
* Attachments directory
@@ -460,7 +460,7 @@
* + It should probably be another directory than data_dir.
* @global string $attachment_dir
*/
-$attachment_dir = $data_dir;
+$attachment_dir = '/var/spool/squirrelmail/attach/';
/**
* Hash level used for data directory.

View file

@ -0,0 +1,43 @@
#!/bin/sh
#
# $FreeBSD: /tmp/pcvs/ports/mail/squirreloutlook/files/Attic/pkg-deinstall.in,v 1.1 2007-01-08 23:03:14 miwi Exp $
#
#set -vx
PKG_BATCH=${BATCH:=NO}
PKG_PREFIX=${PKG_PREFIX:=/usr/local}
SQUIRRELDIR=%%SQUIRRELDIR%%
checkfile() {
diff -bBqw $1 $2 >/dev/null 2>&1
case $? in
0) # config file exists, but is the same
rm $1
;;
1) # config file exists and differs
;;
*) # no config file exists
;;
esac
}
case $2 in
DEINSTALL)
cd ${PKG_PREFIX}
checkfile /var/spool/squirrelmail/prefs/default_pref \
${SQUIRRELDIR}/data/default_pref
;;
POST-DEINSTALL)
if [ "${PKG_BATCH}" = "NO" ]; then
echo "If you are no longer going to use SquirrelOutlook"
echo "you should remove the /var/spool/squirrelmail"
echo "directory with:"
echo
echo " rm -rf /var/spool/squirrelmail"
fi
;;
esac

View file

@ -0,0 +1,57 @@
#!/bin/sh
#
# $FreeBSD: /tmp/pcvs/ports/mail/squirreloutlook/files/Attic/pkg-install.in,v 1.1 2007-01-08 23:03:14 miwi Exp $
#
PKG_BATCH=${BATCH:=NO}
PKG_PREFIX=${PKG_PREFIX:=/usr/local}
SQUIRRELDIR=%%SQUIRRELDIR%%
case $2 in
PRE-INSTALL)
USER=www
GROUP=${USER}
UID=80
GID=${UID}
if ! pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
if pw groupadd ${GROUP} -g ${GID}; then
echo "Added group \"${GROUP}\"."
else
echo "Adding group \"${GROUP}\" failed..."
exit 1
fi
fi
if ! pw usershow "${USER}" 2>/dev/null 1>&2; then
if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
-s "/sbin/nologin" -d "/nonexistent" \
-c "World Wide Web Owner"; \
then
echo "Added user \"${USER}\"."
else
echo "Adding user \"${USER}\" failed..."
exit 1
fi
fi
exit 0
;;
POST-INSTALL)
if [ "${PKG_BATCH}" = "NO" ]; then
install -d -o www -g www -m 0755 /var/spool/squirrelmail
install -d -o www -g www -m 0730 /var/spool/squirrelmail/attach
install -d -o www -g www -m 0750 /var/spool/squirrelmail/pref
if [ ! -f /var/spool/squirrelmail/pref/default_pref ]; then
cp -rp ${SQUIRRELDIR}/data/default_pref \
/var/spool/squirrelmail/pref/default_pref
else
echo ""
echo "An older version of default_pref exists in"
echo "/var/spool/squirrelmail/pref, you may want to"
echo "compare it with the one in ${SQUIRRELDIR}/data"
fi
fi
;;
esac

View file

@ -0,0 +1,18 @@
You now need to add an alias to apache's httpd.conf pointing to
%%SQUIRRELDIR%% in order to access SquirrelOutlook from
your web browser, or create a VirtualHost with DocumentRoot set
to that directory.
For SquirrelOutlook to work properly you will need to make sure the
following option is set in your php.ini file:
file_uploads = On
If you have problems with SquirrelOutlook saying "you must login" after
you just have, the following php.ini option may help:
session.auto_start = 1
In order to do your administrative configuration you need to
cd %%SQUIRRELDIR%% && ./configure
SquirrelOutlook will not work until this has been done.

View file

@ -0,0 +1,12 @@
SquirrelOutlook is a standards-based webmail package written in PHP4. It
includes built-in pure PHP support for the IMAP and SMTP protocols, and
all pages render in pure HTML 4.0 (with no Javascript) for maximum
compatibility across browsers. It has very few requirements and is very
easy to configure and install. SquirrelOutlook has a all the functionality
you would want from an email client, including strong MIME support,
address books, and folder manipulation
WWW: http://sourceforge.net/projects/squirreloutlook/
- Dennis Cabooter
freebsd@rootxs.org

File diff suppressed because it is too large Load diff