textproc/py-normality: Update to 2.4.0
* Switch back to PyPI as the sdist now contains the test suite. * Remove no longer required patch. * Switch to PEP517 build framework. Changelog since 2.3.3: https://github.com/pudo/normality/compare/2.3.3...2.4.0 MFH: No (PEP517 support not present in 2023Q1)
This commit is contained in:
parent
5ee10020c8
commit
6b90f1354b
3 changed files with 10 additions and 24 deletions
|
@ -1,6 +1,7 @@
|
|||
PORTNAME= normality
|
||||
DISTVERSION= 2.3.3
|
||||
DISTVERSION= 2.4.0
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= kai@FreeBSD.org
|
||||
|
@ -10,15 +11,16 @@ WWW= https://github.com/pudo/normality
|
|||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61.2.0:devel/py-setuptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.3:devel/py-setuptools_scm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}banal>=1.0.1:devel/py-banal@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}text-unidecode>=0:converters/py-text-unidecode@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}charset-normalizer>0:textproc/py-charset-normalizer@${PY_FLAVOR}
|
||||
${PYTHON_PKGNAMEPREFIX}charset-normalizer>=2.0.0:textproc/py-charset-normalizer@${PY_FLAVOR}
|
||||
|
||||
USES= python:3.5+ pytest
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= pudo
|
||||
USE_PYTHON= distutils autoplist
|
||||
USE_PYTHON= autoplist pep517
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1650975096
|
||||
SHA256 (pudo-normality-2.3.3_GH0.tar.gz) = 8dc5ad1be2cc1edeabc5960419e61d07f35ffe4d51f8027181dd4f0c04bc962a
|
||||
SIZE (pudo-normality-2.3.3_GH0.tar.gz) = 9788
|
||||
TIMESTAMP = 1679237980
|
||||
SHA256 (normality-2.4.0.tar.gz) = 38bbe4e1dfd737c318ffd70e981ae8ff40bd8839393f6d62f0e200e5aab9e992
|
||||
SIZE (normality-2.4.0.tar.gz) = 11809
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
Really exclude "tests" directory to be installed into
|
||||
${PYTHONPREFIX_SITELIBDIR}
|
||||
|
||||
https://github.com/pudo/normality/pull/18
|
||||
|
||||
--- setup.py.orig 2022-04-11 10:30:15 UTC
|
||||
+++ setup.py
|
||||
@@ -24,7 +24,7 @@ setup(
|
||||
url="http://github.com/pudo/normality",
|
||||
license="MIT",
|
||||
package_data={"banal": ["py.typed"]},
|
||||
- packages=find_packages(exclude=["ez_setup", "examples", "test"]),
|
||||
+ packages=find_packages(exclude=["ez_setup", "examples", "tests"]),
|
||||
namespace_packages=[],
|
||||
include_package_data=True,
|
||||
zip_safe=False,
|
Loading…
Reference in a new issue