Workaround gcc 2.95.x static_cast<> bug on -STABLE
PR: 56030 Submitted by: Sergey Akifyev <asa@gascom.ru> (based on) Approved by: marcus (mentor)
This commit is contained in:
parent
39b6e964c0
commit
6babeb84a5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=87817
4 changed files with 72 additions and 2 deletions
|
@ -29,4 +29,10 @@ USE_LIBTOOL= yes
|
|||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ARGS= --enable-static
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-old_gcc_bugs
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
29
x11-toolkits/libgnomeuimm/files/extra-patch-old_gcc_bugs
Normal file
29
x11-toolkits/libgnomeuimm/files/extra-patch-old_gcc_bugs
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- libgnomeui/libgnomeuimm/dateedit.cc.orig Wed Aug 27 22:24:13 2003
|
||||
+++ libgnomeui/libgnomeuimm/dateedit.cc Wed Aug 27 22:25:02 2003
|
||||
@@ -35,7 +35,7 @@
|
||||
: Gtk::HBox(GTK_HBOX(g_object_new(get_type(), (char*)0)))
|
||||
{
|
||||
gnome_date_edit_construct(gobj(), the_time,
|
||||
- static_cast<GnomeDateEditFlags>(
|
||||
+ GnomeDateEditFlags(
|
||||
(show_time ? DATE_EDIT_SHOW_TIME : static_cast<DateEditFlags>(0))
|
||||
| (use_24_format ? DATE_EDIT_24_HR : static_cast<DateEditFlags>(0)) ) );
|
||||
}
|
||||
@@ -44,7 +44,7 @@
|
||||
DateEdit::DateEdit(time_t the_time, DateEditFlags flags)
|
||||
: Gtk::HBox(GTK_HBOX(g_object_new(get_type(), (char*)0)))
|
||||
{
|
||||
- gnome_date_edit_construct(gobj(), the_time, static_cast<GnomeDateEditFlags>(flags));
|
||||
+ gnome_date_edit_construct(gobj(), the_time, GnomeDateEditFlags(flags));
|
||||
}
|
||||
|
||||
|
||||
@@ -254,7 +254,7 @@
|
||||
|
||||
void DateEdit::set_flags(DateEditFlags flags)
|
||||
{
|
||||
- gnome_date_edit_set_flags(gobj(), static_cast<GnomeDateEditFlags>(flags));
|
||||
+ gnome_date_edit_set_flags(gobj(), GnomeDateEditFlags(flags));
|
||||
}
|
||||
|
||||
DateEditFlags DateEdit::get_flags() const
|
|
@ -29,4 +29,10 @@ USE_LIBTOOL= yes
|
|||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ARGS= --enable-static
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-old_gcc_bugs
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
29
x11-toolkits/libgnomeuimm26/files/extra-patch-old_gcc_bugs
Normal file
29
x11-toolkits/libgnomeuimm26/files/extra-patch-old_gcc_bugs
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- libgnomeui/libgnomeuimm/dateedit.cc.orig Wed Aug 27 22:24:13 2003
|
||||
+++ libgnomeui/libgnomeuimm/dateedit.cc Wed Aug 27 22:25:02 2003
|
||||
@@ -35,7 +35,7 @@
|
||||
: Gtk::HBox(GTK_HBOX(g_object_new(get_type(), (char*)0)))
|
||||
{
|
||||
gnome_date_edit_construct(gobj(), the_time,
|
||||
- static_cast<GnomeDateEditFlags>(
|
||||
+ GnomeDateEditFlags(
|
||||
(show_time ? DATE_EDIT_SHOW_TIME : static_cast<DateEditFlags>(0))
|
||||
| (use_24_format ? DATE_EDIT_24_HR : static_cast<DateEditFlags>(0)) ) );
|
||||
}
|
||||
@@ -44,7 +44,7 @@
|
||||
DateEdit::DateEdit(time_t the_time, DateEditFlags flags)
|
||||
: Gtk::HBox(GTK_HBOX(g_object_new(get_type(), (char*)0)))
|
||||
{
|
||||
- gnome_date_edit_construct(gobj(), the_time, static_cast<GnomeDateEditFlags>(flags));
|
||||
+ gnome_date_edit_construct(gobj(), the_time, GnomeDateEditFlags(flags));
|
||||
}
|
||||
|
||||
|
||||
@@ -254,7 +254,7 @@
|
||||
|
||||
void DateEdit::set_flags(DateEditFlags flags)
|
||||
{
|
||||
- gnome_date_edit_set_flags(gobj(), static_cast<GnomeDateEditFlags>(flags));
|
||||
+ gnome_date_edit_set_flags(gobj(), GnomeDateEditFlags(flags));
|
||||
}
|
||||
|
||||
DateEditFlags DateEdit::get_flags() const
|
Loading…
Reference in a new issue