print/dymo-cups-drivers: the port had been improved (+)

- Replace `std::auto_ptr' with `std::unique_ptr' rather
  than limiting Clang/LLVM version to 15
- Chase HTTP/1.1 301 redirection in the MASTER_SITES and
  finish WWW line update from the previous commit

Fixes:	08760e5251, 9d66bcf099
This commit is contained in:
Alexey Dokuchaev 2024-01-05 08:07:48 +00:00
parent 5e43376d4d
commit 6bc8fc4719
2 changed files with 12 additions and 10 deletions

View File

@ -2,27 +2,20 @@ PORTNAME= dymo-cups-drivers
PORTVERSION= 1.4.0
PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= http://download.dymo.com/Software/Linux/
MASTER_SITES= https://download.dymo.com/Software/Linux/
MAINTAINER= ports@FreeBSD.org
COMMENT= Open source DYMO CUPS driver
WWW= https://www.dymo.com
WWW= https://www.dymo.com/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcupsimage.so:print/cups
USES= localbase:ldflags
USES= localbase:ldflags
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/dymo-cups-drivers-1.4.0.5
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
USES+= llvm:max=15
.endif
.include <bsd.port.mk>

View File

@ -8,3 +8,12 @@
#include <cups/raster.h>
#include <memory>
#include <string>
@@ -132,7 +133,7 @@ CCupsFilter<D, DI, LM>::Run(int argc, char* argv[])
bool UseCustomHalftoning = PageHeader.cupsBitsPerPixel > 1;
bool IsProcessLineSupported = true;
- std::auto_ptr<CHalftoneFilter> H;
+ std::unique_ptr<CHalftoneFilter> H;
if (UseCustomHalftoning)
{
if (HalftoningMethod_ == "NLL")