CLI-MSN is a UNIX Command Line implementation of the MSN Messenger Client,

coded purely in C with the ability to work in almost any UNIX/Linux variation.
The desire for the creation of CLI-MSN came when little or no command-line
based messengers were found to be available that implemented MSN Messenger.

The client itself accepts commands based on that of an IRC clients nature
(/cmd). Currently in the process of working out the file transfer.

WWW:	http://mor-pah.net/

PR:		ports/95186
Submitted by:	Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Approved by:	lawrance (mentor, implicit)
This commit is contained in:
Ion-Mihai Tetcu 2006-06-06 17:47:19 +00:00
parent 8a72df9a62
commit 6be9bd3ef5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=164624
7 changed files with 134 additions and 0 deletions

View file

@ -12,6 +12,7 @@
SUBDIR += centericq
SUBDIR += cicquin
SUBDIR += cjc
SUBDIR += cli-msn
SUBDIR += coccinella
SUBDIR += convey
SUBDIR += echat

42
net-im/cli-msn/Makefile Normal file
View file

@ -0,0 +1,42 @@
# New ports collection makefile for: climsn
# Date created: 2006-03-31
# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
#
# $FreeBSD$
#
PORTNAME= msn
PORTVERSION= 2.2
CATEGORIES= net-im
MASTER_SITES= http://mor-pah.net/code/
PKGNAMEPREFIX= cli-
DISTNAME= CLI-MSN-${PORTVERSION}
MAINTAINER= acardenas@bsd.org.pe
COMMENT= Command line msn messenger
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_LIBS}
LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
SUB_FILES= pkg-message
PLIST_FILES= bin/cli-msn \
share/${PKGNAMEPREFIX}${PORTNAME}/msn.conf \
share/${PKGNAMEPREFIX}${PORTNAME}/curl-ca-bundle.crt
PLIST_DIRS= share/${PKGNAMEPREFIX}${PORTNAME}
DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX}${PORTNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/msn ${PREFIX}/bin/cli-msn
post-install:
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/msn.conf ${WRKSRC}/curl-ca-bundle.crt ${DATADIR}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

3
net-im/cli-msn/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (CLI-MSN-2.2.tar.gz) = 0e75a3cfb86d71acde63623169488180
SHA256 (CLI-MSN-2.2.tar.gz) = ff46c6445ea415f41535bfb2dd8338f84fec794414a60fbe3ad5a9286742ed42
SIZE (CLI-MSN-2.2.tar.gz) = 215672

View file

@ -0,0 +1,48 @@
--- src/conf.c Mon Dec 19 16:25:35 2005
+++ src/conf.c Fri Mar 31 20:56:39 2006
@@ -6,6 +6,7 @@
*/
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include "headers/defs.h"
#include "headers/conf.h"
@@ -15,15 +16,35 @@
int ctr, tmp;
int flag = 0;
FILE *fp;
+ char *homedir;
char ch;
+ char home_directory[255];
char pre[255]; /* Temp Buffer for config lines */
char _confstr[MAX_NO_LINES][MAX_LINE_LENGTH]; /* Temp buffer for valid config lines */
+
+ homedir = getenv("HOME");
+ if (homedir == NULL)
+ {
+ homedir = getenv("USER");
+ if (homedir == NULL)
+ {
+ homedir = getenv("USERNAME");
+ if (homedir == NULL)
+ {
+ cli_msg( stderr, "Could not find user's home directory!\n" );
+ }
+ }
+ strcpy(home_directory,"/home/");
+ }
+
+ strcpy(home_directory,homedir);
+ strcat(home_directory,"/.msn/msn.conf");
- if ( (fp = fopen(CONF_LOCATION, "r")) != NULL ){
+ if ( (fp = fopen(home_directory, "r")) != NULL ){
cli_msg("Reading msn.conf...\n");
}
else {
- cli_msg("No config file found at: %s\n", CONF_LOCATION);
+ cli_msg("No config file found at: %s\n", home_directory);
cli_msg("Continuing with command line args and defaults\n");
return;
}

View file

@ -0,0 +1,10 @@
--- src/headers/defs.h Wed Jan 4 10:52:17 2006
+++ src/headers/defs.h Fri Mar 31 20:29:12 2006
@@ -1,7 +1,6 @@
#define VERSION "CLI-MSN-2.2"
#define MAX_LINE_LENGTH 255 /* Config File line length */
#define MAX_NO_LINES 4 /* Config File No. Lines */
-#define CONF_LOCATION "msn.conf" /* Default locality of msn.conf */
#define MAX_LIST_SIZE 150
#define MAX_ACCOUNT_LEN 130
#define MAX_NICK_LEN 130

View file

@ -0,0 +1,21 @@
###############################################################################
1) Create ~/.msn directory
# mkdir ~/.msn
2) Copy %%DATADIR%% files to ~/.msn directory
# cp %%DATADIR%%/* ~/.msn
3) Modify ~/.msn/msn.conf ( user, pass, cert )
# MSN Login name
user 'user@domain.com'
pass 'password'
cert '/path/to/curl-ca-bundle.crt'
4) Run cli-msn
5) Enjoy it ;)
###############################################################################

9
net-im/cli-msn/pkg-descr Normal file
View file

@ -0,0 +1,9 @@
CLI-MSN is a UNIX Command Line implementation of the MSN Messenger Client,
coded purely in C with the ability to work in almost any UNIX/Linux variation.
The desire for the creation of CLI-MSN came when little or no command-line
based messengers were found to be available that implemented MSN Messenger.
The client itself accepts commands based on that of an IRC clients nature
(/cmd). Currently in the process of working out the file transfer.
WWW: http://mor-pah.net/