- Update to 2.2.5
- Fetch from Github (Sourceforge files no longer available) - Use USES=dos2unix to convert header files - Remove DOCS option (all html docs were replaced with a single html page that just redirects to the muparser homepage) - Add DOXYGEN option to build API documentation - Use options target helpers - configure script already supplies -fPIC -DPIC where needed, so remove it from the port Makefile - Add LICENSE_FILE - Move USES upward, group OPTIONS stuff together Changes: http://beltoforion.de/article.php?a=muparser&hl=en&p=release_notes PR: 216090 Submitted by: jhale Approved by: maintainer timeout (7 weeks)
This commit is contained in:
parent
db40a4a04e
commit
6c2d9007d5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=435575
4 changed files with 66 additions and 102 deletions
|
@ -2,53 +2,53 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= muparser
|
||||
PORTVERSION= 2.2.3
|
||||
PORTVERSION= 2.2.5
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= math devel
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Version%20${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME}_v${PORTVERSION:S/./_/g}
|
||||
|
||||
MAINTAINER= nivit@FreeBSD.org
|
||||
COMMENT= Mathematical expressions parser library written in C++
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/License.txt
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= beltoforion
|
||||
|
||||
USES= dos2unix pathfix
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
ALL_TARGET= lib
|
||||
GNU_CONFIGURE= yes
|
||||
# otherwise it fails to build when the EXAMPLES option is ON
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
DOCS_CONFIGURE_ON= --docdir=${DOCSDIR}
|
||||
OPTIONS_DEFINE= DOXYGEN EXAMPLES
|
||||
|
||||
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
|
||||
dot:graphics/graphviz
|
||||
DOXYGEN_ALL_TARGET= documentation
|
||||
DOXYGEN_PORTDOCS= *
|
||||
# PORTDOCS macro won't work if NOPORTDOCS is defined or if DOCS is disabled
|
||||
DOXYGEN_IMPLIES= DOCS
|
||||
.undef NOPORTDOCS
|
||||
|
||||
EXAMPLES_CONFIGURE_ENABLE= samples
|
||||
EXAMPLES_ALL_TARGET= samples
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
# otherwise it fails to build when the EXAMPLES option is ON
|
||||
MAKE_JOBS_UNSAFE=yes
|
||||
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
USES= pathfix zip
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
|
||||
CFLAGS+= -fPIC
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -E 's,^(CXXFLAGS|LDFLAGS) = ,\1 ?= ,g' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
post-install:
|
||||
post-install-DOXYGEN-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
(cd ${WRKSRC}/docs/html && \
|
||||
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
|
||||
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
post-install-EXAMPLES-on:
|
||||
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
(cd ${WRKSRC}/samples/example1 && \
|
||||
${INSTALL_PROGRAM} example1 ${STAGEDIR}${EXAMPLESDIR} && \
|
||||
${INSTALL_DATA} example1.cpp ${STAGEDIR}${EXAMPLESDIR})
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (muparser_v2_2_3.zip) = dfe831b69392ab0b1eb59d3601b7b1575554a85057cf2f234f64f930c4148902
|
||||
SIZE (muparser_v2_2_3.zip) = 1481359
|
||||
TIMESTAMP = 1484386394
|
||||
SHA256 (beltoforion-muparser-v2.2.5_GH0.tar.gz) = 0666ef55da72c3e356ca85b6a0084d56b05dd740c3c21d26d372085aa2c6e708
|
||||
SIZE (beltoforion-muparser-v2.2.5_GH0.tar.gz) = 761315
|
||||
|
|
38
math/muparser/files/patch-docs_Doxyfile
Normal file
38
math/muparser/files/patch-docs_Doxyfile
Normal file
|
@ -0,0 +1,38 @@
|
|||
--- docs/Doxyfile.orig 2015-08-16 14:23:14 UTC
|
||||
+++ docs/Doxyfile
|
||||
@@ -31,7 +31,7 @@ PROJECT_NAME = "muParser API -
|
||||
# This could be handy for archiving the generated documentation or
|
||||
# if some version control system is used.
|
||||
|
||||
-PROJECT_NUMBER = 1.35
|
||||
+PROJECT_NUMBER = 2.2.5
|
||||
|
||||
# The OUTPUT_DIRECTORY tag is used to specify the (relative or absolute)
|
||||
# base path where the generated documentation will be put.
|
||||
@@ -47,7 +47,7 @@ OUTPUT_DIRECTORY = html/
|
||||
# source files, where putting all generated files in the same directory would
|
||||
# otherwise cause performance problems for the file system.
|
||||
|
||||
-CREATE_SUBDIRS = YES
|
||||
+CREATE_SUBDIRS = NO
|
||||
|
||||
# The OUTPUT_LANGUAGE tag is used to specify the language in which all
|
||||
# documentation generated by doxygen is written. Doxygen will use this
|
||||
@@ -778,7 +778,7 @@ GENERATE_HTML = YES
|
||||
# If a relative path is entered the value of OUTPUT_DIRECTORY will be
|
||||
# put in front of it. If left blank `html' will be used as the default path.
|
||||
|
||||
-HTML_OUTPUT = classdocu/
|
||||
+HTML_OUTPUT =
|
||||
|
||||
# The HTML_FILE_EXTENSION tag can be used to specify the file extension for
|
||||
# each generated HTML page (for example: .htm,.php,.asp). If it is left blank
|
||||
@@ -796,7 +796,7 @@ HTML_HEADER =
|
||||
# each generated HTML page. If it is left blank doxygen will generate a
|
||||
# standard footer.
|
||||
|
||||
-HTML_FOOTER = html/misc/footer.html
|
||||
+HTML_FOOTER =
|
||||
|
||||
# The HTML_STYLESHEET tag can be used to specify a user-defined cascading
|
||||
# style sheet that is used by each HTML page. It can be used to
|
|
@ -14,82 +14,7 @@ include/muParserToken.h
|
|||
include/muParserTokenReader.h
|
||||
lib/libmuparser.so
|
||||
lib/libmuparser.so.2
|
||||
lib/libmuparser.so.2.2.3
|
||||
lib/libmuparser.so.2.2.4
|
||||
libdata/pkgconfig/muparser.pc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/api.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/api_dark.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/back_idx.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/bench2.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/blocks.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/build.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/bytecode.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/caption.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/diff.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/download_muparser.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/download_muparser_.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/grad2.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/help.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/home.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/home_dark.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/info.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/list.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/mathparser.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/mathparser_small.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/muparsernet.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/muparsernet_.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/muparsersse.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/muparsersse_.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/muparserx.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/muparserx_.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/osi.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/question.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/related (Kopie).png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/related.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/thumb_gct.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/thumb_geodes.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/thumb_kst.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/thumb_matrix.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/thumb_meshlab.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/thumb_pasimodo.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/thumb_qtiplot.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/thumb_tm2.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/thumb_trini.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/warning.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/misc/Main.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/misc/calc.cpp
|
||||
%%PORTDOCS%%%%DOCSDIR%%/misc/example.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/misc/footer.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/misc/header.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/misc/list_expr_var.cpp
|
||||
%%PORTDOCS%%%%DOCSDIR%%/misc/listvar.cpp
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mup_features.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mup_interface.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mup_intro.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mup_licence.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mup_links.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mup_locale.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mup_usage.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mup_version.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/script/functions.js
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/build_page.sh
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_features.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_features_meta.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_interface.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_interface_meta.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_intro.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_intro_meta.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_licence.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_licence_meta.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_links.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_links_meta.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_locale.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_locale_meta.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_usage.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_usage_meta.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_version.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/mup_version_meta.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sources/navigation.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/style/formate.css
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1.cpp
|
||||
|
|
Loading…
Reference in a new issue