- Add LICENSE

- Pet portlint
- Add NO_ARCH
- Regenerate patches with `make makepatch`
This commit is contained in:
Dmitry Marakasov 2015-09-14 12:20:04 +00:00
parent afae652a2a
commit 6c71a7e7fe
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=396893
2 changed files with 11 additions and 8 deletions

View file

@ -12,9 +12,12 @@ DISTNAME= Pyfort-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Creating extensions to the Python language with Fortran routines
LICENSE= MIT
RUN_DEPENDS= ${PYNUMERIC}
USES= python
USE_PYTHON= distutils autoplist
USE_PYTHON= autoplist distutils
NO_ARCH= yes
.include <bsd.port.mk>

View file

@ -1,6 +1,6 @@
--- fortran_compiler.py.orig Sat Jul 20 20:40:23 2002
+++ fortran_compiler.py Thu Jul 25 11:43:52 2002
@@ -574,6 +574,7 @@
--- fortran_compiler.py.orig 2005-09-20 18:08:08 UTC
+++ fortran_compiler.py
@@ -703,6 +703,7 @@ compiler_ids = [
'pgf77',
'pgf90',
'g77',
@ -8,13 +8,13 @@
'g77alpha',
'sgi',
'vf',
@@ -654,6 +655,9 @@
@@ -801,6 +802,9 @@ def get_compiler (compiler_id):
elif compiler_id == 'g77':
return G77Compiler()
+
+ elif compiler_id == 'f77':
+ return F77Compiler()
+
elif compiler_id == 'g77alpha':
return G77Compiler(typedict = alpha_typedict)