Fix build with openssl 0.9.8b.

PR:		ports/102822
Submitted by:	simon
This commit is contained in:
Brooks Davis 2006-09-14 17:37:05 +00:00
parent b17ed41b77
commit 6c9ac20960
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=173067
2 changed files with 13 additions and 4 deletions

View file

@ -65,8 +65,4 @@ post-install:
IGNORE=is not supported on FreeBSD < 6.0
.endif
.if ${OSVERSION} >= 700019
BROKEN= does not compile on FreeBSD >= 7.0
.endif
.include <bsd.port.post.mk>

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- crypto.c.orig
+++ crypto.c
@@ -12,6 +12,7 @@
* See README and COPYING for more details.
*/
+#include <sys/types.h>
#include <openssl/md4.h>
#include <openssl/des.h>