databases/rocksdb: Update to 8.0.0
Changes: https://github.com/facebook/rocksdb/releases
This commit is contained in:
parent
bcb40be56f
commit
6ca7096afe
8 changed files with 37 additions and 49 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= rocksdb
|
||||
PORTVERSION= 7.9.2
|
||||
PORTVERSION= 8.0.0
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= databases
|
||||
|
||||
|
@ -13,7 +13,7 @@ LICENSE_COMB= dual
|
|||
LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.Apache
|
||||
LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
|
||||
|
||||
BROKEN= fails to build
|
||||
#BROKEN= fails to build
|
||||
BROKEN_DragonFly= does not build on DragonFly BSD using GCC with -Werror
|
||||
BROKEN_armv6= does not build: db/c.cc:2281:44: implicit conversion loses integer precision: 'uint64_t' (aka 'unsigned long long') to 'size_t' (aka 'unsigned int')
|
||||
BROKEN_armv7= does not build: /nxb-bin/usr/bin/ld: undefined reference to symbol `__gnu_Unwind_Find_exidx@@FBSD_1.4' (try adding -lc) #'`
|
||||
|
@ -32,7 +32,7 @@ CONFIGURE_ARGS= make_config.mk
|
|||
CONFIGURE_ENV= PORTABLE=0 ROCKSDB_ROOT=${WRKSRC}
|
||||
CONFIGURE_SCRIPT= build_tools/build_detect_platform
|
||||
HAS_CONFIGURE= yes
|
||||
MAKE_ENV= CXX=${CXX} INSTALL_PATH=${STAGEDIR}${PREFIX} USE_RTTI=1
|
||||
MAKE_ENV= CXX=${CXX} INSTALL_PATH=${STAGEDIR}${PREFIX} USE_RTTI=1 V=1
|
||||
USE_CXXSTD= c++17
|
||||
USE_LDCONFIG= yes
|
||||
TEST_TARGET= check
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1675190923
|
||||
SHA256 (facebook-rocksdb-v7.9.2_GH0.tar.gz) = 886378093098a1b2521b824782db7f7dd86224c232cf9652fcaf88222420b292
|
||||
SIZE (facebook-rocksdb-v7.9.2_GH0.tar.gz) = 12058713
|
||||
TIMESTAMP = 1679498520
|
||||
SHA256 (facebook-rocksdb-v8.0.0_GH0.tar.gz) = 05ff6b0e89bffdf78b5a9d6fca46cb06bde6189f5787b9eeaef0511b782c1033
|
||||
SIZE (facebook-rocksdb-v8.0.0_GH0.tar.gz) = 12634178
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- db/db_test_util.cc.orig 2022-12-22 17:30:39 UTC
|
||||
--- db/db_test_util.cc.orig 2023-02-19 21:44:55 UTC
|
||||
+++ db/db_test_util.cc
|
||||
@@ -104,9 +104,11 @@ DBTestBase::DBTestBase(const std::string path, bool en
|
||||
@@ -102,9 +102,11 @@ DBTestBase::DBTestBase(const std::string path, bool en
|
||||
}
|
||||
|
||||
DBTestBase::~DBTestBase() {
|
||||
|
@ -12,7 +12,7 @@
|
|||
Close();
|
||||
Options options;
|
||||
options.db_paths.emplace_back(dbname_, 0);
|
||||
@@ -356,6 +358,7 @@ Options DBTestBase::GetOptions(
|
||||
@@ -338,6 +340,7 @@ Options DBTestBase::GetOptions(
|
||||
Options options = default_options;
|
||||
BlockBasedTableOptions table_options;
|
||||
bool set_block_based_table_factory = true;
|
||||
|
@ -20,7 +20,7 @@
|
|||
#if !defined(OS_MACOSX) && !defined(OS_WIN) && !defined(OS_SOLARIS) && \
|
||||
!defined(OS_AIX)
|
||||
ROCKSDB_NAMESPACE::SyncPoint::GetInstance()->ClearCallBack(
|
||||
@@ -363,6 +366,7 @@ Options DBTestBase::GetOptions(
|
||||
@@ -345,6 +348,7 @@ Options DBTestBase::GetOptions(
|
||||
ROCKSDB_NAMESPACE::SyncPoint::GetInstance()->ClearCallBack(
|
||||
"NewWritableFile:O_DIRECT");
|
||||
#endif
|
||||
|
@ -28,7 +28,7 @@
|
|||
// kMustFreeHeapAllocations -> indicates ASAN build
|
||||
if (kMustFreeHeapAllocations && !options_override.full_block_cache) {
|
||||
// Detecting block cache use-after-free is normally difficult in unit
|
||||
@@ -428,7 +432,9 @@ Options DBTestBase::GetOptions(
|
||||
@@ -409,7 +413,9 @@ Options DBTestBase::GetOptions(
|
||||
options.use_direct_reads = true;
|
||||
options.use_direct_io_for_flush_and_compaction = true;
|
||||
options.compaction_readahead_size = 2 * 1024 * 1024;
|
||||
|
@ -37,16 +37,16 @@
|
|||
+#endif
|
||||
break;
|
||||
}
|
||||
#endif // ROCKSDB_LITE
|
||||
@@ -1168,6 +1174,7 @@ std::string DBTestBase::FilesPerLevel(int cf) {
|
||||
case kMergePut:
|
||||
@@ -1141,6 +1147,7 @@ std::string DBTestBase::FilesPerLevel(int cf) {
|
||||
}
|
||||
|
||||
#endif // !ROCKSDB_LITE
|
||||
|
||||
+#ifndef NDEBUG
|
||||
std::vector<uint64_t> DBTestBase::GetBlobFileNumbers() {
|
||||
VersionSet* const versions = dbfull()->GetVersionSet();
|
||||
assert(versions);
|
||||
@@ -1193,6 +1200,7 @@ std::vector<uint64_t> DBTestBase::GetBlobFileNumbers()
|
||||
@@ -1166,6 +1173,7 @@ std::vector<uint64_t> DBTestBase::GetBlobFileNumbers()
|
||||
|
||||
return result;
|
||||
}
|
||||
|
@ -54,7 +54,7 @@
|
|||
|
||||
size_t DBTestBase::CountFiles() {
|
||||
size_t count = 0;
|
||||
@@ -1275,6 +1283,7 @@ void DBTestBase::FillLevels(const std::string& smalles
|
||||
@@ -1248,6 +1256,7 @@ void DBTestBase::FillLevels(const std::string& smalles
|
||||
}
|
||||
|
||||
void DBTestBase::MoveFilesToLevel(int level, int cf) {
|
||||
|
@ -62,14 +62,13 @@
|
|||
for (int l = 0; l < level; ++l) {
|
||||
if (cf > 0) {
|
||||
EXPECT_OK(dbfull()->TEST_CompactRange(l, nullptr, nullptr, handles_[cf]));
|
||||
@@ -1282,13 +1291,16 @@ void DBTestBase::MoveFilesToLevel(int level, int cf) {
|
||||
@@ -1255,12 +1264,15 @@ void DBTestBase::MoveFilesToLevel(int level, int cf) {
|
||||
EXPECT_OK(dbfull()->TEST_CompactRange(l, nullptr, nullptr));
|
||||
}
|
||||
}
|
||||
+#endif
|
||||
}
|
||||
|
||||
#ifndef ROCKSDB_LITE
|
||||
void DBTestBase::DumpFileCounts(const char* label) {
|
||||
fprintf(stderr, "---\n%s:\n", label);
|
||||
+#ifndef NDEBUG
|
||||
|
@ -79,7 +78,7 @@
|
|||
for (int level = 0; level < db_->NumberLevels(); level++) {
|
||||
int num = NumTableFilesAtLevel(level);
|
||||
if (num > 0) {
|
||||
@@ -1331,10 +1343,12 @@ void DBTestBase::GenerateNewFile(int cf, Random* rnd,
|
||||
@@ -1302,10 +1314,12 @@ void DBTestBase::GenerateNewFile(int cf, Random* rnd,
|
||||
ASSERT_OK(Put(cf, Key(*key_idx), rnd->RandomString((i == 99) ? 1 : 990)));
|
||||
(*key_idx)++;
|
||||
}
|
||||
|
@ -92,7 +91,7 @@
|
|||
}
|
||||
|
||||
// this will generate non-overlapping files since it keeps increasing key_idx
|
||||
@@ -1343,10 +1357,12 @@ void DBTestBase::GenerateNewFile(Random* rnd, int* key
|
||||
@@ -1314,10 +1328,12 @@ void DBTestBase::GenerateNewFile(Random* rnd, int* key
|
||||
ASSERT_OK(Put(Key(*key_idx), rnd->RandomString((i == 99) ? 1 : 990)));
|
||||
(*key_idx)++;
|
||||
}
|
||||
|
@ -105,7 +104,7 @@
|
|||
}
|
||||
|
||||
const int DBTestBase::kNumKeysByGenerateNewRandomFile = 51;
|
||||
@@ -1356,10 +1372,12 @@ void DBTestBase::GenerateNewRandomFile(Random* rnd, bo
|
||||
@@ -1327,10 +1343,12 @@ void DBTestBase::GenerateNewRandomFile(Random* rnd, bo
|
||||
ASSERT_OK(Put("key" + rnd->RandomString(7), rnd->RandomString(2000)));
|
||||
}
|
||||
ASSERT_OK(Put("key" + rnd->RandomString(7), rnd->RandomString(200)));
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- memory/arena.cc.orig 2021-06-25 21:15:04 UTC
|
||||
+++ memory/arena.cc
|
||||
@@ -29,7 +29,7 @@ const size_t Arena::kInlineSize;
|
||||
|
||||
const size_t Arena::kMinBlockSize = 4096;
|
||||
const size_t Arena::kMaxBlockSize = 2u << 30;
|
||||
-static const int kAlignUnit = alignof(max_align_t);
|
||||
+static const int kAlignUnit = alignof(std::max_align_t);
|
||||
|
||||
size_t OptimizeBlockSize(size_t block_size) {
|
||||
// Make sure block_size is in optimal range
|
|
@ -1,11 +0,0 @@
|
|||
--- memory/arena.h.orig 2018-01-31 01:15:39 UTC
|
||||
+++ memory/arena.h
|
||||
@@ -82,7 +82,7 @@ class Arena : public Allocator {
|
||||
}
|
||||
|
||||
private:
|
||||
- char inline_block_[kInlineSize] __attribute__((__aligned__(alignof(max_align_t))));
|
||||
+ char inline_block_[kInlineSize] __attribute__((__aligned__(alignof(std::max_align_t))));
|
||||
// Number of bytes allocated in one block
|
||||
const size_t kBlockSize;
|
||||
// Array of new[] allocated memory blocks
|
|
@ -1,6 +1,6 @@
|
|||
--- memory/arena_test.cc.orig 2018-01-31 01:15:39 UTC
|
||||
--- memory/arena_test.cc.orig 2023-02-19 21:44:55 UTC
|
||||
+++ memory/arena_test.cc
|
||||
@@ -91,7 +91,7 @@ static void ApproximateMemoryUsageTest(s
|
||||
@@ -96,7 +96,7 @@ static void ApproximateMemoryUsageTest(size_t huge_pag
|
||||
ASSERT_EQ(kZero, arena.ApproximateMemoryUsage());
|
||||
|
||||
// allocate inline bytes
|
||||
|
|
|
@ -1,6 +1,15 @@
|
|||
--- port/stack_trace.cc.orig 2021-06-25 21:15:04 UTC
|
||||
--- port/stack_trace.cc.orig 2023-02-19 21:44:55 UTC
|
||||
+++ port/stack_trace.cc
|
||||
@@ -135,7 +135,7 @@ void PrintStack(int first_frames_to_skip) {
|
||||
@@ -33,6 +33,8 @@ void* SaveStack(int* /*num_frames*/, int /*first_frame
|
||||
|
||||
#ifdef OS_FREEBSD
|
||||
#include <sys/sysctl.h>
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/wait.h>
|
||||
#endif // OS_FREEBSD
|
||||
#ifdef OS_LINUX
|
||||
#include <sys/prctl.h>
|
||||
@@ -219,7 +221,7 @@ void PrintStack(int first_frames_to_skip) {
|
||||
void* frames[kMaxFrames];
|
||||
|
||||
auto num_frames = backtrace(frames, kMaxFrames);
|
||||
|
@ -9,7 +18,7 @@
|
|||
}
|
||||
|
||||
void PrintAndFreeStack(void* callstack, int num_frames) {
|
||||
@@ -148,7 +148,7 @@ void* SaveStack(int* num_frames, int first_frames_to_s
|
||||
@@ -232,7 +234,7 @@ void* SaveStack(int* num_frames, int first_frames_to_s
|
||||
void* frames[kMaxFrames];
|
||||
|
||||
auto count = backtrace(frames, kMaxFrames);
|
||||
|
|
|
@ -14,6 +14,7 @@ bin/sst_dump
|
|||
bin/table_reader_bench
|
||||
bin/trace_analyzer
|
||||
bin/write_stress
|
||||
include/rocksdb/advanced_cache.h
|
||||
include/rocksdb/advanced_options.h
|
||||
include/rocksdb/block_cache_trace_writer.h
|
||||
include/rocksdb/c.h
|
||||
|
@ -54,6 +55,7 @@ include/rocksdb/options.h
|
|||
include/rocksdb/perf_context.h
|
||||
include/rocksdb/perf_level.h
|
||||
include/rocksdb/persistent_cache.h
|
||||
include/rocksdb/port_defs.h
|
||||
include/rocksdb/rate_limiter.h
|
||||
include/rocksdb/rocksdb_namespace.h
|
||||
include/rocksdb/secondary_cache.h
|
||||
|
@ -118,7 +120,7 @@ include/rocksdb/write_batch_base.h
|
|||
include/rocksdb/write_buffer_manager.h
|
||||
lib/librocksdb.a
|
||||
lib/librocksdb.so
|
||||
lib/librocksdb.so.7
|
||||
lib/librocksdb.so.8
|
||||
lib/librocksdb.so.%%SHLIB_VER%%
|
||||
lib/librocksdb.so.%%PORTVERSION%%
|
||||
lib/librocksdb_tools.so
|
||||
|
|
Loading…
Reference in a new issue