o Update to 4.3.4RC1.
o Sync with latest PHP5 changes (new DB4 extension, use correct knobs, etc...) PR: ports/57399 Submitted by: Alex Dupre <sysadmin@alexdupre.com> (maintainer)
This commit is contained in:
parent
2c24ba8059
commit
6cb400092d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=89888
6 changed files with 66 additions and 76 deletions
|
@ -20,7 +20,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= php4
|
||||
PORTVERSION= 4.3.3
|
||||
PORTVERSION= 4.3.4.r1
|
||||
PORTREVISION= 0
|
||||
CATEGORIES?= lang devel www
|
||||
MASTER_SITES= http://www.php.net/distributions/:release \
|
||||
|
@ -45,7 +45,7 @@ PKGNAMESUFFIX= -cli
|
|||
.endif
|
||||
.endif
|
||||
DISTNAME= php-${PORTVERSION:S/.r/RC/}
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:release
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:rc
|
||||
|
||||
MAINTAINER?= sysadmin@alexdupre.com
|
||||
COMMENT= PHP Scripting Language (Apache Module and CLI)
|
||||
|
@ -65,7 +65,6 @@ USE_BZIP2= yes
|
|||
USE_SUBMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BISON= yes
|
||||
USE_LIBTOOL_VER=14
|
||||
|
||||
CONFIGURE_ARGS= --enable-versioning \
|
||||
--enable-memory-limit \
|
||||
|
@ -112,6 +111,12 @@ PLIST_SUB+= APACHE=""
|
|||
CONFIGURE_ARGS+=--disable-cli
|
||||
PLIST_SUB+= CLI="@comment "
|
||||
.else
|
||||
.if !defined(WITHOUT_PEAR)
|
||||
CONFIGURE_ARGS+=--with-pear
|
||||
PLIST_SUB+= PEAR=""
|
||||
.else
|
||||
PLIST_SUB+= PEAR="@comment "
|
||||
.endif
|
||||
MAN1= php.1
|
||||
PLIST_SUB+= CLI=""
|
||||
.endif
|
||||
|
@ -119,13 +124,13 @@ PLIST_SUB+= CLI=""
|
|||
SAPI_FILE= "bin/php"
|
||||
.endif
|
||||
|
||||
ALL_OPTIONS= BCMATH BZIP2 CALENDAR CDB CRACK CTYPE CURL DBASE DBX DOMXML \
|
||||
DOMXSLT EXIF FILEPRO FRIBIDI FTP GD GDBM GETTEXT GMP HYPERWAVE \
|
||||
ICONV IMAP INTERBASE INIFILE MBSTRING MCAL MCVE MCRYPT MHASH \
|
||||
MIME MING MYSQL NCURSES OPENLDAP OPENSSL ORACLE OVERLOAD PCNTL \
|
||||
PCRE PDFLIB POSIX POSTGRESQL PSPELL READLINE RECODE SESSION \
|
||||
SHMOP SNMP SOCKETS SYBASEDB SYBASECT SYSVSEM SYSVSHM TOKENIZER \
|
||||
UNIXODBC WDDX XML XMLRPC XSLT YAZ YP ZIP ZLIB
|
||||
ALL_OPTIONS= BCMATH BZIP2 CALENDAR CDB CRACK CTYPE CURL DB4 DBASE DBX \
|
||||
DOMXML DOMXSLT EXIF FILEPRO FRIBIDI FTP GD GDBM GETTEXT GMP \
|
||||
HYPERWAVE ICONV IMAP INTERBASE INIFILE MBSTRING MCAL MCVE \
|
||||
MCRYPT MHASH MIME MING MYSQL NCURSES OPENLDAP OPENSSL ORACLE \
|
||||
OVERLOAD PCNTL PCRE PDFLIB POSIX POSTGRESQL PSPELL READLINE \
|
||||
RECODE SESSION SHMOP SNMP SOCKETS SYBASEDB SYBASECT SYSVSEM \
|
||||
SYSVSHM TOKENIZER UNIXODBC WDDX XML XMLRPC XSLT YAZ YP ZIP ZLIB
|
||||
|
||||
.for opt in ${ALL_OPTIONS}
|
||||
.if defined(WITH_${opt}) || defined(WITHOUT_${opt})
|
||||
|
@ -203,7 +208,7 @@ WITH_XML= yes
|
|||
.include "${WRKDIR}/Makefile.inc"
|
||||
.endif
|
||||
|
||||
.if defined(WITH_CDB) || defined(WITH_GDBM) || defined(WITH_INIFILE)
|
||||
.if defined(WITH_CDB) || defined(WITH_DB4) || defined(WITH_GDBM) || defined(WITH_INIFILE)
|
||||
WITH_DBA= yes
|
||||
.endif
|
||||
|
||||
|
@ -215,8 +220,8 @@ WITH_DOMXML= yes
|
|||
WITH_ICONV_DEP= yes
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SNMP)
|
||||
WITH_OPENSSL= yes
|
||||
.if defined(WITH_MCVE) || defined(WITH_SNMP)
|
||||
WITH_OPENSSL_DEP= yes
|
||||
.endif
|
||||
|
||||
.if defined(WITH_XMLRPC) || defined(WITH_XSLT)
|
||||
|
@ -264,6 +269,11 @@ LIB_DEPENDS+= curl.2:${PORTSDIR}/ftp/curl
|
|||
CONFIGURE_ARGS+=--with-curl=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if defined(WITH_DB4)
|
||||
LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
|
||||
CONFIGURE_ARGS+=--with-db4=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if defined(WITH_DBA)
|
||||
CONFIGURE_ARGS+=--enable-dba
|
||||
.endif
|
||||
|
@ -410,13 +420,7 @@ CONFIGURE_ARGS+=--with-ming=${LOCALBASE}
|
|||
.endif
|
||||
|
||||
.if defined(WITH_MYSQL)
|
||||
.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.10)
|
||||
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
|
||||
.elif exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.14)
|
||||
LIB_DEPENDS+= mysqlclient.14:${PORTSDIR}/databases/mysql41-client
|
||||
.else
|
||||
LIB_DEPENDS+= mysqlclient.12:${PORTSDIR}/databases/mysql40-client
|
||||
.endif
|
||||
USE_MYSQL= yes
|
||||
CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
|
@ -431,29 +435,13 @@ CONFIGURE_ARGS+=--with-ncurses=${NCURSESBASE}
|
|||
.endif
|
||||
|
||||
.if defined(WITH_OPENLDAP)
|
||||
.if exists(${LOCALBASE}/lib/libldap.so.1)
|
||||
LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
|
||||
.elif exists(${LOCALBASE}/lib/libldap.so.2)
|
||||
.if exists(${LOCALBASE}/include/srchpref.h)
|
||||
LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20-client
|
||||
.elif exists(${LOCALBASE}/include/slapi-plugin.h)
|
||||
LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap22-client
|
||||
.else
|
||||
LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21-client
|
||||
.endif
|
||||
.else
|
||||
LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap22-client
|
||||
.endif
|
||||
USE_OPENLDAP= yes
|
||||
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if defined(WITH_OPENSSL) || defined(WITH_OPENSSL_DEP)
|
||||
.if exists(${LOCALBASE}/lib/libcrypto.so.3)
|
||||
OPENSSLBASE= ${LOCALBASE}
|
||||
LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
|
||||
.else
|
||||
OPENSSLBASE= /usr
|
||||
.endif
|
||||
USE_OPENSSL= yes
|
||||
CONFIGURE_ARGS+=--with-openssl-dir=${OPENSSLBASE}
|
||||
.endif
|
||||
|
||||
.if defined(WITH_OPENSSL)
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (php-4.3.3.tar.bz2) = 1171d96104e2ff2cff9e19789a4a1536
|
||||
MD5 (php-4.3.4RC1.tar.bz2) = f7ff7bf763f917b9f955e19caf77c1f1
|
||||
|
|
|
@ -228,7 +228,7 @@
|
|||
@@ -58977,8 +59151,8 @@
|
||||
|
||||
echo $ac_n "checking Oracle version""... $ac_c" 1>&6
|
||||
echo "configure:58982: checking Oracle version" >&5
|
||||
echo "configure:59852: checking Oracle version" >&5
|
||||
- if test -s "$ORACLE_DIR/orainst/unix.rgs"; then
|
||||
- ORACLE_VERSION=`grep '"ocommon"' $ORACLE_DIR/orainst/unix.rgs | sed 's/ */:/g' | cut -d: -f 6 | cut -c 2-4`
|
||||
+ if test -s "$ORACLE_DIR/ocommon/install/partial.prd"; then
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
%%CLI%%bin/pear
|
||||
%%CLI%%%%PEAR%%bin/pear
|
||||
%%CLI%%bin/php
|
||||
bin/php-config
|
||||
bin/phpextdist
|
||||
|
@ -201,31 +201,31 @@ lib/php/build/shtool
|
|||
%%SAPI_FILE%%
|
||||
%%APACHE%%@exec %D/sbin/apxs -e -a -n php4 %f
|
||||
%%APACHE%%@unexec %D/sbin/apxs -e -A -n php4 %f
|
||||
%%CLI%%share/pear/bootstrap/Archive/Tar.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR.php
|
||||
%%CLI%%share/pear/bootstrap/System.php
|
||||
%%CLI%%share/pear/bootstrap/Console/Getopt.php
|
||||
%%CLI%%share/pear/bootstrap/OS/Guess.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Command/Auth.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Command/Build.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Command/Common.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Command/Config.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Command/Install.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Command/Mirror.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Command/Package.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Command/Registry.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Command/Remote.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Autoloader.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Builder.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Command.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Common.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Config.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Dependency.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Installer.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Packager.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Registry.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Remote.php
|
||||
%%CLI%%share/pear/bootstrap/PEAR/Frontend/CLI.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/Archive/Tar.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/System.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/Console/Getopt.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/OS/Guess.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Command/Auth.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Command/Build.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Command/Common.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Command/Config.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Command/Install.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Command/Mirror.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Command/Package.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Command/Registry.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Command/Remote.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Autoloader.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Builder.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Command.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Common.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Config.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Dependency.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Installer.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Packager.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Registry.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Remote.php
|
||||
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Frontend/CLI.php
|
||||
@dirrm include/php/TSRM
|
||||
@dirrm include/php/Zend
|
||||
@dirrm include/php/ext/mbstring
|
||||
|
@ -241,11 +241,11 @@ lib/php/build/shtool
|
|||
@unexec rmdir %D/lib/php/%%EXT_DIR%% 2> /dev/null || true
|
||||
@dirrm lib/php/build
|
||||
@unexec rmdir %D/lib/php 2> /dev/null || true
|
||||
%%CLI%%@dirrm share/pear/bootstrap/Archive
|
||||
%%CLI%%@dirrm share/pear/bootstrap/Console
|
||||
%%CLI%%@dirrm share/pear/bootstrap/OS
|
||||
%%CLI%%@dirrm share/pear/bootstrap/PEAR/Command
|
||||
%%CLI%%@dirrm share/pear/bootstrap/PEAR/Frontend
|
||||
%%CLI%%@dirrm share/pear/bootstrap/PEAR
|
||||
%%CLI%%@dirrm share/pear/bootstrap
|
||||
%%CLI%%@unexec rmdir %D/share/pear 2> /dev/null || true
|
||||
%%CLI%%%%PEAR%%@dirrm share/pear/bootstrap/Archive
|
||||
%%CLI%%%%PEAR%%@dirrm share/pear/bootstrap/Console
|
||||
%%CLI%%%%PEAR%%@dirrm share/pear/bootstrap/OS
|
||||
%%CLI%%%%PEAR%%@dirrm share/pear/bootstrap/PEAR/Command
|
||||
%%CLI%%%%PEAR%%@dirrm share/pear/bootstrap/PEAR/Frontend
|
||||
%%CLI%%%%PEAR%%@dirrm share/pear/bootstrap/PEAR
|
||||
%%CLI%%%%PEAR%%@dirrm share/pear/bootstrap
|
||||
%%CLI%%%%PEAR%%@unexec rmdir %D/share/pear 2> /dev/null || true
|
||||
|
|
|
@ -25,6 +25,7 @@ CDB "cdb database support (dba)" ${WITH_CDB:-OFF} \
|
|||
CRACK "crack support" ${WITH_CRACK:-OFF} \
|
||||
CTYPE "ctype functions" ${WITH_CTYPE:-OFF} \
|
||||
CURL "CURL support" ${WITH_CURL:-OFF} \
|
||||
DB4 "Berkeley DB4 support" ${WITH_DB4:-OFF} \
|
||||
DBASE "dBase library support" ${WITH_DBASE:-OFF} \
|
||||
DBX "dbx support" ${WITH_DBX:-OFF} \
|
||||
DOMXML "DOM support" ${WITH_DOMXML:-OFF} \
|
||||
|
@ -44,7 +45,7 @@ INIFILE "INI file support (dba)" ${WITH_INIFILE:-OFF} \
|
|||
INTERBASE "Interbase 6 database support (Firebird)" ${WITH_INTERBASE:-OFF} \
|
||||
MBSTRING "multibyte string support" ${WITH_MBSTRING:-OFF} \
|
||||
MCAL "Modular Calendar Access Library support" ${WITH_MCAL:-OFF} \
|
||||
MCVE "MCVE support" ${WITH_MCVE:-OFF} \
|
||||
MCVE "MCVE support (implies OPENSSL)" ${WITH_MCVE:-OFF} \
|
||||
MCRYPT "Encryption support" ${WITH_MCRYPT:-OFF} \
|
||||
MHASH "Crypto-hashing support" ${WITH_MHASH:-OFF} \
|
||||
MIME "mime_magic support" ${WITH_MIME:-OFF} \
|
||||
|
|
|
@ -5,6 +5,7 @@ WITH_CDB=OFF
|
|||
WITH_CRACK=OFF
|
||||
WITH_CTYPE=ON
|
||||
WITH_CURL=OFF
|
||||
WITH_DB4=OFF
|
||||
WITH_DBASE=OFF
|
||||
WITH_DBX=OFF
|
||||
WITH_DOMXML=OFF
|
||||
|
|
Loading…
Reference in a new issue