- New port math/octave-forge-level-set.
The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts. This is level-set.
This commit is contained in:
parent
5a05d1b1c8
commit
6ceff601d7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=379409
6 changed files with 53 additions and 0 deletions
|
@ -306,6 +306,7 @@
|
|||
SUBDIR += octave-forge-interval
|
||||
SUBDIR += octave-forge-io
|
||||
SUBDIR += octave-forge-irsa
|
||||
SUBDIR += octave-forge-level-set
|
||||
SUBDIR += octave-forge-linear-algebra
|
||||
SUBDIR += octave-forge-lssa
|
||||
SUBDIR += octave-forge-ltfat
|
||||
|
|
28
math/octave-forge-level-set/Makefile
Normal file
28
math/octave-forge-level-set/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# Created by: Stephen Montgomery-Smith <stephen@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= octave-forge-level-set
|
||||
PORTVERSION= 0.2.0
|
||||
CATEGORIES= math
|
||||
|
||||
MAINTAINER= stephen@FreeBSD.org
|
||||
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
ALL_TARGET= oct
|
||||
USES= compiler:c++0x
|
||||
|
||||
# OCTSRC is the name of the directory of the package.
|
||||
# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
|
||||
OCTSRC= ${OCTAVE_PKGNAME}
|
||||
|
||||
WRKSRC= ${WRKDIR}/${OCTSRC}/src
|
||||
|
||||
.include "${.CURDIR}/../../Mk/bsd.octave.mk"
|
||||
|
||||
post-build:
|
||||
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
|
||||
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
|
||||
|
||||
.include <bsd.port.mk>
|
2
math/octave-forge-level-set/distinfo
Normal file
2
math/octave-forge-level-set/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (octave-forge/level-set-0.2.0.tar.gz) = 1152e20bd84d12b031dab80320965d490289b25a9a9a0589ba171e8b1bea00b9
|
||||
SIZE (octave-forge/level-set-0.2.0.tar.gz) = 136521
|
10
math/octave-forge-level-set/files/patch-FastMarching.cpp
Normal file
10
math/octave-forge-level-set/files/patch-FastMarching.cpp
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- FastMarching.cpp-orig 2015-02-20 03:51:59.000000000 +0000
|
||||
+++ FastMarching.cpp 2015-02-20 03:52:16.000000000 +0000
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <cmath>
|
||||
#include <memory>
|
||||
#include <stdexcept>
|
||||
+#include <string>
|
||||
|
||||
namespace fastMarching
|
||||
{
|
11
math/octave-forge-level-set/pkg-descr
Normal file
11
math/octave-forge-level-set/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
The octave-forge package is the result of The GNU Octave Repositry project,
|
||||
which is intended to be a central location for custom scripts, functions and
|
||||
extensions for GNU Octave. contains the source for all the functions plus
|
||||
build and install scripts.
|
||||
|
||||
This is level-set.
|
||||
|
||||
Routines for calculating the time-evolution of the level-set equation and
|
||||
extracting geometric information from the level-set function.
|
||||
|
||||
WWW: http://octave.sourceforge.net/
|
1
math/octave-forge-level-set/pkg-plist
Normal file
1
math/octave-forge-level-set/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
@comment This file intentionally left empty
|
Loading…
Reference in a new issue