As previously announced, remove these expired ports.

Hat: portmgr.
This commit is contained in:
Mark Linimon 2005-07-18 03:40:11 +00:00
parent f14c154a56
commit 6cf9722c4f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=139453
19 changed files with 0 additions and 1017 deletions

View file

@ -1,16 +0,0 @@
# New ports collection makefile for: openldap21-client
# Date created: 10 Jul 2003
# Whom: Oliver Eikemeier <eikemeier@fillmore-labs.com>
#
# $FreeBSD$
#
PORTNAME= openldap
COMMENT= Open source LDAP client implementation
CLIENT_ONLY= yes
MASTERDIR= ${.CURDIR}/../openldap21-server
.include "${MASTERDIR}/Makefile"

View file

@ -1,17 +0,0 @@
# New ports collection makefile for: openldap21-sasl-client
# Date created: 01 May 2004
# Whom: Oliver Eikemeier
#
# $FreeBSD$
#
PORTNAME= openldap
COMMENT= Open source LDAP client implementation with SASL2 support
CLIENT_ONLY= yes
WITH_SASL= yes
MASTERDIR= ${.CURDIR}/../openldap21-server
.include "${MASTERDIR}/Makefile"

View file

@ -1,16 +0,0 @@
# New ports collection makefile for: openldap21-sasl-server
# Date created: 01 May 2004
# Whom: Oliver Eikemeier
#
# $FreeBSD$
#
PORTNAME= openldap
COMMENT= Open source LDAP server implementation with SASL2 support
WITH_SASL= yes
MASTERDIR= ${.CURDIR}/../openldap21-server
.include "${MASTERDIR}/Makefile"

View file

@ -1,342 +0,0 @@
# New ports collection makefile for: openldap21-server
# Date created: 10 Jul 2003
# Whom: Oliver Eikemeier
#
# $FreeBSD$
#
PORTNAME= openldap
PORTVERSION= 2.1.30
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
http://public.planetmirror.com/pub/openldap/%SUBDIR%/ \
ftp://gd.tuwien.ac.at/infosys/network/OpenLDAP/%SUBDIR%/ \
ftp://ftp.matrix.com.br/pub/openldap/%SUBDIR%/ \
ftp://ftp.ucr.ac.cr/pub/Unix/openldap/%SUBDIR%/ \
ftp://ftp.ntua.gr/mirror/OpenLDAP/%SUBDIR%/ \
ftp://ftp.shellhung.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/%SUBDIR%/ \
ftp://ftp.u-aizu.ac.jp/pub/net/openldap/%SUBDIR%/ \
ftp://ftp.holywar.net/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.nl.uu.net/pub/unix/db/openldap/%SUBDIR%/ \
ftp://ftp.linux.pt/pub/mirrors/OpenLDAP/%SUBDIR%/ \
ftp://ftp.rediris.es/mirror/OpenLDAP/%SUBDIR%/ \
ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/%SUBDIR%/ \
http://openldap.cdpa.nsysu.edu.tw/OpenLDAP/%SUBDIR%/ \
ftp://ftp.plig.org/pub/OpenLDAP/%SUBDIR%/
MASTER_SITE_SUBDIR= openldap-release
PKGNAMESUFFIX= ${OPENLDAP_PKGNAMESUFFIX}
EXTRACT_SUFX= .tgz
MAINTAINER= eik@FreeBSD.org
COMMENT?= Open source LDAP server implementation
DEPRECATED= EOL, no longer actively maintained by the OpenLDAP Project. Please use OpenLDAP 2.2 instead
EXPIRATION_DATE= 2005-03-01
LATEST_LINK= ${PKGNAMEPREFIX}openldap21${PKGNAMESUFFIX}
WANT_OPENLDAP_VER?= 21
.if ${WANT_OPENLDAP_VER} != 21
BROKEN= "incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}"
.endif
PORTREVISION_CLIENT= 0
PORTREVISION_SERVER= 0
PKGNAMESUFFIX_CLIENT= -client
PKGNAMESUFFIX_SERVER= -server
.if defined(CLIENT_ONLY)
OPENLDAP_PORTREVISION= ${PORTREVISION_CLIENT}
OPENLDAP_PKGNAMESUFFIX= ${PKGNAMESUFFIX_CLIENT}
OPENLDAP_PKGFILESUFX= .client
.if defined(WITH_SASL)
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.[!1].*
.else
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.[!1].* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-client-2.*
.endif
.if !defined(NOPORTDOCS)
PORTDOCS= drafts rfc
.endif
.if defined(USE_OPENLDAP)
.error You have `USE_OPENLDAP' defined either in your environment or in make(1) arguments.
.endif
.else
OPENLDAP_PORTREVISION= ${PORTREVISION_SERVER}
OPENLDAP_PKGNAMESUFFIX= ${PKGNAMESUFFIX_SERVER}
OPENLDAP_PKGFILESUFX=
.if defined(WITH_SASL)
RUN_DEPENDS= ${LOCALBASE}/lib/libldap.so.2:${PORTSDIR}/net/openldap21-sasl-client
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-server-2.* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.[!1].*
.else
RUN_DEPENDS= ${LOCALBASE}/lib/libldap.so.2:${PORTSDIR}/net/openldap21-client
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-server-2.[!1].* \
${PKGNAMEPREFIX}${PORTNAME}-sasl-server-2.*
.endif
.if ${PORTREVISION_CLIENT} != 0
SUF1_CLIENT= _${PORTREVISION_CLIENT}
.endif
PKGNAME_CLIENT= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX_CLIENT}-${PORTVERSION}${SUF1_CLIENT}
.endif
USE_OPENSSL= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
DESCR= ${PKGDIR}/pkg-descr${OPENLDAP_PKGFILESUFX}
PLIST= ${PKGDIR}/pkg-plist${OPENLDAP_PKGFILESUFX}
PKGINSTALL= ${WRKDIR}/pkg-install
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SCHEMATA= corba core cosine \
inetorgperson java \
misc nis openldap
LDAP_RUN_DIR?= ${DESTDIR}/var/run/openldap
LOCALSTATEDIR?= ${DESTDIR}/var/db
DATABASEDIR?= ${LOCALSTATEDIR}/openldap-data
SLURPDIR?= ${LOCALSTATEDIR}/openldap-slurp
PLIST_SUB+= LDAP_RUN_DIR=${LDAP_RUN_DIR} \
DATABASEDIR=${DATABASEDIR} \
SLURPDIR=${SLURPDIR} \
SED_SCRIPT= -e 's,%%PKGNAME%%,${PKGNAME},g' \
-e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%LDAP_RUN_DIR%%,${LDAP_RUN_DIR},g' \
-e 's,%%DATABASEDIR%%,${DATABASEDIR},g' \
-e 's,%%SLURPDIR%%,${SLURPDIR},g'
CONFIGURE_ARGS= --with-threads=posix \
--with-tls=openssl \
--enable-dynamic
.if defined(WITH_SASL)
PKGNAMESUFFIX_CLIENT:= -sasl${PKGNAMESUFFIX_CLIENT}
PKGNAMESUFFIX_SERVER:= -sasl${PKGNAMESUFFIX_SERVER}
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
CONFIGURE_ARGS+= --with-cyrus-sasl
.else
CONFIGURE_ARGS+= --without-cyrus-sasl
.endif
.if defined(CLIENT_ONLY)
# client specific configuration
CONFIGURE_ARGS+= --disable-slapd
INSTALLS_SHLIB= yes
.else
# server specific configuration
USE_RC_SUBR= yes
SED_SCRIPT+= -e 's,%%PKGNAME_CLIENT%%,${PKGNAME_CLIENT:R}.*,g' \
-e 's,%%RC_SUBR%%,${RC_SUBR},g' \
-e 's,%%RC_DIR%%,${RC_DIR},g' \
-e 's,%%RC_SUFX%%,${RC_SUFX},g'
PLIST_SUB+= RC_DIR=${RC_DIR} \
RC_SUFX=${RC_SUFX}
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-Makefile.in
CONFIGURE_ARGS+= --localstatedir=${LOCALSTATEDIR} \
--enable-ldbm \
--enable-crypt \
--enable-lmpasswd \
--enable-ldap \
--enable-meta \
--enable-rewrite \
--enable-null \
--enable-monitor
.if defined(WITHOUT_BDB)
CONFIGURE_ARGS+= --with-ldbm-api=bcompat \
--disable-bdb
.else
WITH_BDB_VER?= 41
.if ${WITH_BDB_VER} == 42
CONFIGURE_ARGS+= --enable-bdb
BDBLIB= db-4.2.2
.elif ${WITH_BDB_VER} == 41
CONFIGURE_ARGS+= --enable-bdb
BDBLIB= db41.1
.elif ${WITH_BDB_VER} == 4
CONFIGURE_ARGS+= --disable-bdb
BDBLIB= db4.0
.elif ${WITH_BDB_VER} == 3
CONFIGURE_ARGS+= --disable-bdb
BDBLIB= db3.3
.else
.error WITH_BDB_VER must be 3, 4, 41 or 42
.endif
LIB_DEPENDS+= ${BDBLIB}:${PORTSDIR}/databases/db${WITH_BDB_VER}
CPPFLAGS+= -I${LOCALBASE}/include/db${WITH_BDB_VER}
CONFIGURE_ARGS+= --with-ldbm-api=berkeley
CONFIGURE_SED+= -e 's,ol_DB_LIB=$$,&-l${BDBLIB:R},' \
-e 's,(ol_cv_lib_db=)yes$$,\1-l${BDBLIB:R},'
.endif
.if defined(WITH_SHELL)
CONFIGURE_ARGS+= --enable-shell
.endif
.if defined(WITH_PERL)
USE_PERL5= yes
CONFIGURE_ARGS+= --enable-perl
.endif
.if defined(WITH_SASL)
CONFIGURE_ARGS+= --enable-spasswd
.endif
.if defined(WITH_ODBC)
WITH_ODBC_TYPE?= iODBC
.endif
.if defined(WITH_ODBC_TYPE)
CONFIGURE_ARGS+= --enable-sql
.if ${WITH_ODBC_TYPE:L} == iodbc
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
.elif ${WITH_ODBC_TYPE:L} == unixodbc
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
.else
.error WITH_ODBC_TYPE must be iODBC or unixODBC
.endif
.endif
# Include tcp-wrapper support
.if !defined(WITHOUT_TCP_WRAPPERS) && exists(/usr/include/tcpd.h)
CONFIGURE_ARGS+= --enable-wrappers
.endif
# end of client/server specific configuration
.endif
CPPFLAGS+= ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
#LIBS+= ${PTHREAD_LIBS}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
LIBS="${LIBS}"
.include <bsd.port.pre.mk>
.if defined(CLIENT_ONLY)
.include "${FILESDIR}/manpages"
.else
.if ${OSVERSION} >= 500038
RC_DIR= ${DESTDIR}/etc/rc.d
RC_SUFX=
.else
RC_DIR= ${PREFIX}/etc/rc.d
RC_SUFX= .sh
.endif
.endif
pre-everything::
@${ECHO} "============================================================="
@${ECHO}
@${ECHO} "You can build ${PKGNAME} with the following options:"
@${ECHO}
.if defined(CLIENT_ONLY)
@${ECHO} "WITH_SASL with (Cyrus) SASL2 support"
.else
@${ECHO} "WITH_BDB_VER select BerkeleyDB version (default 41)"
@${ECHO} "WITH_SASL with (Cyrus) SASL2 password verification"
@${ECHO} "WITH_PERL with Perl backend"
@${ECHO} "WITH_SHELL with Shell backend"
@${ECHO} "WITH_ODBC with SQL backend"
@${ECHO} "WITH_ODBC_TYPE select ODBC interface (iODBC or unixODBC)"
@${ECHO} "WITHOUT_TCP_WRAPPERS without tcp wrapper support"
@${ECHO} "WITHOUT_BDB without BerkeleyDB support"
.endif
@${ECHO}
@${ECHO} "============================================================="
@${ECHO}
post-patch:
@${REINPLACE_CMD} -e 's,%LOCALSTATEDIR%/slapd\.,${LDAP_RUN_DIR}/slapd.,g' \
${WRKSRC}/servers/slapd/slapd.conf
.if defined(CONFIGURE_SED)
@${REINPLACE_CMD} -E ${CONFIGURE_SED} \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
pre-configure:
@if [ -n "`${PKG_INFO} -xI '^bind\(84\)\{0,1\}-base-8\.' 2>/dev/null`" ]; then \
${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
${FALSE}; \
fi
post-build:
.for script in slapd slurpd
@${SED} ${SED_SCRIPT} ${FILESDIR}/${script}.sh >${WRKDIR}/${script}.sh
.endfor
.for text in pkg-install pkg-message pkg-deinstall
@if [ -f ${PKGDIR}/${text}${OPENLDAP_PKGFILESUFX} ]; then \
${SED} ${SED_SCRIPT} ${PKGDIR}/${text}${OPENLDAP_PKGFILESUFX} \
>${WRKDIR}/${text}; \
fi
.endfor
.if !defined(CLIENT_ONLY)
test: build
@cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
.endif
pre-install:
@if [ -f ${PKGINSTALL} ]; then \
${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL; \
fi
post-install:
.if defined(CLIENT_ONLY)
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@for dir in drafts rfc; do \
${MKDIR} ${DOCSDIR}/$${dir}; \
${INSTALL_DATA} ${WRKSRC}/doc/$${dir}/* ${DOCSDIR}/$${dir}; \
done
.endif
.else
@for schema in ${SCHEMATA}; do \
${ECHO_CMD} "@unexec if cmp -s %D/etc/openldap/schema/$${schema}.schema" \
"%D/etc/openldap/schema/$${schema}.schema.default; then" \
"rm -f %D/etc/openldap/schema/$${schema}.schema; fi" >>${TMPPLIST}; \
${ECHO_CMD} "etc/openldap/schema/$${schema}.schema.default" >>${TMPPLIST}; \
${ECHO_CMD} "@exec [ -f %B/$${schema}.schema ] || cp %B/%f %B/$${schema}.schema" >>${TMPPLIST}; \
done
@${ECHO_CMD} "@unexec rmdir %D/etc/openldap/schema 2>/dev/null || true" >>${TMPPLIST}
@${ECHO_CMD} "@unexec rmdir %D/etc/openldap 2>/dev/null || true" >>${TMPPLIST}
# currently the only way to participate in rcorder(8)
@if [ "${RC_DIR}" != "${PREFIX}" ]; then \
${ECHO_CMD} "@cwd ${RC_DIR}" >>${TMPPLIST}; \
fi
.for script in slapd slurpd
@${INSTALL_SCRIPT} ${WRKDIR}/${script}.sh ${RC_DIR}/${script}${RC_SUFX}
@${ECHO_CMD} "${script}${RC_SUFX}" >>${TMPPLIST}
.endfor
@${MKDIR} ${LDAP_RUN_DIR}
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View file

@ -1,2 +0,0 @@
MD5 (openldap-2.1.30.tgz) = e2ae8148c4bed07d7a70edd930bdc403
SIZE (openldap-2.1.30.tgz) = 2044673

View file

@ -1,17 +0,0 @@
--- Makefile.in.orig Mon Apr 7 22:23:24 2003
+++ Makefile.in Thu Jul 10 17:43:35 2003
@@ -10,9 +10,11 @@
## in file LICENSE in the top-level directory of the distribution.
##
-SUBDIRS= include libraries clients servers tests doc
-CLEANDIRS=
-INSTALLDIRS=
+SUBDIRS=
+ALLDIRS= include libraries clients servers tests doc
+CLEANDIRS= include libraries clients servers tests doc
+DEPENDDIRS= include libraries clients servers tests doc
+INSTALLDIRS= servers
makefiles: FORCE
./config.status

View file

@ -1,190 +0,0 @@
#
# $FreeBSD$
#
MAN1+= ldapcompare.1 \
ldapdelete.1 \
ldapmodify.1 \
ldapmodrdn.1 \
ldappasswd.1 \
ldapsearch.1 \
ldapwhoami.1
MLINKS+= \
ldapmodify.1 ldapadd.1
MAN3+= lber-decode.3 \
lber-encode.3 \
lber-memory.3 \
lber-types.3 \
ldap.3 \
ldap_abandon.3 \
ldap_add.3 \
ldap_bind.3 \
ldap_compare.3 \
ldap_delete.3 \
ldap_error.3 \
ldap_first_attribute.3 \
ldap_first_entry.3 \
ldap_first_message.3 \
ldap_first_reference.3 \
ldap_get_dn.3 \
ldap_get_values.3 \
ldap_modify.3 \
ldap_modrdn.3 \
ldap_open.3 \
ldap_parse_reference.3 \
ldap_parse_result.3 \
ldap_result.3 \
ldap_schema.3 \
ldap_search.3 \
ldap_sort.3 \
ldap_url.3
MLINKS+= \
lber-decode.3 ber_first_element.3 \
lber-decode.3 ber_get_bitstring.3 \
lber-decode.3 ber_get_boolean.3 \
lber-decode.3 ber_get_enum.3 \
lber-decode.3 ber_get_int.3 \
lber-decode.3 ber_get_next.3 \
lber-decode.3 ber_get_null.3 \
lber-decode.3 ber_get_stringa.3 \
lber-decode.3 ber_get_stringb.3 \
lber-decode.3 ber_next_element.3 \
lber-decode.3 ber_peek_tag.3 \
lber-decode.3 ber_scanf.3 \
lber-decode.3 ber_skip_tag.3 \
lber-encode.3 ber_alloc_t.3 \
lber-encode.3 ber_flush.3 \
lber-encode.3 ber_printf.3 \
lber-encode.3 ber_put_enum.3 \
lber-encode.3 ber_put_int.3 \
lber-encode.3 ber_put_null.3 \
lber-encode.3 ber_put_ostring.3 \
lber-encode.3 ber_put_seq.3 \
lber-encode.3 ber_put_set.3 \
lber-encode.3 ber_put_string.3 \
lber-encode.3 ber_start_set.3 \
lber-types.3 ber_bvarray_add.3 \
lber-types.3 ber_bvarray_free.3 \
lber-types.3 ber_bvdup.3 \
lber-types.3 ber_bvecadd.3 \
lber-types.3 ber_bvecfree.3 \
lber-types.3 ber_bvfree.3 \
lber-types.3 ber_bvstr.3 \
lber-types.3 ber_bvstrdup.3 \
lber-types.3 ber_dupbv.3 \
lber-types.3 ber_free.3 \
lber-types.3 ber_str2bv.3 \
ldap_abandon.3 ldap_abandon_ext.3 \
ldap_add.3 ldap_add_ext.3 \
ldap_add.3 ldap_add_ext_s.3 \
ldap_add.3 ldap_add_s.3 \
ldap_bind.3 ldap_bind_s.3 \
ldap_bind.3 ldap_kerberos_bind1.3 \
ldap_bind.3 ldap_kerberos_bind1_s.3 \
ldap_bind.3 ldap_kerberos_bind2.3 \
ldap_bind.3 ldap_kerberos_bind2_s.3 \
ldap_bind.3 ldap_kerberos_bind_s.3 \
ldap_bind.3 ldap_sasl_bind.3 \
ldap_bind.3 ldap_sasl_bind_s.3 \
ldap_bind.3 ldap_simple_bind.3 \
ldap_bind.3 ldap_simple_bind_s.3 \
ldap_bind.3 ldap_unbind.3 \
ldap_bind.3 ldap_unbind_ext.3 \
ldap_bind.3 ldap_unbind_ext_s.3 \
ldap_bind.3 ldap_unbind_s.3 \
ldap_compare.3 ldap_compare_ext.3 \
ldap_compare.3 ldap_compare_ext_s.3 \
ldap_compare.3 ldap_compare_s.3 \
ldap_delete.3 ldap_delete_ext.3 \
ldap_delete.3 ldap_delete_ext_s.3 \
ldap_delete.3 ldap_delete_s.3 \
ldap_error.3 ld_errno.3 \
ldap_error.3 ldap_err2string.3 \
ldap_error.3 ldap_errlist.3 \
ldap_error.3 ldap_perror.3 \
ldap_error.3 ldap_result2error.3 \
ldap_first_attribute.3 ldap_next_attribute.3 \
ldap_first_entry.3 ldap_count_entries.3 \
ldap_first_entry.3 ldap_next_entry.3 \
ldap_first_message.3 ldap_count_messages.3 \
ldap_first_message.3 ldap_next_message.3 \
ldap_first_reference.3 ldap_count_references.3 \
ldap_first_reference.3 ldap_next_reference.3 \
ldap_get_dn.3 ldap_dcedn2dn.3 \
ldap_get_dn.3 ldap_dn2ad_canonical.3 \
ldap_get_dn.3 ldap_dn2dcedn.3 \
ldap_get_dn.3 ldap_dn2str.3 \
ldap_get_dn.3 ldap_dn2ufn.3 \
ldap_get_dn.3 ldap_explode_dn.3 \
ldap_get_dn.3 ldap_explode_rdn.3 \
ldap_get_dn.3 ldap_str2dn.3 \
ldap_get_values.3 ldap_count_values.3 \
ldap_get_values.3 ldap_count_values_len.3 \
ldap_get_values.3 ldap_get_values_len.3 \
ldap_get_values.3 ldap_value_free.3 \
ldap_get_values.3 ldap_value_free_len.3 \
ldap_modify.3 ldap_modify_ext.3 \
ldap_modify.3 ldap_modify_ext_s.3 \
ldap_modify.3 ldap_modify_s.3 \
ldap_modify.3 ldap_mods_free.3 \
ldap_modrdn.3 ldap_modrdn2.3 \
ldap_modrdn.3 ldap_modrdn2_s.3 \
ldap_modrdn.3 ldap_modrdn_s.3 \
ldap_open.3 ldap_init.3 \
ldap_parse_result.3 ldap_parse_extended_result.3 \
ldap_parse_result.3 ldap_parse_sasl_bind_result.3 \
ldap_result.3 ldap_msgfree.3 \
ldap_result.3 ldap_msgid.3 \
ldap_result.3 ldap_msgtype.3 \
ldap_schema.3 ldap_attributetype2name.3 \
ldap_schema.3 ldap_attributetype2str.3 \
ldap_schema.3 ldap_attributetype_free.3 \
ldap_schema.3 ldap_matchingrule2name.3 \
ldap_schema.3 ldap_matchingrule2str.3 \
ldap_schema.3 ldap_matchingrule_free.3 \
ldap_schema.3 ldap_objectclass2name.3 \
ldap_schema.3 ldap_objectclass2str.3 \
ldap_schema.3 ldap_objectclass_free.3 \
ldap_schema.3 ldap_scherr2str.3 \
ldap_schema.3 ldap_str2attributetype.3 \
ldap_schema.3 ldap_str2matchingrule.3 \
ldap_schema.3 ldap_str2objectclass.3 \
ldap_schema.3 ldap_str2syntax.3 \
ldap_schema.3 ldap_syntax2name.3 \
ldap_schema.3 ldap_syntax2str.3 \
ldap_schema.3 ldap_syntax_free.3 \
ldap_search.3 ldap_search_ext.3 \
ldap_search.3 ldap_search_ext_s.3 \
ldap_search.3 ldap_search_s.3 \
ldap_search.3 ldap_search_st.3 \
ldap_sort.3 ldap_sort_entries.3 \
ldap_sort.3 ldap_sort_strcasecmp.3 \
ldap_sort.3 ldap_sort_values.3 \
ldap_url.3 ldap_free_urldesc.3 \
ldap_url.3 ldap_is_ldap_url.3 \
ldap_url.3 ldap_url_parse.3
MAN5+= ldap.conf.5 \
ldif.5 \
slapd-bdb.5 \
slapd-dnssrv.5 \
slapd-ldap.5 \
slapd-ldbm.5 \
slapd-meta.5 \
slapd-null.5 \
slapd-passwd.5 \
slapd-perl.5 \
slapd-shell.5 \
slapd-sql.5 \
slapd-tcl.5 \
slapd.access.5 \
slapd.conf.5 \
slapd.replog.5
MAN8+= slapadd.8 \
slapcat.8 \
slapd.8 \
slapindex.8 \
slappasswd.8 \
slurpd.8

View file

@ -1,46 +0,0 @@
--- build/ltmain.sh.orig Mon Feb 10 20:24:24 2003
+++ build/ltmain.sh Sun Mar 28 19:11:24 2004
@@ -1066,7 +1066,7 @@
esac
elif test "X$arg" = "X-lc_r"; then
case $host in
- *-*-openbsd* | *-*-freebsd*)
+ *-*-openbsd* | *-*-freebsd4*)
# Do not include libc_r directly, use -pthread flag.
continue
;;
@@ -1078,6 +1078,12 @@
-module)
module=yes
+ case $host in
+ *-*-freebsd*)
+ # Do not build the useless static library
+ build_old_libs=no
+ ;;
+ esac
continue
;;
@@ -4286,10 +4292,17 @@
fi
# Install the pseudo-library for information purposes.
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
+ case $host in
+ *-*-freebsd*)
+ # Do not install the useless pseudo-library
+ ;;
+ *)
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
+ ;;
+ esac
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -1,20 +0,0 @@
--- configure.orig Wed Apr 14 23:11:09 2004
+++ configure Wed May 5 12:45:52 2004
@@ -20586,7 +20586,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-liodbc $LIBS"
+LIBS="-liodbc $LIBS $LTHREAD_LIBS"
cat > conftest.$ac_ext <<EOF
#line 20592 "configure"
#include "confdefs.h"
@@ -20630,7 +20630,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lodbc $LIBS"
+LIBS="-lodbc $LIBS $LTHREAD_LIBS"
cat > conftest.$ac_ext <<EOF
#line 20636 "configure"
#include "confdefs.h"

View file

@ -1,103 +0,0 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: slapd
# REQUIRE: NETWORKING SERVERS
# BEFORE: DAEMON
# KEYWORD: FreeBSD shutdown
#
# Add the following lines to /etc/rc.conf to enable slapd:
#
#slapd_enable="YES"
#slapd_flags='-h "ldapi://%2fvar%2frun%2fopenldap%2fldapi/ ldap://0.0.0.0/"'
#slapd_sockets="/var/run/openldap/ldapi"
#
# See slapd(8) for more flags
#
# The `-u' and `-g' flags are automatically extracted from slapd_owner,
# by default slapd runs under the non-privileged user id `ldap'. If you
# want to run slapd as root, override this in /etc/rc.conf with
#
#slapd_owner="DEFAULT"
#
. %%RC_SUBR%%
name=slapd
rcvar=`set_rcvar`
command=%%PREFIX%%/libexec/slapd
pidfile=%%LDAP_RUN_DIR%%/slapd.pid
required_dirs=%%LDAP_RUN_DIR%%
required_files=%%PREFIX%%/etc/openldap/slapd.conf
start_precmd=start_precmd
start_postcmd=start_postcmd
# extract user and group, adjust ownership of directories and database
start_precmd()
{
case x"$slapd_owner" in
x|x[Nn][Oo][Nn][Ee]|x[Dd][Ee][Ff][Aa][Uu][Ll][Tt])
;;
x*)
chown "$slapd_owner" "%%LDAP_RUN_DIR%%"
chown -RL "$slapd_owner" "%%DATABASEDIR%%"
chown "$slapd_owner" "%%PREFIX%%/etc/openldap/slapd.conf"
slapd_ownername=`expr //"$slapd_owner" : //'\([^:]*\)'`
slapd_groupname=`expr //"$slapd_owner" : //'.*:\([^:]*\)'`
if [ -n "$slapd_ownername" ]; then
rc_flags="$rc_flags -u $slapd_ownername"
fi
if [ -n "$slapd_groupname" ]; then
rc_flags="$rc_flags -g $slapd_groupname"
fi
;;
esac
}
# adjust ownership of created unix sockets
start_postcmd()
{
for socket in $slapd_sockets; do
for seconds in 1 2 3 4 5; do
[ -e "$socket" ] && break
sleep 1
done
if [ -S "$socket" ]; then
case x"$slapd_owner" in
x|x[Nn][Oo][Nn][Ee]|x[Dd][Ee][Ff][Aa][Uu][Ll][Tt])
;;
x*)
chown "$slapd_owner" "$socket"
;;
esac
chmod "$slapd_sockets_mode" "$socket"
fi
done
}
# set defaults
[ -z "$slapd_enable" ] && slapd_enable=NO
[ -z "$slapd_flags" ] && slapd_flags=
[ -z "$slapd_owner" ] && slapd_owner=ldap:ldap
[ -z "$slapd_sockets" ] && slapd_sockets=
[ -z "$slapd_sockets_mode" ] && slapd_sockets_mode=666
load_rc_config $name
if [ -n "$slapd_args" ]; then
warn "slapd_args is deprecated, use slapd_flags"
slapd_flags="$slapd_args"
fi
run_rc_command "$1"

View file

@ -1,36 +0,0 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: slurpd
# REQUIRE: slapd
# BEFORE:
# KEYWORD: FreeBSD shutdown
# Add the following line to /etc/rc.conf to enable slurpd:
#
#slurpd_enable="YES"
#
# See slurpd(8) for more flags
#
. %%RC_SUBR%%
name=slurpd
rcvar=`set_rcvar`
command=%%PREFIX%%/libexec/slurpd
required_files=%%PREFIX%%/etc/openldap/slapd.conf
[ -z "$slurpd_enable" ] && slurpd_enable="NO"
[ -z "$slurpd_flags" ] && slurpd_flags=
load_rc_config $name
if [ -n "$slurpd_args" ]; then
warn "slurpd_args is deprecated, use slurpd_flags"
slurpd_flags="$slurpd_args"
fi
run_rc_command "$1"

View file

@ -1,33 +0,0 @@
#!/bin/sh
#
# $FreeBSD$
#
ECHO_CMD=echo
case $2 in
POST-DEINSTALL)
${ECHO_CMD}
${ECHO_CMD} "The OpenLDAP server package has been deleted."
${ECHO_CMD} "If you're *not* upgrading and won't be using"
${ECHO_CMD} "it any longer, you may want to issue the"
${ECHO_CMD} "following commands:"
${ECHO_CMD}
if [ -d %%DATABASEDIR%% ]; then
${ECHO_CMD} "- to delete the OpenLDAP database permanently (losing all data):"
${ECHO_CMD} " rm -Rf %%DATABASEDIR%%"
${ECHO_CMD}
fi
if [ -d %%SLURPDIR%% ]; then
${ECHO_CMD} "- to remove the OpenLDAP replication directory:"
${ECHO_CMD} " rm -Rf %%SLURPDIR%%"
${ECHO_CMD}
fi
${ECHO_CMD} "- to remove the OpenLDAP user:"
${ECHO_CMD} " pw userdel ldap"
${ECHO_CMD}
${ECHO_CMD} "If you are upgrading, don't forget to restart"
${ECHO_CMD} "slapd and slurpd."
${ECHO_CMD}
;;
esac

View file

@ -1,15 +0,0 @@
OpenLDAP is a suite of Lightweight Directory Access Protocol (v3) servers,
clients, utilities and development tools.
This package includes the following major components:
* slapd - a stand-alone LDAP directory server
* slurpd - a stand-alone LDAP replication server
* LDIF tools - data conversion tools for use with slapd
This is the latest release of OpenLDAP Software for general use.
WWW: http://www.OpenLDAP.org/
- Oliver Eikemeier
eikemeier@fillmore-labs.com

View file

@ -1,16 +0,0 @@
OpenLDAP is a suite of Lightweight Directory Access Protocol (v3) servers,
clients, utilities and development tools.
This package includes the following major components:
* -lldap - a LDAP client library
* -llber - a lightweight BER/DER encoding/decoding library
* LDAP tools - A collection of command line LDAP utilities
* documentation - man pages for all components
This is the latest release of OpenLDAP Software for general use.
WWW: http://www.OpenLDAP.org/
- Oliver Eikemeier
eikemeier@fillmore-labs.com

View file

@ -1,50 +0,0 @@
#!/bin/sh
#
# $FreeBSD$
#
CHOWN=/usr/sbin/chown
ECHO_CMD=echo
GREP=/usr/bin/grep
PKG_INFO=/usr/sbin/pkg_info
PW=/usr/sbin/pw
FTPUSERS=/etc/ftpusers
case $2 in
PRE-INSTALL)
if [ -z "`${PKG_INFO} -I '%%PKGNAME_CLIENT%%' 2> /dev/null`" ]; then
${ECHO_CMD} "===> %%PKGNAME%% requires %%PKGNAME_CLIENT%%."
${ECHO_CMD}
${ECHO_CMD} " Please install %%PKGNAME_CLIENT%% manually."
exit 1
fi
if ! ${PW} usershow -n ldap >/dev/null 2>&1; then
${ECHO_CMD}
if ! ${PW} groupshow -n ldap >/dev/null 2>&1; then
if ! ${PW} groupadd -n ldap -g 389; then
${ECHO_CMD} "*** Failed to add a group ldap with id 389."
${ECHO_CMD}
${ECHO_CMD} "Please add the ldap user manually with"
${ECHO_CMD} " ${PW} useradd -n ldap -g ldap -c 'OpenLDAP server' \\"
${ECHO_CMD} " -d /nonexistent -s /sbin/nologin -h -"
${ECHO_CMD} "and retry installing this package."
exit 1
fi
${ECHO_CMD} "===> Group 'ldap' created."
fi
if ! ${PW} useradd -n ldap -u 389 -g ldap -c 'OpenLDAP Server' \
-d /nonexistent -s /sbin/nologin -h -; then
${ECHO_CMD} "*** Failed to add an user ldap with id 389."
${ECHO_CMD}
${ECHO_CMD} "Please add the ldap user manually with"
${ECHO_CMD} " ${PW} useradd -n ldap -g ldap -c 'OpenLDAP server' \\"
${ECHO_CMD} " -d /nonexistent -s /sbin/nologin -h -"
${ECHO_CMD} "and retry installing this package."
exit 1
fi
${GREP} -qs '^ldap$' ${FTPUSERS} || ${ECHO_CMD} ldap >> ${FTPUSERS}
${ECHO_CMD} "===> Account 'ldap' created."
fi
;;
esac

View file

@ -1,28 +0,0 @@
************************************************************
The OpenLDAP server package has been successfully installed.
In order to run the LDAP server, you need to edit
%%PREFIX%%/etc/openldap/slapd.conf
to suit your needs and add the following lines to /etc/rc.conf:
slapd_enable="YES"
slapd_flags='-h "ldapi://%2fvar%2frun%2fopenldap%2fldapi/ ldap://0.0.0.0/"'
slapd_sockets="/var/run/openldap/ldapi"
Then start the server with
%%RC_DIR%%/slapd%%RC_SUFX%% start
or reboot.
Try `man slapd' and the online manual at
http://www.OpenLDAP.org/doc/admin21/
for more information.
NOTE: Some variable names have been changed to conform with rc.subr(8)
If you are upgrading, you may want to check your configuration with
grep ^slapd_ /etc/rc.conf
slapd runs under a non-privileged user id (by default `ldap'),
see %%RC_DIR%%/slapd%%RC_SUFX%% for more information.
************************************************************

View file

@ -1,13 +0,0 @@
************************************************************
The OpenLDAP client package has been successfully installed.
Edit
%%PREFIX%%/etc/openldap/ldap.conf
to change the system-wide client defaults.
Try `man ldap.conf' and visit the OpenLDAP FAQ-O-Matic at
http://www.OpenLDAP.org/faq/index.cgi?file=3
for more information.
************************************************************

View file

@ -1,19 +0,0 @@
@comment $FreeBSD$
@unexec %%RC_DIR%%/slapd%%RC_SUFX%% stop 2>&1 >/dev/null || true
@unexec %%RC_DIR%%/slurpd%%RC_SUFX%% stop 2>&1 >/dev/null || true
etc/openldap/schema/README
@unexec if cmp -s %D/etc/openldap/slapd.conf %D/etc/openldap/slapd.conf.default; then rm -f %D/etc/openldap/slapd.conf; fi
etc/openldap/slapd.conf.default
@exec [ -f %B/slapd.conf ] || cp %B/%f %B/slapd.conf
libexec/slapd
libexec/slurpd
sbin/slapadd
sbin/slapcat
sbin/slapindex
sbin/slappasswd
@exec mkdir -p %%LDAP_RUN_DIR%%
@unexec rmdir %%LDAP_RUN_DIR%% 2>/dev/null || true
@exec mkdir -p %%DATABASEDIR%%
@unexec rmdir %%DATABASEDIR%% 2>/dev/null || true
@exec mkdir -p %%SLURPDIR%%
@unexec rmdir %%SLURPDIR%% 2>/dev/null || true

View file

@ -1,38 +0,0 @@
@comment $FreeBSD$
bin/ldapadd
bin/ldapcompare
bin/ldapdelete
bin/ldapmodify
bin/ldapmodrdn
bin/ldappasswd
bin/ldapsearch
bin/ldapwhoami
@unexec if cmp -s %D/etc/openldap/ldap.conf %D/etc/openldap/ldap.conf.default; then rm -f %D/etc/openldap/ldap.conf; fi
etc/openldap/ldap.conf.default
@exec [ -f %B/ldap.conf ] || cp %B/%f %B/ldap.conf
@unexec rmdir %D/etc/openldap 2>/dev/null || true
include/lber.h
include/lber_types.h
include/ldap.h
include/ldap_cdefs.h
include/ldap_features.h
include/ldap_schema.h
include/ldap_utf8.h
lib/liblber.a
lib/liblber.so
lib/liblber.so.2
lib/libldap.a
lib/libldap.so
lib/libldap.so.2
lib/libldap_r.a
lib/libldap_r.so
lib/libldap_r.so.2
share/openldap/ucdata/case.dat
share/openldap/ucdata/cmbcl.dat
share/openldap/ucdata/comp.dat
share/openldap/ucdata/ctype.dat
share/openldap/ucdata/decomp.dat
share/openldap/ucdata/kdecomp.dat
share/openldap/ucdata/num.dat
@dirrm share/openldap/ucdata
@dirrm share/openldap