Fix build on amd64 [1].

Fix build with debug option [2].

Submitted by:  Marcin Cieslak <saper@system.pl> (will be SCAed) [1], [2]
               Andrew Reilly <areilly@bigpond.net.au> [2]
PR: 122627 [2]
Issue: http://qa.openoffice.org/issues/show_bug.cgi?id=88156 [2]
       http://qa.openoffice.org/issues/show_bug.cgi?id=88160 [2]
This commit is contained in:
Maho Nakata 2008-04-12 07:39:16 +00:00
parent 8406cf7754
commit 6d24c5d1f7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=211114
6 changed files with 130 additions and 24 deletions

View file

@ -1,7 +1,12 @@
Merge from Linux CWS pj87 (#i83022#: Make bridges warning free)
Update to newest cpp-uno bridge from Linux x86-64.
Index: bridges/source/cpp_uno/gcc3_freebsd_x86-64/abi.cxx
===================================================================
RCS file: /cvs/udk/bridges/source/cpp_uno/gcc3_freebsd_x86-64/abi.cxx,v
retrieving revision 1.3
diff -u -r1.3 abi.cxx
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/abi.cxx 16 Sep 2006 15:46:23 -0000 1.3
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/abi.cxx 8 Jan 2008 16:57:00 -0000
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/abi.cxx 12 Apr 2008 00:10:44 -0000
@@ -358,6 +358,8 @@
case X86_64_SSEDF_CLASS:
*pStructAlign++ = *reinterpret_cast<sal_uInt64 *>( *pSSE++ );
@ -11,8 +16,13 @@ Merge from Linux CWS pj87 (#i83022#: Make bridges warning free)
}
}
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/cpp2uno.cxx 16 Sep 2006 15:46:37 -0000 1.3
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/cpp2uno.cxx 8 Jan 2008 16:57:00 -0000
Index: bridges/source/cpp_uno/gcc3_freebsd_x86-64/cpp2uno.cxx
===================================================================
RCS file: /cvs/udk/bridges/source/cpp_uno/gcc3_freebsd_x86-64/cpp2uno.cxx,v
retrieving revision 1.4
diff -u -r1.4 cpp2uno.cxx
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/cpp2uno.cxx 27 Feb 2008 09:49:58 -0000 1.4
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/cpp2uno.cxx 12 Apr 2008 00:10:44 -0000
@@ -82,8 +82,8 @@
void ** gpreg, void ** fpreg, void ** ovrflw,
sal_uInt64 * pRegisterReturn /* space for register return */ )
@ -24,17 +34,21 @@ Merge from Linux CWS pj87 (#i83022#: Make bridges warning free)
// return
typelib_TypeDescription * pReturnTypeDescr = 0;
@@ -492,7 +492,7 @@
unsigned char * bridges::cpp_uno::shared::VtableFactory::addLocalFunctions(
void ** slots, unsigned char * code,
typelib_InterfaceTypeDescription const * type, sal_Int32 nFunctionOffset,
- sal_Int32 functionCount, sal_Int32 nVtableOffset )
+ sal_Int32 /* functionCount */, sal_Int32 nVtableOffset )
@@ -500,7 +500,6 @@
{
(*slots) -= functionCount;
Slot * s = *slots;
-
for ( sal_Int32 nPos = 0; nPos < type->nMembers; ++nPos )
{
typelib_TypeDescription * pTD = 0;
Index: bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx
===================================================================
RCS file: /cvs/udk/bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx,v
retrieving revision 1.4
diff -u -r1.4 except.cxx
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 5 Jul 2007 09:01:44 -0000 1.4
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 8 Jan 2008 16:57:00 -0000
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 12 Apr 2008 00:10:44 -0000
@@ -180,8 +180,8 @@
else
{
@ -55,8 +69,13 @@ Merge from Linux CWS pj87 (#i83022#: Make bridges warning free)
}
}
}
Index: bridges/source/cpp_uno/gcc3_freebsd_x86-64/uno2cpp.cxx
===================================================================
RCS file: /cvs/udk/bridges/source/cpp_uno/gcc3_freebsd_x86-64/uno2cpp.cxx,v
retrieving revision 1.4
diff -u -r1.4 uno2cpp.cxx
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/uno2cpp.cxx 5 Jul 2007 09:02:53 -0000 1.4
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/uno2cpp.cxx 8 Jan 2008 16:57:00 -0000
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/uno2cpp.cxx 12 Apr 2008 00:10:44 -0000
@@ -73,13 +73,13 @@
// Let's figure out what is really going on here
{

View file

@ -0,0 +1,18 @@
Index: binfilter/bf_sw/source/filter/w4w/makefile.mk
===================================================================
RCS file: /cvs/framework/binfilter/bf_sw/source/filter/w4w/makefile.mk,v
retrieving revision 1.9
diff -u -r1.9 makefile.mk
--- binfilter/bf_sw/source/filter/w4w/makefile.mk 20 Nov 2006 12:38:59 -0000 1.9
+++ binfilter/bf_sw/source/filter/w4w/makefile.mk 12 Apr 2008 00:02:49 -0000
@@ -58,6 +58,10 @@
CDEFS=$(CDEFS) -Dmydebug
.ENDIF
+.IF "$(OSL_DEBUG_LEVEL)" > 0
+CDEFS += -DENABLE_BYTESTRING_STREAM_OPERATORS
+.ENDIF
+
# --- Files --------------------------------------------------------
CXXFILES = \

View file

@ -0,0 +1,16 @@
Index: sw/source/core/doc/dbgoutsw.cxx
===================================================================
RCS file: /cvs/sw/sw/source/core/doc/dbgoutsw.cxx,v
retrieving revision 1.23
diff -u -r1.23 dbgoutsw.cxx
--- sw/source/core/doc/dbgoutsw.cxx 19 Feb 2008 13:40:02 -0000 1.23
+++ sw/source/core/doc/dbgoutsw.cxx 12 Apr 2008 00:17:46 -0000
@@ -296,7 +296,7 @@
if (!bFirst)
aStr += String(", ", RTL_TEXTENCODING_ASCII_US);
- if ((sal_uInt32)pItem != 0xffffffff)
+ if (! pItem->IsInvalidItem())
aStr += lcl_dbg_out(*pItem);
else
aStr += String("invalid", RTL_TEXTENCODING_ASCII_US);

View file

@ -1,7 +1,12 @@
Merge from Linux CWS pj87 (#i83022#: Make bridges warning free)
Update to newest cpp-uno bridge from Linux x86-64.
Index: bridges/source/cpp_uno/gcc3_freebsd_x86-64/abi.cxx
===================================================================
RCS file: /cvs/udk/bridges/source/cpp_uno/gcc3_freebsd_x86-64/abi.cxx,v
retrieving revision 1.3
diff -u -r1.3 abi.cxx
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/abi.cxx 16 Sep 2006 15:46:23 -0000 1.3
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/abi.cxx 8 Jan 2008 16:57:00 -0000
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/abi.cxx 12 Apr 2008 00:10:44 -0000
@@ -358,6 +358,8 @@
case X86_64_SSEDF_CLASS:
*pStructAlign++ = *reinterpret_cast<sal_uInt64 *>( *pSSE++ );
@ -11,8 +16,13 @@ Merge from Linux CWS pj87 (#i83022#: Make bridges warning free)
}
}
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/cpp2uno.cxx 16 Sep 2006 15:46:37 -0000 1.3
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/cpp2uno.cxx 8 Jan 2008 16:57:00 -0000
Index: bridges/source/cpp_uno/gcc3_freebsd_x86-64/cpp2uno.cxx
===================================================================
RCS file: /cvs/udk/bridges/source/cpp_uno/gcc3_freebsd_x86-64/cpp2uno.cxx,v
retrieving revision 1.4
diff -u -r1.4 cpp2uno.cxx
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/cpp2uno.cxx 27 Feb 2008 09:49:58 -0000 1.4
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/cpp2uno.cxx 12 Apr 2008 00:10:44 -0000
@@ -82,8 +82,8 @@
void ** gpreg, void ** fpreg, void ** ovrflw,
sal_uInt64 * pRegisterReturn /* space for register return */ )
@ -24,17 +34,21 @@ Merge from Linux CWS pj87 (#i83022#: Make bridges warning free)
// return
typelib_TypeDescription * pReturnTypeDescr = 0;
@@ -492,7 +492,7 @@
unsigned char * bridges::cpp_uno::shared::VtableFactory::addLocalFunctions(
void ** slots, unsigned char * code,
typelib_InterfaceTypeDescription const * type, sal_Int32 nFunctionOffset,
- sal_Int32 functionCount, sal_Int32 nVtableOffset )
+ sal_Int32 /* functionCount */, sal_Int32 nVtableOffset )
@@ -500,7 +500,6 @@
{
(*slots) -= functionCount;
Slot * s = *slots;
-
for ( sal_Int32 nPos = 0; nPos < type->nMembers; ++nPos )
{
typelib_TypeDescription * pTD = 0;
Index: bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx
===================================================================
RCS file: /cvs/udk/bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx,v
retrieving revision 1.4
diff -u -r1.4 except.cxx
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 5 Jul 2007 09:01:44 -0000 1.4
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 8 Jan 2008 16:57:00 -0000
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/except.cxx 12 Apr 2008 00:10:44 -0000
@@ -180,8 +180,8 @@
else
{
@ -55,8 +69,13 @@ Merge from Linux CWS pj87 (#i83022#: Make bridges warning free)
}
}
}
Index: bridges/source/cpp_uno/gcc3_freebsd_x86-64/uno2cpp.cxx
===================================================================
RCS file: /cvs/udk/bridges/source/cpp_uno/gcc3_freebsd_x86-64/uno2cpp.cxx,v
retrieving revision 1.4
diff -u -r1.4 uno2cpp.cxx
--- bridges/source/cpp_uno/gcc3_freebsd_x86-64/uno2cpp.cxx 5 Jul 2007 09:02:53 -0000 1.4
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/uno2cpp.cxx 8 Jan 2008 16:57:00 -0000
+++ bridges/source/cpp_uno/gcc3_freebsd_x86-64/uno2cpp.cxx 12 Apr 2008 00:10:44 -0000
@@ -73,13 +73,13 @@
// Let's figure out what is really going on here
{

View file

@ -0,0 +1,18 @@
Index: binfilter/bf_sw/source/filter/w4w/makefile.mk
===================================================================
RCS file: /cvs/framework/binfilter/bf_sw/source/filter/w4w/makefile.mk,v
retrieving revision 1.9
diff -u -r1.9 makefile.mk
--- binfilter/bf_sw/source/filter/w4w/makefile.mk 20 Nov 2006 12:38:59 -0000 1.9
+++ binfilter/bf_sw/source/filter/w4w/makefile.mk 12 Apr 2008 00:02:49 -0000
@@ -58,6 +58,10 @@
CDEFS=$(CDEFS) -Dmydebug
.ENDIF
+.IF "$(OSL_DEBUG_LEVEL)" > 0
+CDEFS += -DENABLE_BYTESTRING_STREAM_OPERATORS
+.ENDIF
+
# --- Files --------------------------------------------------------
CXXFILES = \

View file

@ -0,0 +1,16 @@
Index: sw/source/core/doc/dbgoutsw.cxx
===================================================================
RCS file: /cvs/sw/sw/source/core/doc/dbgoutsw.cxx,v
retrieving revision 1.23
diff -u -r1.23 dbgoutsw.cxx
--- sw/source/core/doc/dbgoutsw.cxx 19 Feb 2008 13:40:02 -0000 1.23
+++ sw/source/core/doc/dbgoutsw.cxx 12 Apr 2008 00:17:46 -0000
@@ -296,7 +296,7 @@
if (!bFirst)
aStr += String(", ", RTL_TEXTENCODING_ASCII_US);
- if ((sal_uInt32)pItem != 0xffffffff)
+ if (! pItem->IsInvalidItem())
aStr += lcl_dbg_out(*pItem);
else
aStr += String("invalid", RTL_TEXTENCODING_ASCII_US);